locked
The icon of UWP control is not shown in toolbox RRS feed

  • Question

  • I have two UWP controls in two assemblies, please refer to the following for more details.

    1. KWFlexButton inherits from Control and the assembly name is FlexButton.

    2. KWFlexAButton inherits from KWFlexButton and the assembly name is FlexAButton.

    I made two vsix and installed them, I found KWFlexAButton could not be shown in toolbox.

    After I investigated, I guessed vs loaded KWFlexAButton is earlier than KWFlexButton.

    Therefore I tried to change the assembly name of FlexAButton to FlexCButton, I found KWFlexAButton is shown.

    I wonder it is the default behavior of visual studio? Do you any other ideas?

    Monday, June 6, 2016 2:16 PM

All replies

  • I don't attach the sample because it is not difficult to make such demo.

    It is very urgent for me...


    • Edited by minLVwang Monday, June 6, 2016 2:20 PM
    Monday, June 6, 2016 2:18 PM
  • Hi minLVwang,

    >>"I wonder it is the default behavior of visual studio? Do you any other ideas?"

    Yes, it is.

    >>"I have two UWP controls in two assemblies"

    Is KWFlexButton referenced and used by KWFlexAButton? I suggest you create a standalone assembly for KWFlexAButton. So there will be no problem.

    Best Regards,
    Li Wang


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by DotNet Wang Wednesday, June 15, 2016 1:35 AM
    • Unmarked as answer by minLVwang Wednesday, June 15, 2016 3:43 AM
    Tuesday, June 7, 2016 9:39 AM
  • They are standalone assemblies(FlexButton and FlexAButton)

    Please take a look at my question carefully.

    Wednesday, June 15, 2016 3:45 AM