none
Microsoft.Interop.Security.AzRoles registration issue RRS feed

  • Question

  • Hi All,

    I am facing an issue with the Azroles dll when using with a Smart client application. 

    Below is the complete exception:

    Handling instance: fb5809ad-828d-45b6-873a-5dd0d4e65cf5

    Date and time: 30/11/2010 11:47:00

    Machine name: LDSCXA3

    IP Address: 10.160.124.100

    Current User: ITVPLC\AdarSree

    Application Domain: ConMaint.exe

    Assembly codebase: file:///M:/Program Files/Genersys/ConMaint.exe

    Assembly full name: ConMaint, Version=1.0.1130.1, Culture=neutral, PublicKeyToken=null

    Assembly version: 1.0.1130.1

    Assembly Build Date: 30/11/2010 10:01:18

     

    Exception stack trace:

    (Inner Exception)

    Exception Source:      Microsoft.Interop.Security.AzRoles

    Exception Type:        System.Runtime.InteropServices.COMException

    Exception Message:     Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG))

    Exception Target Site: Initialize

     

    (Outer Exception)

    Exception Source:      Microsoft.Practices.EnterpriseLibrary.Security.AzMan

    Exception Type:        System.Security.SecurityException

    Exception Message:     Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG))

    Exception Target Site: CheckAccessOperations

    I have tried un-registering and registering the dll on the deployment server (Windows 2K3) and rebooted the server as well. This step seems to work sometimes, but not always.

    Please advice if anybody has come across this issue.

    Thanks,

    Adarsh

    Tuesday, November 30, 2010 12:27 PM

Answers

All replies