locked
The maximum number of Web Parts for all zones on this page has been exceeded. RRS feed

  • Question

  • Hi All,

    I am getting following error message when making a new view for SharePoint Form Library

    The maximum number of Web Parts for all zones on this page has been exceeded.

     

    Any help in this regard will be greatly appreciated...

    • Moved by Mike Walsh FIN Thursday, May 27, 2010 9:11 AM I don't see any connection to Search in this question. Moving to admin (From:SharePoint - Search (pre-SharePoint 2010))
    Thursday, May 27, 2010 9:03 AM

Answers

  • Please modify the following configration to increase the MaxZoneParts in the web.config for the web application.

    <WebPartLimits MaxZoneParts="50" PropertySize="1048576" />

    Do not forget to restart IIS to make the setting work.
    Sincerely,
    Lambert Qin
    Posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, May 28, 2010 10:03 AM

All replies

  • When you are looking at the page append the following at the end of your URL:  ?contents=1

    Your URL should look something like this:

    http://contoso/site/default.aspx?contents=1

    This will open the web part maintenance page.  How many web parts are listed?  You might have a large number of closed web parts that aren't showing on the page but are actually still there.


    John
    SharePoint911: SharePoint Consulting
    Blog: http://www.rossonmoss.com
    Twitter: JohnRossJr

    MOSS Explained: An Information Workers Deep Dive into Microsoft Office SharePoint Server 2007
    Thursday, May 27, 2010 1:12 PM
  • Hi John D. Ross,

    I have checked that there are only two webparts on the page. I have checked it from Web part maintenance page... Error in my case occurs when i try to create a personal view following error message appears...

    The maximum number of Web Parts for all zones on this page has been exceeded.

     

    Friday, May 28, 2010 5:58 AM
  • Check the page and delete unnecessary webparts. just type url and at the end add ?contents=1 then it will display web part maintance page. There you can see all webparts(Open on page Yes/No).


    Thanks & Regards, Neerubee
    Friday, May 28, 2010 6:02 AM
  • Dear neerubee,

    I have already checked it by adding ?contents=1 at the end of URL. Only two webparts are showing.

    Friday, May 28, 2010 6:17 AM
  • Hi Muhammad,

    So are you trying to add some new webpart in your page, still are you getting The maximum number of Web Parts for all zones on this page has been exceeded error?


    Thanks & Regards, Neerubee
    Friday, May 28, 2010 6:45 AM
  • Dear neerubee,

    I am not adding any new webpart. I am creating a new personal view in existing webpart. If a try to create a personal view i got the error

    The maximum number of Web Parts for all zones on this page has been exceeded error?

    Now as per error description, if i try to see total webparts on my page using the url (http://portal/hr/default.aspx?contents=1). I can see that there are only two weparts on my page.  

    I think this error is due to creating personal view... correct me please if i am wrong...  

    Friday, May 28, 2010 6:58 AM
  • Please modify the following configration to increase the MaxZoneParts in the web.config for the web application.

    <WebPartLimits MaxZoneParts="50" PropertySize="1048576" />

    Do not forget to restart IIS to make the setting work.
    Sincerely,
    Lambert Qin
    Posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, May 28, 2010 10:03 AM
  • Thanks Lambert Qin... 

    Your post helps me in resolving the issue. I have increased MaxZoneParts value from 50 to 100. Now everything works fine

    Monday, May 31, 2010 6:04 AM
  • I just had the same problem, went to the webconfig on the SharePoint Server, changed the 50 to 100, worked like a charm, thanks!

    Taffy


    Working Hard
    Wednesday, July 7, 2010 2:11 PM
  • Thanks Lambert,

    It worked for me as well.

    Tuesday, December 16, 2014 5:22 AM