none
W10 LTSB 2016 and recent updates, UWF on = BSOD.

    General discussion

  • Has anyone else had BSOD's with their LTSB image caused by recent updates?

    So far:

    no updates - uwf works

    2017-11 - last *known* working uwf. 

    ... several of these were not for AMD...

    2018-03 - any, BSOD

    2018-04 - not looking good.

    Since I use UEFI, sometimes I get stuck in the BIOS too, not good at all.

    I've been using this to dig myself out of the hole:

    reboot with winpe


    c:
    cd \windows\system32\config
    reg load hklm\goats SYSTEM
    reg add HKLM\Goats\ControlSet001\Control\Class\{71a27cdd-812a-11d0-bec7-08002be2092f} /v LowerFilters /t REG_MULTI_SZ /d "fvevol\0rdyboost\0iorate\0" /f
    wpeutil reboot

    And you can get back into the OS...


    =^x^=

    Wednesday, April 11, 2018 4:39 AM

All replies

  • Excellent! Someone else is running into the same problem. I ran into the same problem last week with a client. The latest patches break UWF. I think it is the December update.

    What BSOD value do you get at the bottom of the screen? Is it "Bugcode ID Driver"?


    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com


    Wednesday, April 11, 2018 11:47 PM
    Moderator
  • Good old BUGCODE ID DRIVER

    Good morning. I am really surprised it didn't blow up more people. I have reliably BSODded every machine I have with this.

    It's not december. I'm checking them all from a known working image. Current suspect is 4088889 but don't jump to conclusions just yet. I have 7 left to check today.

    ---

    I am now thoroughly mystified, because I just got one 4093119 that doesn't crash messily. Implying that something *else* that I do triggers this failure more with recent ones but not with 4053579.

    I will continue investigating, but now I have a lot more work to do >_<!

    (aside - settings -> update crashes instantly.)


    =^x^=



    • Edited by P 'Bunny' E Thursday, April 12, 2018 6:24 AM
    Thursday, April 12, 2018 12:00 AM
  • The mystery deepens.

    One machine that I killed off somehow, BSOD --> "bios recovery screen!"

    I plugged it in today and it worked the first time. UWF was on and it worked, Imagine my surprise. 

    This would be KB4088787 / .2125

    Then the second time, it exploded and crashed back to the bios screen.

    A different machine, same hw/ different bios works in 4093119.

    In all cases, system settings -> updates  crashes with the same event bug.

    So right now I am pretty mystified. Any ideas?


    =^x^=

    Thursday, April 12, 2018 7:17 AM
  • None. I also have seen the BIOS recovery screen.

    I am going to elevate this through one channel.


    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Friday, April 13, 2018 1:24 AM
    Moderator
  • Are you using AMD or Intel?

    And did you have systemsettings -> update  crash every time?

    (I don't actually use this, but it's another bug.)

    I have done this on both now, today I am starting from scratch >_<!

    A no frills just boot, update and uwf worked yesterday.


    =^x^=

    Friday, April 13, 2018 2:48 AM
  • Built two identical tests on similar hardware today. (AMD SoC) but one 25% faster

    Both failed, which ruled out hardware... I hope ^^;

    Both also fail on SystemSettings -> Update

    This combination is fatal:

    List Updates: 04/13/2018 14:41:34.
    Updates needed:

    KB        RebootRequired Size  LastDeploymentChangeTime Title                                                          
    --        -------------- ----  ------------------------ -----                                                          
    KB4093119          False 1 GB  4/10/2018 12:00:00 AM    2018-04 Cumulative Update for Windows 10 Version 1607 for x6...
    KB890830           False 42 MB 4/10/2018 12:00:00 AM    Windows Malicious Software Removal Tool x64 - April 2018 (KB...
    KB4093110          False 21 MB 4/10/2018 12:00:00 AM    2018-04 Security Update for Adobe Flash Player for Windows 1...
    KB4093137          False 11 MB 4/10/2018 12:00:00 AM    2018-04 Update for Windows 10 Version 1607 for x64-based Sys...

    Download  size: 1297.69 MB.

    -----------------------------------------------------------

    Assuming that UWFVOL is the guilty party, we have

    10.0.14393.2155 (which came from 4088889) March 22

    10.0.14393.2097 (which came from 4077525) Feb 22

    10.0.14393.2034 (which came from 4057142) Jan 17

    10.0.14393.1770 (which came from 4041691) Oct 10 (but not mentioned!)


    =^x^=

    Friday, April 13, 2018 7:47 AM
  • Intel. I did a clean install with no updates and UWF worked just fine. Let updates run and UWF crashes inconsistently but crashes often with the same bugcode

    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Friday, April 13, 2018 11:44 PM
    Moderator
  • Before or after reseal?

    Some incomplete testing last week suggests that before reseal uwf will work even with the latest updates.

    I shall do an before/after today.


    =^x^=

    Monday, April 16, 2018 12:37 AM
  • before and after - yes. The first time I spotted the issue was in a clone image. The i just installed windows 10, installed updates, and enabled UWF - bang BSOD.

    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Monday, April 16, 2018 2:45 PM
    Moderator
  • Do you have a HASP driver of any shape size or form?

    I didn't, it worked.

    Installed the application, BSOD every time

    knobbled it in the registry and now I BSOD after the first reboot


    =^x^=

    Tuesday, April 17, 2018 6:46 AM
  • This is the only forum where I have found others with the same issues that I experience. I started having stop error / bsod with one of the march updates: kb4088786 . I havn't been able to install it without having bsod so I have declined that update in wsus. One month later we have another update causing blue screen: kb4093111. I have an open ticket on this issue with the hardware manufacturer since a month ago, they have escalated this to their third level support. I called them today and asked for status update. They assured me that they are working hard to resolve this issue. Maybe I should have created a ticket to Microsoft instead.   

    • Edited by P atrick Tuesday, April 17, 2018 1:47 PM
    Tuesday, April 17, 2018 10:59 AM
  • You are using W 10 LTSB 2016 I take it.

    Are you doing anything weird? Yesterday I discovered that UWF would work until I installed our application which has a HASP driver in it. 

    (edit, installing python 2.7.11 kills UWF, not the HASP driver at all.)

    Also, a new CU for 2018-04 just came out. I do not expect it to fix the problems.

    https://support.microsoft.com/en-us/help/4093120/windows-10-update-kb4093120

    It does not appear to change the uwfvol driver that crashes though.

    Nor address the crash of systemsettings-> update I am getting.


    =^x^=


    • Edited by P 'Bunny' E Thursday, April 19, 2018 2:34 AM blame python
    Wednesday, April 18, 2018 2:17 AM
  • I'm running Windows 10.0 Enterprise 2015 LTSB Build 10240.

    I even tried disabling UWF and then install patch kb4093111 and kb4088786, I'm not doing anything weird, the image is preinstalled from the manufacturer. Latest bios installed, drivers fully updated. 

    Related?: https://www.theverge.com/2018/4/17/17246170/microsoft-windows-10-april-update-delay


    Wednesday, April 18, 2018 6:47 AM
  • I am running into same issue with LTSB 2015 on AMD Soc based thin client. I can only manage to install kb4077525 with UWF turn off.

    What is the known good Windows CU in your environment with UWF turn on ? Do you install additional UWF hotfix provided by OEM vendor?
    • Edited by nivlacckw Wednesday, April 18, 2018 1:31 PM
    Wednesday, April 18, 2018 1:29 PM
  • I really think that you should consider switching to LTSB 2016, but another couple of months and we'll have to do it all over again for LTSB 2018.

    I to have an AMD SOC, in fact I have prarie falcon, merlin falcon and bald eagle. One image works on them all.

    The last updates I had that worked reliably on it were: (LTSB 2016 =~ W10 1607)

    KB

    Size

    Title

    KB4049065

    11 M

    2017-11 Update for Windows 10 Version 1607 for x64-based Systems (KB4049065)

    KB4053579

    1 G

    2017-12 Cumulative Update for Windows 10 Version 1607 for x64-based Systems (KB4053579)

    KB4056887

    21 M

    2018-01 Security Update for Adobe Flash Player for Windows 10 Version 1607 for x64-based Systems (KB4056887)

    KB890830

    38 M

    Windows Malicious Software Removal Tool for Windows 8, 8.1, 10 and Windows Server 2012, 2012 R2, 2016 x64 Edition...

    After that, 2017-12, 2018-01, 2018-02 refused to play, and 2018-03 broke it.

    UWF should not be "ON" when updating your image. Either use servicing mode or disable it before-hand. 


    =^x^=

    Thursday, April 19, 2018 2:27 AM
  • Remember, UWF should be off (or use servicing mode) when updating the OS. It will just make an unholy mess otherwise because unlike EWF, there is no "commit all" option.

    I do not think that the verge url is related no. That is likely for the latest and grated cheesiest feature update.

    Feature updates are not for LTSB at all, just like Cortana isn't really there either (she is though)


    =^x^=

    Thursday, April 19, 2018 2:37 AM
  • I sent a contact at Microsoft a memory.dmp file for the crash. Have no idea if they will look at it. Took some doing to reconfigure the system to get the dump file.

    On the same system, I re-installed the Windows 10 Enterprise LTSB 2016 and let the updates run. Enabled UWF - and there was no crash. So either the issue has been spotted and addressed, or this is really a hard to find bug.

    Can you retry a clean install and windows updates, and then try UWF again?


    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Thursday, April 19, 2018 4:16 PM
    Moderator
  • Thank you, LTSB 2018 in fact is the reason why we want to stay with LTSB 2015 for a few months more. We have a mix of Intel/AMD Soc and we are still in the process of narrowing down the possibilities.

    Would like to see uwf HORM mode again in LTSB, a long lost since windows 8 embedded
    • Edited by nivlacckw Saturday, April 21, 2018 5:01 AM
    Thursday, April 19, 2018 6:28 PM
  • May I know your Soc and the list of update on a fresh LTSB 2016 system?

    • Edited by nivlacckw Thursday, April 19, 2018 7:15 PM
    Thursday, April 19, 2018 6:30 PM
  • Intel Core m3-7y30

    For the image that is working:

    KB4093137
    KB890830
    KB4033631
    KB4049411

    For the image that is crashing:

    KB4088787
    KB4049411
    KB4033631
    KB4049065

    checking the catalog - KB4049065 - replaced by KB4093137

    Interesting we are not seeing the same updates. also, I am only seeing 10.0.14393 and no subversion on the image that is crashing. 


    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Thursday, April 19, 2018 7:39 PM
    Moderator
  • Please check if settings --> update crashes too. 



    =^x^=

    Friday, April 20, 2018 2:32 AM
  • I have several. Current testing is on an R-series Merlin Falcon. with 8Gb of ram and a 64Gb mSATA. THere is also a G-Series Prarie Falcon that dies when tested and another one that is a R-series Bald Eagle.

    • 4093137
    • 4093119
    • 4093110
    • 890830

    In general this works, excepting the "Settings --> update" crashing instantly. (I use powershell for updates anyway but this worries me.)

    I do not have 4033631 on my list. 

    A known working image that would not crash had:

    • 4049065
    • 4053579
    • 4056887
    • 890830

    On the same hardware, same bios.

    I found that installing python 2.7.11 from our application alone was enough to kill UWF every single time across 3 machines.


    =^x^=

    Friday, April 20, 2018 2:40 AM
  • I am hoping 2018 will be better yes. Not much news as to whether it will actually be embedded worthy or whether we'll still have to eviscerate cortana and friends.

    I script everything, so AMD or Intel it doesn't matter, 90% of my image will be the same.

    I'm partial to iBASE for hardware too...


    =^x^=

    Friday, April 20, 2018 2:50 AM
  • This morning I had the same problem, but it miraculously came back to life after it cycled a dozen times or so. WTF?

    I have also been seeing this problem for a while (I'm not great at documenting which KBs are responsible though.)

    Today I enabled UWF on a machine I had been using as a reference unit, and... BSOD. While preparing an email , and reading through this forum I let it continue cycling (Post, Boot...BSOD with STOP CODE and mention of "Bugcode ID Driver", Post, Boot, BSOD... Post, Boot, BSOD.... a dozen times more... and finally Post, Boot, Login screen!)

    <rant> I thought we used computers because they were supposed to be repeatable.  I also thought the whole point of Windows 10 IoT Enterprise 1607 was that this type of things was not going to happen. "Only security updates are applied to that build." - Salesman. It appears I was "brochured".
    On top of all this the Servicing Mode doesn't work!? I seriously expected more from Microsoft. </rant>

    After successfully logging on it shows I still have some updates to apply:

    KB2267602 (Windows Defender Antivirus)

    KB4052623 (Windows Defender Antivirus anitmalware platform)

    Update History shows:

    2018-04 Cumulative Update for Windows 10 Version 1607 for x64-based System (KB4093120)
    Successfully Installed on 4/20/2018
    2018-04 Security Update for Adobe Flash Player for Windows 10 Version 1607 for x64-based Systems (KB4093110)
    Successfully Installed on 4/20/2018
    Windows Malicious Software Removal Tool x64 - April 2018 (KB890830)
    Successfully Installed on 4/20/2018
    2018-04 Update for Windows 10 Version 1607 for x64-based Systems (KB4093137)
    Successfully Installed on 4/20/2018
    2018-04 Cumulative Update for Windows 10 Version 1607 for x-64-based Systems (KB4093119)
    Successfully Installed on 4/20/2018

    So:

    A) I think in my case this problem stems 2018-04 Windows Updates (and similar in the past)

    B) I needed to reboot "one more time" after applying Windows Updates prior to enabling the UWF.

    After this I disabled UWF, rebooted, installed updates, rebooted, rebooted, enabled UWF, rebooted and rebooted. It is now functioning as it was last week before the BSOD.

    The good news in this case, is that this embedded PC seems to be stable one again.

    Sadly I have no idea why or how it came back to life after cycling with so many BSODs, while the UWF was enabled (registry or other values shouldn't have been changing). After the BSOD and dozen reboots it came back to life with UWF still enabled (surprised me at least).


    • Edited by MWatchorn Monday, April 30, 2018 6:22 PM
    Monday, April 30, 2018 6:21 PM
  • KB4093120 is the latest cumulative update - https://www.microsoft.com/en-us/itpro/windows-10/release-information. I suggest downloading the KB MSU file and install with the OS. Then run Windows update. When I did this I didn't hit the BSOD when enabling UWF. at least so far I have not seen it.


    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Monday, April 30, 2018 7:20 PM
    Moderator
  • Would it do any better if injecting April update MSU to WIM ?

    One week to go for May update, will see if this will be improved

    Tuesday, May 1, 2018 12:13 PM
  • Same here, we have AMD/Intel CPU'S so it's hardware independent... it seems to be healing itself sometimes after a couple of reboots.

    I have not yet tested with a 32bit OS, does anybody got the BSOD also with a 32bit build ?


    Tuesday, May 1, 2018 2:08 PM
  • I have only seen this in 64-bit

    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Tuesday, May 1, 2018 3:41 PM
    Moderator
  • Okay, did you know that KB4093120 solve the issues, or is this just your best guess (nothing mentioned in the changelog).

    Is Microsoft aware of this issue or do I need to open another case to let them working (hopefully) on that ?


    Tuesday, May 1, 2018 4:55 PM
  • Not sure if KB4093120 solve the issues, but I have not seen the issue since installing it. I would like others who are running into this problem, repeat what I did to verify.

    I did raise the issue to Microsoft and provided data, but I sent the information in as an MVP to the product team. No ticket was submitted. I have not heard back if they are looking into this. If the issue is not resolved, then I suggest everyone open a ticket to get visibility with Microsoft. 


    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Tuesday, May 1, 2018 7:35 PM
    Moderator
  • Well, we are here on 14393.2214 and the BSOD is still there (on AMD CPU ), so i don't belive KB4093120 will fix that
    Wednesday, May 2, 2018 11:21 AM
  • I read in another forums thread that the issues started once they add some file/registry exclusions... can somebody confirm that or does it happend even without any exclusion ?
    Wednesday, May 2, 2018 3:19 PM
  • Happens without the exclusions.

    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Wednesday, May 2, 2018 8:03 PM
    Moderator
  • Case opened with MS , bug confirmed and they are fixing that.
    Sunday, May 6, 2018 9:13 AM
  • I had to go back to 2017-12 (.1944) to get it to work.

    In my case, the fatal step is installing python 2.7.11, 

    turning on UWF after that, BSOD. AMD or Intel too.

    There is a case open internally that I don't have access to, it might be the same one as Sean Liming has.


    =^x^=

    Monday, May 7, 2018 3:32 AM
  • I also open a Case and wait for feedback... same here all plattform's Intel + AMD failed with 14393.2214, no Python or any other installation needed, but I need to add 1-2 exclusion to get the BSOD on the next boot...
    Monday, May 7, 2018 7:02 AM
  • Anyone tested May windows update? Any improvement noticed?
    Saturday, May 12, 2018 2:39 PM
  • I don't belive the fix is in the May update, nothing mentioned in the release notes. I received last week a fix for testing and it works for me, I'm waiting now for the official fix...
    Sunday, May 13, 2018 11:35 AM
  • I got the same testing patch as well. I am told it will be in June fix. Cross reference with the OEM hardware vendor Windows IOT OS restore tool, it only allows download windows update up to Feb 2018


    • Edited by nivlacckw Wednesday, May 16, 2018 7:48 AM
    Sunday, May 13, 2018 4:15 PM
  • What I was told was "maybe June #2 ..." 

    So very much wait and see, and a warning to our users not to update >_<!


    =^x^=

    Wednesday, May 16, 2018 6:04 AM
  • 1507 LTSB out for almost 3 years and no stable UWF still

    Wednesday, May 16, 2018 7:51 AM
  • We tested it with the June Update from yesterday, but still not working. Is it fixed by anyone with the june update?


    There is also Nothing in the release notes.
    • Edited by flyingwefa Wednesday, June 13, 2018 7:24 AM edit
    Wednesday, June 13, 2018 7:22 AM
  • There is a new update   2018-06 KB 4284880 (you also need KB4132216) that claims to fix a UWF crash.

    As of now, it's running on a system that would previously have died. So I think it's fixed.


    =^x^=

    Wednesday, June 13, 2018 7:41 AM
  • We tested it with the June Update from yesterday, but still not working. Is it fixed by anyone with the june update?


    There is also Nothing in the release notes.

    https://support.microsoft.com/en-us/help/4284880

    This should be the issue :

    Addresses an issue where booting with Unified Write Filter and a connected USB hub may lead to stop error E1. 


    EDIT : And I can confirm it works for us (1607 , OS Build 14393.2312 )
    Wednesday, June 13, 2018 9:38 AM
  • Thanks now it works with LTSB 2016. but with Windows 10 1803 i have the same Problems. and i cant install the updates because they are only for 1607. Doe you have any idea?

    Wednesday, June 13, 2018 12:46 PM
  • From the release notes it seems to be only fixed in 1607 and 1703, so you would need to open a new call at Microsoft if you would like to see that in the 1803 version...
    Wednesday, June 13, 2018 2:37 PM
  • 1507 also fixed, we have a case with MS to confirm this
    Saturday, June 16, 2018 9:20 AM
  • c:\Windows\BootStat.dat exclusion causing “Blue Screens Of Death” (BSOD) in our environment. Windows 10 1607, 1709, and LTSC 2019 - Error “SYSTEM THREAD EXCEPTION NOT HANDLED” uwfs.sys

    I’ve removed “c:\Windows\BootStat.dat from the exclusions list, and the Thin Client reboots happily with the UWF on or off 😊 😊 😊 😊

    Friday, January 11, 2019 12:07 PM
  • Thank you! I had the same problem and this fixed it!!!

    Jim

    Tuesday, April 2, 2019 2:02 PM
  • Does anybody have the same Problem now with LTSC 2019 without an exclusion of the bootstat.dat?
    Thursday, May 2, 2019 1:49 PM
  • I ran into a simialr problem with a different exclusion. In conversation with Microsoft, there has been some changes with UWF, but they seem to be a lack of forthcoming information until we run into problems.

    bootstat.dat cannot be excluded in UWF.. You can remove the file if you want too.


    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Thursday, May 2, 2019 9:54 PM
    Moderator