locked
Old ASPMail component with PGP options on Windows 2012R2 / IIS 8.5 server RRS feed

  • Question

  • User1756538050 posted

    I have an old ASP site using ASPMail component to construct and e-mail form results using PGP encryption. Everything works, except the point when the Mailer needs to run the pgp.exe and encrypt the text file. I can run the same code in PowerShell window, and it works flawlessly - it creates the encrypted file and deletes the original text file. Moreover, the ASPMail object works fine after that - it just doesn't run that PGP.EXE program automatically within the ASP page like it did before.

    The point in the ASP code where it gets stuck looks like this:
    Mailer.PGPPath = "C:\PGP\PGP.exe"
    Mailer.PGPParams = "-e -a -w C:\PGP\TMP\message.txt -u Webmaster"

    ..and after I run this command in PowerShell - "pgp.exe -e -a -w C:\PGP\TMP\message.txt -u Webmaster"  the next line of code starts working:

    if Mailer.GetBodyTextFromFile("C:\PGP\TMP\message.txt.asc", true, false)

    ..and the Mailer sends the encrypted E-mail message just fine.

    The are no error messages of any kind, and I already checked all the permissions and tried just about everything. It seems like for some reason the ASPMail server object lost ability to execute command line programs in IIS 8.

    Monday, August 18, 2014 3:30 AM

All replies

  • User1183424175 posted

    Hi,

    I suggest that you can try enabling "anonymous authentication" and set "local system" as the application pool identity who has high privileges on the filesystem, including Execute permissions.

    For more information, you can refer here

    http://forums.iis.net/p/1193937/2037828.aspx?+BAT+and+vbs+Files+does+not+run+anymore+from+Classic+ASP+was+running+on+Win+2003+Server+

    #asp run photoshap(just refer to the setting)

    http://stackoverflow.com/questions/14532048/trying-to-launch-photoshop-with-scripting/14555053#14555053

    Hope it can help you.

    Monday, August 18, 2014 10:46 PM
  • User1756538050 posted

    I followed your suggestions, and changed the site's and application pool's settings as directed -- with the same result - it still DOES NOT work.

    Friday, September 26, 2014 11:31 AM
  • User1756538050 posted

    This problem still exists with no explanation or even errors from IIS / Windows OS -- I can run the same command line in a .bat or .cmd file successfully, but not from Classic ASP page where it worked fine for many years until now.

    Thursday, December 4, 2014 4:53 PM
  • User1176107588 posted

    hi , understand it's old thread !

    i have the same issue , is this being resolved ?? please HELP 

    i am having the same issue, i enabled detailed error and still don't get any eror desc except 500 , checked logs , no luck .

    can someone update or help resolving this for good . thanks in advance !

    Saturday, January 17, 2015 8:57 AM
  • User1756538050 posted

    I finally managed to get it to work, basically making ASPMail run as a service under LocalSystem account.

    Friday, February 6, 2015 1:39 PM