locked
Images do not display in report using ASP.NET 4.5 web projects RRS feed

  • Question

  • User-2100645920 posted

    Hi, I am trying to display an image in the report's header, using Visual Studio 2013 Update 4 and CRforVS SP 12.

    The report looks fine in the developer while creating it, showing data as well as images.

    When I try to see the web page with the report (using IIS Express), I can see the report with data but the image is represented by its Alt text (image).

    I tried many suggestions from the SAP forum but nothing worked for me.

    Then I created a new web application targeting .NET 4.0 Framework, and it worked normally, showing both data and images in the web browser.

    The only thing I had to do in both ASP.NET versions (4.5 and 4.0) is adding in the application folder the "aspnet_client" folder found in "inetpub\wwwroot".

    What should I change in ASP.NET 4.5 projects to show an image in the reports?

    Thanks

    Monday, December 29, 2014 9:18 AM

Answers

  • User-2100645920 posted

    I don't know why when I applied one of the tips suggested in the SAP forum it did not work, while today it is working and solving this problem.

    It seems that this problem is due to an incompatibility between OWIN and CrystalImageHandler

    The temporary walkaround suggested is to comment one line in the RouteConfig.cs found in the App_Start folder of the project, as showed below:

                //settings.AutoRedirectMode = RedirectMode.Permanent;


    There are other tips suggested, but in my case only commenting that line of code solved the problem.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, January 5, 2015 1:56 AM