locked
Crystal Reports multiple columns RRS feed

  • Question

  • Please excuse the post if this is the wrong forum ...

    I want the Crystal Report (VS 2008) to have 2 columns on a single page (in landscape mode), with identical vertical sizes

    [ ------ column 1 ------ ]    [ ------ column 2 ------]
      details for day 1                details for day 4

    [ ------ column 1 ------ ]    [ ------ column 2 ------]
      details for day 2                details for day 5

    The size allotted for each "day" should be the same. Hopefully I will be able to get 7 days worth of data on a single page.

    Is this possible? or should I think of a different method to use?

    Thanks,
    T
    • Moved by CoolDadTxModerator Wednesday, October 14, 2009 2:31 PM CR related (From:Visual C# General)
    Wednesday, October 14, 2009 1:13 PM

Answers

  • Is it just me being tetchy today or are there a lot of questions that could be answered by pressing the help button?

    I did a search for columns in the crystal help file:

    Multiple columns

    Instead of having your data print straight down the page, you can set up multiple columns and have the data flow from column to column.

    To create a multiple-column report
    1. Open the report you want to format with multiple columns.
    2. On the Report menu, click Section Expert.

      Tip:     Another way to do this is to click the Section Expert button on the Expert Tools toolbar.

    3. In the Section Expert, highlight Details, and then select Format with Multiple Columns.

      A Layout tab is added to the Section Expert.

    4. Click the Layout tab and set the Width you want your column to be.

      Keep in mind the width of your paper when deciding your column width. For example, if you have three fields in your Details section, and they take up four inches of space, limit the width of the column to under four and a half inches so that all the field information can be seen.

    5. Set the Horizontal and/or Vertical gap you want to maintain between each record in your column.
    6. In the Printing Direction area, choose a direction.
    7. If the report you're formatting contains grouping, select Format Groups with multiple column.
    8. Click OK.

    When you preview the report, you'll see that the field headers appear only for the first column. To have field headers for the second column, insert a text object.

    Regards

    Rupert


    the problem is not what you don't know it's what you think you know that's wrong
    • Marked as answer by tarne Monday, December 7, 2009 4:47 PM
    Thursday, October 29, 2009 5:14 PM

All replies

  • Is it just me being tetchy today or are there a lot of questions that could be answered by pressing the help button?

    I did a search for columns in the crystal help file:

    Multiple columns

    Instead of having your data print straight down the page, you can set up multiple columns and have the data flow from column to column.

    To create a multiple-column report
    1. Open the report you want to format with multiple columns.
    2. On the Report menu, click Section Expert.

      Tip:     Another way to do this is to click the Section Expert button on the Expert Tools toolbar.

    3. In the Section Expert, highlight Details, and then select Format with Multiple Columns.

      A Layout tab is added to the Section Expert.

    4. Click the Layout tab and set the Width you want your column to be.

      Keep in mind the width of your paper when deciding your column width. For example, if you have three fields in your Details section, and they take up four inches of space, limit the width of the column to under four and a half inches so that all the field information can be seen.

    5. Set the Horizontal and/or Vertical gap you want to maintain between each record in your column.
    6. In the Printing Direction area, choose a direction.
    7. If the report you're formatting contains grouping, select Format Groups with multiple column.
    8. Click OK.

    When you preview the report, you'll see that the field headers appear only for the first column. To have field headers for the second column, insert a text object.

    Regards

    Rupert


    the problem is not what you don't know it's what you think you know that's wrong
    • Marked as answer by tarne Monday, December 7, 2009 4:47 PM
    Thursday, October 29, 2009 5:14 PM
  • Rupert, what a ____! You didn't even read my question, you just assumed it had to do with "stock" multiple columns in Crystal Reports. Next time, take the small amount of time to read the question, and formulate an answer based on that.

    Thursday, October 29, 2009 7:12 PM
  • tame,

    Point taken, and I was being tetcy that day, I did say...


    But the answer is still the same, if you want to format data over two columns down and accross the page then use the columns above.
    The fixed distance for each entry is determined by the height of the section and will not vary.
    Therefore if you judge your height correctly it will print each "day" the same height and print 4 groups to the page (8 records)

    If you group the data by date and weekly then set a page throw after the group, then it will print 7 days per page assuming you get the sizing right (4 groups per page/8 records).

    I haven't yet thought of a way to get it to do 3 then 4 down the page, but I'm sure there is a way after a few moments thought.

    Regards

    Rupert

    the problem is not what you don't know it's what you think you know that's wrong
    Monday, November 9, 2009 1:59 PM
  • I have done these steps, and my report still won't flow into multiple columns.  My situation is:

    • My report, which is configured for a standard page size of 8.5 by 11, in portrait mode, with .25 inch margins all the way around, contains a subreport in one of it's report footer sections
    • The sub report has a report header, details, and a report footer
    • The details section of the sub report has the "Format with Multiple Columns" checkbox checked, and the width in the layout tab is set at 3.875 inches and the printing direction is set to "Across then Down"

    The sub report prints in a single column, with approximately 4 inches of blank space to the right of it.  The data I am feeding to the sub report contains 3 fields: name, age, and status.

    What am I doing wrong?

    Thursday, February 17, 2011 7:57 PM