none
Installing latest small basic version problems. RRS feed

  • Question

  • Hi I been  trying to install the latest version of small basic but it will not install.

    Every time i try it  says you already got a version of small basic on you computer please go into  control panel and add/remove programs but when i try and find the program it is no where to be found.

     

    I have windows 7 

    Please help THANKS.

    Monday, March 14, 2011 5:03 PM

Answers

  • You could try using a restore point if you have one before you deleted the old version - I assume you didn't uninstall it, but just deleted it somehow, hence the problem that something in the registry thinks it is still installed.

    I uploaded a zip of the exe and dlls (contents of the installation directory I have) if you want here , not certain this would work (probably would) and certainly won't solve the problem for future releases.  Perhaps when a new version comes we could try to contact MS to find out exactly what is needed to be done to the registry - I could make a good guess, but honestly your reluctance is sensible.

     

    Tuesday, March 15, 2011 8:41 PM
    Moderator

All replies

  • On windows 7 to be sure it is not installed already, try:
    Start=>Programs and Features

    List by name, then look for 'Microsoft Small Basic'

    If it is there, then uninstall it.

    If it is not listed here, then go to the previous installation place, probably C:\Program Files (x86)\Microsoft\Small Basic or C:\Program Files\Microsoft\Small Basic.

    Delete everything in this directory (and the directory if you like) - if you have a lib folder for extensions then copy this somewhere safe first - you will need new extension dlls anyway for each new version of Small Basic, so you could just take a note of what you have and delete the lib directory.

    Then try the re-install.

    Monday, March 14, 2011 6:39 PM
    Moderator
  • Nothing is working at all.

     

    Nothing to unstall and i deleted the  folder and tried restalling and is not working something werid is going on.

    Monday, March 14, 2011 6:55 PM
  • I assume you have done a reboot.  Was the old one working (which version was it) before you tried the re-install - was there anything else unusual that happened - PC crash etc, in which case using a restore point may help restore to a condition that was good.  It is possible the downloaded msi is corrupted - you could download it again.  Beyond these rather obvious things you have probably tried I don't have much idea apart from very carefully deleting references to SmallBasic in the registry that is possibly indicating you have an installed version. Unless you are very sure what you are doing and backup the registry first e.g. with a restore point I wouldn't touch the registry - you could easily go from no Small Basic to NO PC!
    Monday, March 14, 2011 7:57 PM
    Moderator
  • Nope just nothing at all.

     

    All i did was delete the old version (Because it was not showing up in the programs list) and then install the new version (Which will not install because it says there is a old version install like i said above).

     

    Is there a .exe file or a zip file that i can download instead it may make it allot easier if not it does not matter.

     

    Also i would not touch anything to do with the resighty or anything because knowing me i may just brake something.

    P.S It was version 0.70 or something like that i have tried redownloading and all the other things you said which are the basic things i would do anyway.
    • Edited by klimyriad Tuesday, March 15, 2011 8:02 PM Putting in more info
    Tuesday, March 15, 2011 7:55 PM
  • You could try using a restore point if you have one before you deleted the old version - I assume you didn't uninstall it, but just deleted it somehow, hence the problem that something in the registry thinks it is still installed.

    I uploaded a zip of the exe and dlls (contents of the installation directory I have) if you want here , not certain this would work (probably would) and certainly won't solve the problem for future releases.  Perhaps when a new version comes we could try to contact MS to find out exactly what is needed to be done to the registry - I could make a good guess, but honestly your reluctance is sensible.

     

    Tuesday, March 15, 2011 8:41 PM
    Moderator
  • Thanks for that zip file it working.

     

    I did try and unstall it but i could not because it was not in the Programs and Features so i had to delete it.

     

    I will contact ms to get it sorted when i have chance.

     

    Thanks for your help if you got any other ideas please do tell me them.

     

    Thanks

    Klimyriad


    Wednesday, March 16, 2011 8:36 PM