locked
Build succeeded but still shows as failed. RRS feed

  • Question

  • User-1151899654 posted

     I am able to run a build successfully on just the web site, but when i add the deployment project it shows failed (see below) but in the details it says build succeeded for the WDP build portion...so I am stumped as to by I am getting a failure. any ideas? I have set the build output to "Diagnostic" and dont see any failures or errors...so is there anything else i can do to find the problem?

     

    Build succeeded.

    Time Elapsed 00:00:21.71
    ------ Skipped Rebuild All: Project: AdminToolHelp, Configuration: Debug Any CPU ------
    Project not selected to build for this solution configuration
    ========== Rebuild All: 1 succeeded, 1 failed, 1 skipped ==========

    Monday, April 14, 2008 2:12 PM

Answers

  • User2100964097 posted

    My Web Deployment Project used to compile without a problem, however, after installing the Visual Studio 2008 SDK I now get the same error.  Everything looks ok but the output reports the "failed" message. 

    Is there some setting that the SDK changes?

    Any information would be appreciated, but I will investigate further.

    UPDATE:
    I have now removed the VS 2008 SDK and now the Web Deployment Project compiles without any problems.  This is a bit of a problem as I need both WDP and SDK.

    Anyone else with this problem? 


    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, May 4, 2008 7:30 PM

All replies

  • User-592590055 posted

    Have a look in the Configuration Manager and see which projects are being built. The documentation says not to build both your webapp and deployment app. It also says not to build your deployment app on debug.

    Tuesday, April 15, 2008 11:42 AM
  • User-1151899654 posted

     I tried what you suggested, but it looks like i am still getting the same error, see below. This time it is on the release build and only the deployment project is selected...any other ideas? thanks.

    Build succeeded.

    Time Elapsed 00:00:10.45
    ------ Skipped Build: Project: AdminToolHelp, Configuration: Release Any CPU ------
    Project not selected to build for this solution configuration
    ========== Build: 0 succeeded or up-to-date, 1 failed, 2 skipped ==========


     

    Tuesday, April 15, 2008 12:34 PM
  • User-592590055 posted

    does the project build outside of the deployment project? i.e. if it were just in a solution on it's own? if so, this should narrow down the problem to the deployment project. 

    Wednesday, April 16, 2008 3:58 AM
  • User-1151899654 posted

    Well i copied the web folder to a new location, opened the web site in VS and the build succeeded. Then I added a new deployment project to it, didnt modify any aspect of it, just ran the build...and got the same error:

    Build succeeded.

    Time Elapsed 00:00:31.42
    ========== Build: 1 succeeded or up-to-date, 1 failed, 0 skipped ==========

     

    i can post the full build log if you think that might help answer some questions...i just didnt want to add something that big if i didnt need to...let me know

    Thanks for the help.
     

    Wednesday, April 16, 2008 12:24 PM
  • User372121194 posted

    Hi,

    If we create a simple test website in new solution and add a web deployment project, does it have the same issue?

    Are there three projects in your solution, including deploy project? If we build the project one by one, does it have the issue? We need to make sure that every project can be built successfully.

    Do they have dependence? If so, we need to build the dependence project while building.

    You can try to configure which project is built or skipped while release or debug building.

    If this doesn’t help you, please feel free to let me know or post the build log here.


    I hope this helps.

    Thursday, April 17, 2008 1:39 AM
  • User-1151899654 posted

    well i opened a new fresh clean web site in vs 2008 with no changes, then i added a wdp...then tried the build. first building just the website...succeeded, then just the wdp...failed...then build both, website succeeded and the wdp failed...here is the build log from just building the wdp:

     ------ Skipped Build: Project: test, Configuration: Release Any CPU ------
    Project not selected to build for this solution configuration
    ------ Build started: Project: test.csproj_deploy, Configuration: Release Any CPU ------
    Build started 4/17/2008 11:30:17 AM.
    Initial Properties:
    _AspNetCompilerSourceWebPath   = @(_SourceWebPathItem->'%(FullPath)')
    _AspNetCompilerVirtualPath     = /test.csproj
    _Force                         = true
    _FullSourceWebDir              = @(_SourceWebPathItem->'%(FullPath)')
    ALLUSERSPROFILE                = C:\Documents and Settings\All Users
    APPDATA                        = C:\Documents and Settings\tphillips\Application Data
    AvailablePlatforms             = Any CPU
    BuildDependsOn                 =
              _PrepareForBuild;
              _SplitProjectReferencesByType;
              _ResolveReferences;
              _ResolveProjectReferences;
              ResolveAssemblyReferences;
              _CopyBeforeBuild;
              BeforeBuild;
              AspNetCompiler;
              BeforeMerge;
              AspNetMerge;
              AfterMerge;
              CopyToOutputDir;
              ReplaceWebConfigSections;
              CreateVirtualDirectory;
              AfterBuild
            
    BuildingInsideVisualStudio     = true
    BuildingProject                = true
    CLASSPATH                      = .;C:\Program Files\Java\jre1.5.0_06\lib\ext\QTJava.zip
    CommonProgramFiles             = C:\Program Files\Common Files
    COMPUTERNAME                   = TPHILLIPS2-XP
    ComSpec                        = C:\WINDOWS\system32\cmd.exe
    ConfigReplaceDependsOn         =
                _PrepareForBuild;
                AspNetCompiler;
                AspNetMerge;
            
    Configuration                  = Release
    CopyBeforeBuildTargetPath      = C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Source
    DebugSymbols                   = false
    DevEnvDir                      = C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\
    DXROOT                         = C:\Program Files\Sandcastle\
    EnableUpdateable               = true
    FP_NO_HOST_CHECK               = NO
    Framework20Dir                 = @(_TargetFramework20DirectoryItem)
    Framework30Dir                 = @(_TargetFramework30DirectoryItem)
    Framework35Dir                 = @(_TargetFramework35DirectoryItem)
    FrameworkDir                   = @(_TargetFramework20DirectoryItem)
    FrameworkSDKDir                = @(_TargetFrameworkSDKDirectoryItem)
    FxCopDir                       =
    GetFrameworkPathsDependsOn     =
    GetRedistListsDependsOn        =
          GetFrameworkPaths
        
    HOMEDRIVE                      = F:
    HOMEPATH                       = \
    HOMESHARE                      = \\svr-ca-fs2\home\tphillips
    LOGONSERVER                    = \\SVR-CA-DC1
    MergeDependsOn                 =
              GetFrameworkPaths;
              _PrepareForBuild;
              AspNetCompiler;
              GenerateAssemblyInfo;
            
    MSBuildBinPath                 = C:\WINDOWS\Microsoft.NET\Framework\v3.5
    MSBuildExtensionsPath          = C:\Program Files\MSBuild
    MSBuildExtensionsPath32        = C:\Program Files\MSBuild
    MSBuildNodeCount               = 1
    MSBuildProjectDefaultTargets   = Build
    MSBuildProjectDirectory        = C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy
    MSBuildProjectDirectoryNoRoot  = Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy
    MSBuildProjectExtension        = .wdproj
    MSBuildProjectFile             = test.csproj_deploy.wdproj
    MSBuildProjectFullPath         = C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\test.csproj_deploy.wdproj
    MSBuildProjectName             = test.csproj_deploy
    MSBuildStartupDirectory        = C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE
    MSBuildToolsPath               = C:\WINDOWS\Microsoft.NET\Framework\v3.5
    MSBuildToolsVersion            = 3.5
    NUMBER_OF_PROCESSORS           = 2
    OS                             = Windows_NT
    OutputPath                     = .\Release\
    Path                           = C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\NTRU Cryptosystems\NTRU TCG Software Stack\bin\;C:\Program Files\Wave Systems Corp\Gemalto\Access Client\v5\;C:\Program Files\Gemplus\GemSafe Libraries\BIN;C:\Program Files\Common Files\Roxio Shared\DLLShared\;c:\Program Files\Microsoft SQL Server\90\Tools\binn\;c:\Program Files\Microsoft SQL Server\80\Tools\Binn\;C:\Program Files\Sandcastle\ProductionTools\;C:\Program Files\QuickTime\QTSystem\;C:\Program Files\Microsoft Visual Studio 2008 SDK\VisualStudioIntegration\Tools\Sandcastle\ProductionTools\
    PATHEXT                        = .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
    Platform                       = AnyCPU
    PrecompDependsOn               =
            _PrepareForBuild;
          
    PROCESSOR_ARCHITECTURE         = x86
    PROCESSOR_IDENTIFIER           = x86 Family 6 Model 15 Stepping 11, GenuineIntel
    PROCESSOR_LEVEL                = 6
    PROCESSOR_REVISION             = 0f0b
    ProductVersion                 = 9.0.21022
    ProgramFiles                   = C:\Program Files
    ProjectGuid                    = {00000000-0000-0000-0000-000000000000}
    QTJAVA                         = C:\Program Files\Java\jre1.5.0_06\lib\ext\QTJava.zip
    ResolveAssemblyReferencesDependsOn =
          GetFrameworkPaths;
          GetRedistLists;
          _PrepareForBuild
        
    RoxioCentral                   = C:\Program Files\Common Files\Roxio Shared\9.0\Roxio Central33\
    RunCodeAnalysisOnce            = FALSE
    SchemaVersion                  = 2.0
    SESSIONNAME                    = Console
    SingleAssemblyName             = test.csproj_deploy
    SolutionDir                    = C:\Documents and Settings\tphillips\My Documents\Temp\newsite\test\
    SolutionExt                    =
    SolutionFileName               =
    SolutionName                   =
    SolutionPath                   = C:\Documents and Settings\tphillips\My Documents\Temp\newsite\test\
    SourceWebPhysicalPath          = ..\..\test
    SourceWebProject               = {E93769AE-9B6D-4BC7-8013-9C6894445932}|test.csproj
    SourceWebVirtualPath           = /test.csproj
    SystemDrive                    = C:
    SystemRoot                     = C:\WINDOWS
    TargetFrameworkVersion         = v3.5
    TEMP                           = C:\DOCUME~1\TPHILL~1\LOCALS~1\Temp
    TMP                            = C:\DOCUME~1\TPHILL~1\LOCALS~1\Temp
    UseMerge                       = true
    USERDNSDOMAIN                  = ATG.LC
    USERDOMAIN                     = ATG
    USERNAME                       = tphillips
    USERPROFILE                    = C:\Documents and Settings\tphillips
    VisualStudioDir                = C:\Documents and Settings\tphillips\My Documents\Visual Studio 2008
    VS90COMNTOOLS                  = c:\Program Files\Microsoft Visual Studio 9.0\Common7\Tools\
    VSIDEResolvedNonMSBuildProjectOutputs = <VSIDEResolvedNonMSBuildProjectOutputs></VSIDEResolvedNonMSBuildProjectOutputs>
    VSSDK90Install                 = C:\Program Files\Microsoft Visual Studio 2008 SDK\
    WDTargetDir                    = @(_WDOutputPathItem->'%(FullPath)')
    windir                         = C:\WINDOWS

    Initial Items:
    _SourceWebPathItem
        ..\..\test
    _WDOutputPathItem
        .\Release\

    Building with tools version "3.5".
    Target "_PrepareForBuild" in file "C:\Program Files\MSBuild\Microsoft\WebDeployment\v9.0\Microsoft.WebDeployment.targets":
      Task "CreateProperty"
      Done executing task "CreateProperty".
      Task "CreateProperty"
      Done executing task "CreateProperty".
      Task "CreateProperty"
      Done executing task "CreateProperty".
      Task "Exec"
        Command:
        if exist ".\TempBuildDir\" rd /s /q ".\TempBuildDir\"
      Done executing task "Exec".
    Done building target "_PrepareForBuild" in project "test.csproj_deploy.wdproj".
    Target "_SplitProjectReferencesByType" skipped, due to false condition; ('@(ProjectReference)'!='') was evaluated as (''!='').
    Target "_PrepareForBuild" skipped. Previously built successfully.
    Target "GetFrameworkPathAndRedistList" in file "C:\Program Files\MSBuild\Microsoft\WebDeployment\v9.0\Microsoft.WebDeployment.targets":
      Task "GetFrameworkPath"
      Done executing task "GetFrameworkPath".
      Task "CreateItem"
      Done executing task "CreateItem".
    Done building target "GetFrameworkPathAndRedistList" in project "test.csproj_deploy.wdproj".
    Target "_ResolveReferences" in file "C:\Program Files\MSBuild\Microsoft\WebDeployment\v9.0\Microsoft.WebDeployment.targets":
      Task "CreateItem"
      Done executing task "CreateItem".
      Task "ReadLinesFromFile" skipped, due to false condition; ( '%(References_RefreshFile.Identity)' != '' ) was evaluated as ( '' != '' ).
      Task "CombinePath"
      Done executing task "CombinePath".
      Task "Copy"
      Done executing task "Copy".
      Task "ResolveAssemblyReference" skipped, due to false condition; (Exists('%(References.Identity)')) was evaluated as (Exists('')).
      Task "Copy"
      Done executing task "Copy".
    Done building target "_ResolveReferences" in project "test.csproj_deploy.wdproj".
    Target "_ResolveProjectReferences" skipped, due to false condition; ('@(NonVCProjectReference)'!='') was evaluated as (''!='').
    Target "ResolveAssemblyReferences" skipped, due to false condition; ('@(Reference)'!='' or '@(_ResolvedProjectReferencePaths)'!='') was evaluated as (''!='' or ''!='').
    Target "_CopyBeforeBuild" skipped, due to false condition; ( '$(EnableCopyBeforeBuild)' == 'true' or '@(ExcludeFromBuild)' != ''  ) was evaluated as ( '' == 'true' or '' != ''  ).
    Target "BeforeBuild" in file "C:\Program Files\MSBuild\Microsoft\WebDeployment\v9.0\Microsoft.WebDeployment.targets":
    Done building target "BeforeBuild" in project "test.csproj_deploy.wdproj".
    Target "_PrepareForBuild" skipped. Previously built successfully.
    Target "AspNetCompiler" in file "C:\Program Files\MSBuild\Microsoft\WebDeployment\v9.0\Microsoft.WebDeployment.targets":
      Task "AspNetCompiler"
        
        Command:
        c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_compiler.exe -v /test.csproj -p "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\test" -u -f .\TempBuildDir\
        The "AspNetCompiler" task is using "aspnet_compiler.exe" from "c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_compiler.exe".
        Utility to precompile an ASP.NET application
        Copyright (C) Microsoft Corporation. All rights reserved.
        
        
      Done executing task "AspNetCompiler".
      Task "RemoveDir" skipped, due to false condition; ('$(DeleteAppDataFolder)' == 'true') was evaluated as ('' == 'true').
      Task "CreateItem" skipped, due to false condition; ('$(UseMerge)' != 'true') was evaluated as ('true' != 'true').
    Done building target "AspNetCompiler" in project "test.csproj_deploy.wdproj".
    Target "BeforeMerge" in file "C:\Program Files\MSBuild\Microsoft\WebDeployment\v9.0\Microsoft.WebDeployment.targets":
    Done building target "BeforeMerge" in project "test.csproj_deploy.wdproj".
    Target "GetFrameworkPaths" in file "C:\Program Files\MSBuild\Microsoft\WebDeployment\v9.0\Microsoft.WebDeployment.targets":
      Task "GetFrameworkPath"
      Done executing task "GetFrameworkPath".
      Task "GetFrameworkSdkPath"
      Done executing task "GetFrameworkSdkPath".
    Done building target "GetFrameworkPaths" in project "test.csproj_deploy.wdproj".
    Target "_PrepareForBuild" skipped. Previously built successfully.
    Target "AspNetCompiler" skipped. Previously built successfully.
    Target "GenerateAssemblyInfo" skipped, due to false condition; ( '@(AssemblyAttributes)' != '' ) was evaluated as ( '' != '' ).
    Target "AspNetMerge" in file "C:\Program Files\MSBuild\Microsoft\WebDeployment\v9.0\Microsoft.WebDeployment.targets":
      Task "AspNetMerge"
        Running aspnet_merge.exe.
        Command:
        C:\Program Files\Microsoft SDKs\Windows\v6.0A\bin\aspnet_merge.exe .\TempBuildDir -o test.csproj_deploy -a  -copyattrs
        The "AspNetMerge" task is using "aspnet_merge.exe" from "C:\Program Files\Microsoft SDKs\Windows\v6.0A\bin\aspnet_merge.exe".
        Utility to merge precompiled ASP.NET assemblies. Version 3.5.21022.
        Copyright (c) Microsoft Corporation 2007. All rights reserved.
        
        aspnet_merge : warning 1013: Cannot find any assemblies that can be merged in the application bin folder.
        Successfully merged '.\TempBuildDir'.
      Done executing task "AspNetMerge".
      Task "CreateItem"
      Done executing task "CreateItem".
    Done building target "AspNetMerge" in project "test.csproj_deploy.wdproj".
    Target "AfterMerge" in file "C:\Program Files\MSBuild\Microsoft\WebDeployment\v9.0\Microsoft.WebDeployment.targets":
    Done building target "AfterMerge" in project "test.csproj_deploy.wdproj".
    Target "CopyToOutputDir" in file "C:\Program Files\MSBuild\Microsoft\WebDeployment\v9.0\Microsoft.WebDeployment.targets":
      Task "CreateItem"
      Done executing task "CreateItem".
      Task "Exec"
        Command:
        if exist "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\" rd /s /q "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\"
      Done executing task "Exec".
      Task "Exec"
        Command:
        if not exist "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\" md "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\"
      Done executing task "Exec".
      Task "Copy"
        Copying file from ".\TempBuildDir\\Default.aspx" to "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\Default.aspx".
        Command:
        copy /y ".\TempBuildDir\\Default.aspx" "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\Default.aspx"
        Copying file from ".\TempBuildDir\\PrecompiledApp.config" to "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\PrecompiledApp.config".
        Command:
        copy /y ".\TempBuildDir\\PrecompiledApp.config" "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\PrecompiledApp.config"
        Copying file from ".\TempBuildDir\\test.csproj" to "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\test.csproj".
        Command:
        copy /y ".\TempBuildDir\\test.csproj" "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\test.csproj"
        Copying file from ".\TempBuildDir\\test.csproj.user" to "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\test.csproj.user".
        Command:
        copy /y ".\TempBuildDir\\test.csproj.user" "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\test.csproj.user"
        Copying file from ".\TempBuildDir\\test.sln" to "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\test.sln".
        Command:
        copy /y ".\TempBuildDir\\test.sln" "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\test.sln"
        Copying file from ".\TempBuildDir\\Web.config" to "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\Web.config".
        Command:
        copy /y ".\TempBuildDir\\Web.config" "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\Web.config"
      Done executing task "Copy".
      Task "Copy"
        Creating directory "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\bin".
        Copying file from ".\TempBuildDir\\bin\test.dll" to "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\bin\test.dll".
        Command:
        copy /y ".\TempBuildDir\\bin\test.dll" "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\bin\test.dll"
        Copying file from ".\TempBuildDir\\bin\test.pdb" to "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\bin\test.pdb".
        Command:
        copy /y ".\TempBuildDir\\bin\test.pdb" "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\bin\test.pdb"
      Done executing task "Copy".
      Task "Copy"
        Creating directory "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\obj\Debug".
        Copying file from ".\TempBuildDir\\obj\Debug\ResolveAssemblyReference.cache" to "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\obj\Debug\ResolveAssemblyReference.cache".
        Command:
        copy /y ".\TempBuildDir\\obj\Debug\ResolveAssemblyReference.cache" "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\obj\Debug\ResolveAssemblyReference.cache"
        Copying file from ".\TempBuildDir\\obj\Debug\test.csproj.FileListAbsolute.txt" to "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\obj\Debug\test.csproj.FileListAbsolute.txt".
        Command:
        copy /y ".\TempBuildDir\\obj\Debug\test.csproj.FileListAbsolute.txt" "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\obj\Debug\test.csproj.FileListAbsolute.txt"
        Copying file from ".\TempBuildDir\\obj\Debug\test.dll" to "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\obj\Debug\test.dll".
        Command:
        copy /y ".\TempBuildDir\\obj\Debug\test.dll" "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\obj\Debug\test.dll"
        Copying file from ".\TempBuildDir\\obj\Debug\test.pdb" to "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\obj\Debug\test.pdb".
        Command:
        copy /y ".\TempBuildDir\\obj\Debug\test.pdb" "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\obj\Debug\test.pdb"
      Done executing task "Copy".
      Task "Copy"
        Creating directory "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\obj\Release".
        Copying file from ".\TempBuildDir\\obj\Release\test.csproj.FileListAbsolute.txt" to "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\obj\Release\test.csproj.FileListAbsolute.txt".
        Command:
        copy /y ".\TempBuildDir\\obj\Release\test.csproj.FileListAbsolute.txt" "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\obj\Release\test.csproj.FileListAbsolute.txt"
        Copying file from ".\TempBuildDir\\obj\Release\test.dll" to "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\obj\Release\test.dll".
        Command:
        copy /y ".\TempBuildDir\\obj\Release\test.dll" "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\obj\Release\test.dll"
        Copying file from ".\TempBuildDir\\obj\Release\test.pdb" to "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\obj\Release\test.pdb".
        Command:
        copy /y ".\TempBuildDir\\obj\Release\test.pdb" "C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\Release\\obj\Release\test.pdb"
      Done executing task "Copy".
      Task "Exec"
        Command:
        if exist ".\TempBuildDir\" rd /s /q ".\TempBuildDir\"
      Done executing task "Exec".
      Task "ToggleDebugCompilation"
        Updating Web.config <compilation> element debug attribute to 'False'.
        Successfully updated Web.config <compilation> element debug attribute to 'False'.
      Done executing task "ToggleDebugCompilation".
    Done building target "CopyToOutputDir" in project "test.csproj_deploy.wdproj".
    Target "ReplaceWebConfigSections" skipped, due to false condition; ('$(UseWebConfigReplacement)' == 'true') was evaluated as ('' == 'true').
    Target "CreateVirtualDirectory" skipped, due to false condition; ( '$(VirtualDirectoryAlias)' != ''  ) was evaluated as ( '' != ''  ).
    Target "AfterBuild" in file "C:\Program Files\MSBuild\Microsoft\WebDeployment\v9.0\Microsoft.WebDeployment.targets":
    Done building target "AfterBuild" in project "test.csproj_deploy.wdproj".
    Target "Build" in file "C:\Program Files\MSBuild\Microsoft\WebDeployment\v9.0\Microsoft.WebDeployment.targets":
    Done building target "Build" in project "test.csproj_deploy.wdproj".

    Done building project "test.csproj_deploy.wdproj".

    Project Performance Summary:
         1969 ms  C:\Documents and Settings\tphillips\My Documents\Temp\newsite\depoly\test.csproj_deploy\test.csproj_deploy.wdproj   1 calls

    Target Performance Summary:
            0 ms  GetFrameworkPaths                          1 calls
            0 ms  AfterBuild                                 1 calls
            0 ms  BeforeBuild                                1 calls
            0 ms  AfterMerge                                 1 calls
            0 ms  _ResolveReferences                         1 calls
            0 ms  BeforeMerge                                1 calls
            0 ms  Build                                      1 calls
            0 ms  GetFrameworkPathAndRedistList              1 calls
           31 ms  _PrepareForBuild                           1 calls
          250 ms  AspNetMerge                                1 calls
          250 ms  CopyToOutputDir                            1 calls
         1422 ms  AspNetCompiler                             1 calls

    Task Performance Summary:
            0 ms  CombinePath                                1 calls
            0 ms  GetFrameworkSdkPath                        1 calls
            0 ms  CreateProperty                             3 calls
            0 ms  GetFrameworkPath                           2 calls
            0 ms  CreateItem                                 4 calls
           16 ms  ToggleDebugCompilation                     1 calls
           94 ms  Copy                                       6 calls
          172 ms  Exec                                       4 calls
          250 ms  AspNetMerge                                1 calls
         1422 ms  AspNetCompiler                             1 calls

    Build succeeded.

    Time Elapsed 00:00:01.96
    ========== Build: 0 succeeded or up-to-date, 1 failed, 1 skipped ==========

     

    Thursday, April 17, 2008 2:32 PM
  • User2100964097 posted

    My Web Deployment Project used to compile without a problem, however, after installing the Visual Studio 2008 SDK I now get the same error.  Everything looks ok but the output reports the "failed" message. 

    Is there some setting that the SDK changes?

    Any information would be appreciated, but I will investigate further.

    UPDATE:
    I have now removed the VS 2008 SDK and now the Web Deployment Project compiles without any problems.  This is a bit of a problem as I need both WDP and SDK.

    Anyone else with this problem? 


    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, May 4, 2008 7:30 PM
  • User-1151899654 posted

     Well it looks like that was the same problem for me...i had the SDK installed...once i removed it, the build works like expected.

     Would be interesting if someone could explain what the SDK is doing to cause this failure.
     

    Monday, May 5, 2008 12:22 PM
  • User1095185381 posted
    Same problem here. Same solution. How irritating.
    Wednesday, June 10, 2009 1:32 PM
  • User-850001062 posted

    i haven't deinstalled the sdk to verify if WDP won't fail anymore but obviously i have the same problem. my WDP was building successfully all the time - then recently i have installed the sdk and the WDP is reporting "1 failed" (although the WDP build seems fine).

    would you guys @microsoft please take into account this bug and leave a message?

    thanks

    Tuesday, May 4, 2010 6:40 AM
  • User-359936451 posted

    Which SDK are all of you refereing to? I have the Silverlight SDK installed. deciding whether to uninstall it now.

    At least a KB article number would be helpful MS!!

     

     

     

     

    Thursday, July 8, 2010 12:26 PM