none
Add-in wont load from a url or local share. RRS feed

  • Question

  • I have been developing an add-in for Word and all was going well until about a week ago. I am hosting the app in Azure and the xml manifest is hosted on a local share here in the office. All of a sudden, I cant get the app to show in the insert menu. 

    I attempted to submit to the marketplace/store and got rejected as I was not using the 1.1 schema. I updated the schema and ran it through the Office App Compatibility Kit and it passes. I cannot test it in my install of Word though, I really need to do this prior to submitting again so I can avoid it failing. 

    Unfortunately I cannot just run in debug as it uses a web service in the background and due to CORS complexities it wont be able to access those endpoints while in debug. Basically the app will load but I wont have any data so it is useless.

    I have even tried using the old schema version of the xml, that worked for months, and that wont work now either.

    I am starting to think this is a legit bug. Any help with this would be much appreciated.

    Edit: I am using Windows 7 with all updates, VS2013 with all updates and Word 2013 with all updates.
    • Edited by TOPS Software Tuesday, September 22, 2015 6:14 PM configuration info
    Tuesday, September 22, 2015 6:12 PM

Answers

  • I resolved my issue, kind of. I just edited the config file in the project to point to the publish and now I can run in debug. I just need to publish before testing if anything changed since it runs from the site now. Cant use the debugger now but that isnt as big of a deal.
    • Marked as answer by TOPS Software Monday, September 28, 2015 2:00 PM
    Monday, September 28, 2015 2:00 PM