locked
Cube Browser returns only NULL values RRS feed

  • Question

  • I am new to SSAS and have been practicing building dimensions and cubes.

    I have been using the Adventure Works DW for my practice.

    Several times this issue has happened to me.

    When I go into the cube browser and pull in some measures all that is returned is NULL.

    Currently it is only happening for fact internet sales, fact reseller sales is fine.

    This was working correctly.

    I read some articles on this issue and nothing so far has helped.

    I usually end up resorting to deleting and rebuilding the cube.

    When I go into SQL Management Studio and attempt a very basic MDX query on the same date all that is returned is #error

    This is a very frustrating product.

    Errors seems to happen out of the blue and very little descriptions to go on

    Also I am finding out someone else is having the same problem.

    Any help would be greatly appreciated

    Thanks

    Tuesday, November 20, 2018 2:24 PM

Answers

  • Hi James ,

    Welcome to the ssas community, be sure you will learn quickly :)

    About Null values - The most common things which I can think about :

    1) No data in the fact table .

    2) One of the dimension which slice the fact has no data .

    What to do ? If you have created some code in the Calculation tab (data tools) - remove it .

    Remove all connection from dimentions which slice the problematic fact from usage tab (data tools) .

    Reprocess the relevant MeasureGroup again and update .

    Good Luck !


    Regards, David .


    • Edited by David Harazi Tuesday, November 20, 2018 2:31 PM
    • Marked as answer by James N San Tuesday, November 20, 2018 4:47 PM
    Tuesday, November 20, 2018 2:30 PM

All replies

  • Hi James ,

    Welcome to the ssas community, be sure you will learn quickly :)

    About Null values - The most common things which I can think about :

    1) No data in the fact table .

    2) One of the dimension which slice the fact has no data .

    What to do ? If you have created some code in the Calculation tab (data tools) - remove it .

    Remove all connection from dimentions which slice the problematic fact from usage tab (data tools) .

    Reprocess the relevant MeasureGroup again and update .

    Good Luck !


    Regards, David .


    • Edited by David Harazi Tuesday, November 20, 2018 2:31 PM
    • Marked as answer by James N San Tuesday, November 20, 2018 4:47 PM
    Tuesday, November 20, 2018 2:30 PM
  • David,

    Thanks for replying.

    I looked at each of my dimensions and the Fact Internet Sales measure and was able to explore the data, and all have data.

    the Calculations tab just has the word Calculate in it.

    I went into the Dimension usage a deleted all the relationships between the dimensions and the Fact Internet Sales table.

    I am getting an error for the Fact Internet Sales "No dimension relationships exists"

    and for Fact Reseller Sales I am now getting a message "Measure group has zero overlapping dimensions, consider moving to a separate cube"

    How do I reestablish the relationships between each dimension and the measure group?

    Thanks

    Tuesday, November 20, 2018 4:43 PM
  • David,

    ok I went back into the dimension usage and I see how to reestablish the relationship.

    I started with 1 dimension, the date dimension and I am seeing data again!

    Thank you so much.

    I am going to add the relationships back one at a time and see where it breaks

    Thanks again

    Tuesday, November 20, 2018 4:47 PM