locked
Help With LDAP Filters Using Wildcards - Part 2 RRS feed

  • Question

  • User1001000304 posted

    First of all, many thanks to Ashish for his help with my earlier post.  It was very helpful indeed!

    However, I'm still not seeing the results I'm hoping for with my LDAP filters.  Just to recap, I'm trying to create a web form that will allow users to query my company's Active Directory for users using a fuzzy-filter type approach.  Essentially, if the user enters "an" as the query, it should retrieve "Anne", "Dan"--as well as last names containing "an" somewhere in the value.

    When I construct the filter in my web app, I'm getting mixed results, and I'm not sure why.  Some terms seem to work, others don't.  When it works, I can verify that the value filtered exists in either the givenname or sn (or both) just fine.  But if I adjust the term to something else, I don't get any results.  I'm including the filter below for your reference.

    (&(objectCategory=user)(mail=*)(|(givenname=*an*)(sn=*an*)))

    Here's an example of what works and what doesn't.  It seems like one or two characters in the filter work okay (although some don't)...but more than two characters have never worked.

    Works:  o, a, d, an, k

    Doesn't work:  da, dan, ka

    Some of the names that exist in our AD are "Dan", "David", "Katherine", "O'Brien", etc...  All of the above filters should have returned at least one of these names, but not all of them do.

    If you have any suggestions, I would really appreciate it.  I must be doing something wrong, but I can't see it.

    Many thanks.
    -Dan

    Monday, December 8, 2008 12:39 PM

All replies

  • User1001000304 posted

    My appologies...this was an error in my web code.  Essentially the results were only showing up if there were more than one page returned.

    Sorry for the invalid post!
    -Dan

    Monday, December 8, 2008 1:06 PM