Install sticks on Pending restarts on windows server 2008 R2 RRS feed

  • Question

  • I have tried installing on a number of machines running windows server r2, (standard and enterprise) installer will keep asking for the machine to be restarted to clear pending restarts/ renaming of files - despite multiple reboots the install will not progress with the actual sharepoint server install.

    Any ideas?

    • Moved by Mike Walsh FIN Tuesday, November 24, 2009 7:21 AM install q (From:SharePoint 2010 - General Questions and Answers)
    Monday, November 23, 2009 4:56 PM


All replies

  • Please (and this applies to everyone posting about installation problems with R2) tell us if you have applied the fix needed before all R2 installations.
    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    Monday, November 23, 2009 5:26 PM
  • I have tried with the fix installed and without the fix install will not proceed due to pending restart/ renames

    Monday, November 23, 2009 8:42 PM
  • I'm getting the same thing. 

    I've tried on both 2008 SP2 and 2008 R2 (virtual) machines.  Fresh install of Windows, nothing else yet configured.  Run the prereq installer, reboot, run the hotfix, reboot again, and no matter what I get the pending restart message when trying to install Foundation.  I've gone into the registry to verify the PendingFileRenameOperations key is empty, which I had to do the last time I tried installing SQL 2008 on R2.

    Thank god for snapshots or I'd really be pulling my hair out.  I've tried every variation I could think of.

    EDIT:  I should also mention that one site I found advised configuring IIS before running the prereq installer to fix this issue.  It made no difference either way.

    Tuesday, November 24, 2009 4:59 AM
  • Are you logging on with an account with local admin rights? 
    Tuesday, November 24, 2009 2:08 PM
  • Yes,  Local and Domain admin rights.
    Tuesday, November 24, 2009 4:18 PM
  • This sounds like an issue not in SharePoint, but in MSI installer. If MSIEXEC report back code 3010 then "a restart is pending". However, in some very strange scenarios a restart will not solve the problem. For example, like Geektechnica mentioned by PendingFileRenameOperations, a file need to be renamed after reboot is still locked so it can't rename it, then it will reschedule another reboot... The cause of the issue can be different.

    The KB articles from Windows team is to suggest that get system status back to the point you have not install updates by system recovery or snapshots. Which means, if you cannot find PendingFileRenameOperations, basicly you have to rebuild the system.:(

    Tuesday, November 24, 2009 4:40 PM
  • The oddest thing is I've rebuilt the system a number of times.  I've done fresh installs of 2008 SP2 and R2 a couple times as well as reverting to snapshots.  I tried doing the install immediately following setting up the system before running windows updates, and I've tried it on fully patched, up-to-date installs as well.  I can't think of anything else at this point.  Over the last several days I'd wager to say I've rebuilt this machine 5-6 times, not including reverting to prior snapshots.
    Wednesday, November 25, 2009 1:04 AM
  • I know this sounds a bit off but maybe you want to download the beta2 once again. I know it does not make sense, but I had issues with SPD2010 and possibly this is one option.

    Also confirming that you have not been reusing the same VM back and forth? You have rebuilt this 5-6 times - totally fresh?

    Blog: Alpesh Nakar's Blog | Twitter: Follow Alpesh on Twitter |SharePoint Resources: Just SharePoint Resource Center | Follow Just SharePoint updates on Twitter
    Wednesday, November 25, 2009 5:44 AM
  • I think that is what I'll try next.  I downloaded the copy I have only moments after it became available.  And yes, 5-6 times completely fresh installs, and probably twice that many times reverting to snapshots.
    Wednesday, November 25, 2009 8:03 PM
  • Again does not make sense but my copy of SPD2010 that I downloaded from connect did not work (possibly download was corrupt) and then I downloaded from MS (general) link and all good.

    Try it.

    Also have you installed Visual Studio before installing SP?

    Blog: Alpesh Nakar's Blog | Twitter: Follow Alpesh on Twitter |SharePoint Resources: Just SharePoint Resource Center | Follow Just SharePoint updates on Twitter
    • Proposed as answer by Geektechnica Thursday, November 26, 2009 4:25 AM
    • Marked as answer by Mike Walsh FIN Thursday, November 26, 2009 7:26 AM
    Wednesday, November 25, 2009 10:15 PM
  • Well whaddya know...  I downloaded the beta installer again, but this time via my Technet subscription, and this time it worked without a hitch.  Wish I had tried it earlier.

    Thanks for the help.
    Thursday, November 26, 2009 4:26 AM