VFP could not load resources error


  • Hi,

    a have a big problem with getting running an App., which is really important to a friend of mine for his office.

    App is using FoxPro (according to the dll files). I hope the version is correct.

    I have already got running successfully this App on a VMWARE fusion WinXP Home SP3 Version on a MACOSX.
    In this VMWARE WinXP i have just copied the needed dlls to system32 folder and everything worked fine without any changes.

    Now i have installed WinXP with SP3 and all Updates from scratch on his other desktop computer. I have copied the needed dlls in system32 folder again and the app folder to C:\. But now this error pops up:
    "Visual FoxPro Cannot start. Could not load resources..Press F1 for Help".

    I have tried at the moment everything (googled, and looked here in the forum). I have alread downloaded the version from Also tried to regsvr und regsvr -u the dlls. But keep saying the same error.

    The config.fpw is in the app folder and contains this (haven't changed it, tried only once with Resource = On --> no effect):
    CURRENCY = ' öS'
    POINT = ","
    SEPARATOR = "."
    HOURS = 24
    MVCOUNT = 500

    Note: Before i formatted the harddisk, i have copied the hole HD to an extern HD of mine, therefore the files of the old "system status" are available if this is any use...
    In this old system status in system32 folder there was : VFP5DEU.DLL, VFP6R.DLL, VFP6RDEU.DLL, VFP6RUN.EXE, VFP500.DLL, vfpodbc.dll, VFPOLE50.DLL

    But i think the App is using VFP5. Tried also to copy all files to new system32 folder and only to copy vfb5 files etc....

    I hope somebody is able to help me is really important.

    I would appreciate your help, thanks!


    Sunday, October 19, 2008 12:40 PM


  • Take a look in VFP Help.

    This is from VFP6 Help.

    Visual FoxPro cannot start

      Visual FoxPro cannot be initialized or configured for one of the following reasons:

      • Insufficient memory.

        Visual FoxPro could not allocate sufficient memory for internal structures. Free up memory and restart Visual FoxPro.

      • Insufficient disk space.

        Visual FoxPro could not allocate temporary files. Free up disk space and restart Visual FoxPro.

      • Vfp6enu.dll could not be loaded.

        Visual FoxPro cannot find Vfp6enu.dll because it is missing or has been renamed. Reinstall Visual FoxPro.

      • The resource file you specified with the -L startup switch could not be loaded.

        Visual FoxPro cannot find the file you specified. Check that the file you specified with the -L switch is available.

      • Visual FoxPro requires Windows 95 or Windows NT 3.51.

        Install Windows 95 or Window NT 3.51.

      • Product in use by another.

        Make sure that you have the correct network access rights. See your Windows documentation.

      • Invalid or missing .EXE file.

        Reinstall Visual FoxPro.


    Sunday, October 19, 2008 1:21 PM