none
550 5.7.501 spam abuse detected sending with https://outlook.office.com/api/v2.0 REST API RRS feed

  • Question

  • We have recently built an outlook365 add-in which needs to send emails and uses the Outlook Mail REST API to handle sending the emails. When emails are sent to Office 365 users on the same .onmicrosoft.com account they go through no problem, but anything that goes outside the domain gets rejected with the error below.

    Any help would be appreciated

    Delivery has failed to these recipients or groups:

    Your message wasn't delivered because the recipient's email provider rejected it.

    Diagnostic information for administrators:
    Generating server: YTXPR01MB0318.CANPRD01.PROD.OUTLOOK.COM
    Remote Server returned '550 5.7.501 Access denied, spam abuse detected. For more information please go to http://go.microsoft.com/fwlink/?LinkId=526653'
    Original message headers:

    Authentication-Results: bananatag.com; dkim=none (message not signed) header.d=none;bananatag.com; dmarc=none action=none header.from=bananatag.onmicrosoft.com; Received: from YTXPR01MB0317.CANPRD01.PROD.OUTLOOK.COM (10.165.219.15) by YTXPR01MB0318.CANPRD01.PROD.OUTLOOK.COM (10.165.219.16) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256_P256) id 15.1.1178.14; Tue, 20 Jun 2017 21:49:44 +0000 Received: from YTXPR01MB0317.CANPRD01.PROD.OUTLOOK.COM ([10.165.219.15]) by YTXPR01MB0317.CANPRD01.PROD.OUTLOOK.COM ([10.165.219.15]) with mapi id 15.01.1178.018; Tue, 20 Jun 2017 21:49:43 +0000 Content-Type: application/ms-tnef; name="winmail.dat" Content-Transfer-Encoding: binary

    Wednesday, June 21, 2017 10:59 PM

All replies

  • Hi,

    Can you please share your code with us? Thanks!


    Regards, Sjoukje

    Please remember to click 'Mark as Answer' on the post that helps you.

    Monday, June 26, 2017 1:13 PM
    Moderator