window2012 insert vlan id while no VLAN is configured RRS feed

  • Question

  • HI,

    I have a mini port network driver (not written by me though) which works fine on windows 2008.  It doesn't support anything rellated to VLAN tag.   When install it on windows 2012 standard edition,  all the outgoing pakcets are inserted with a VLAN tag (vlan id 2), and the peer systems don't like it.

    I am wondering why there is a VLAN tag inserted,  and how I can disable it.  Is there anything changed in window 2012, eg. Vlan ID is now enabled by default, that I need to update the miniport drvier accordingly?   BTW:  My miniport driver exposes no interface to configure VLAN related staff.  I am sure the miniport driver itself doesn't insert anything like that,  and I am working on a fresh installed window 2012,  no additional software installed,  and I didn't change any default configuration on it. 

    Not sure whether I describe my question clearly enough,  I know almost nothing about driver development.. Thanks a lot for any advice on this..

    Thursday, October 4, 2012 9:18 PM


  • As Pavel said, the default TCPIP stack won't use VLAN IDs.  However, Windows Server 2012 has a couple inbox features that can be configured to add VLAN tags:

    In addition to those two inbox features, 3rd party solutions might use VLAN IDs too.

    So first, check if you have any teaming or virtualization enabled in the server.  If you are using the inbox solutions, you can quickly check for VLANs with these two PowerShell commands:

    • Get-VMNetworkAdapterVLAN
    • Get-NetLbfoTeamNic

    For example, here I have a vSwitch on VLAN 2, and a team on VLAN 3:

    PS C:\> Get-VMNetworkAdapterVLAN
    VMName          VMNetworkAdapterName   Mode     VlanList
    ------          --------------------   ----     --------
                    my-vlan-switch         Access   2
                    my-non-vlan-switch     Access   
    PS C:\> Get-NetLbfoTeamNic
    Name                    : my-team - VLAN 3
    InterfaceDescription    : Microsoft Network Adapter Multiplexor Driver #2
    Team                    : my-team
    VlanID                  : 3
    Primary                 : False
    Default                 : False
    TransmitLinkSpeed(Mbps) : 0
    ReceiveLinkSpeed(Mbps)  : 0
    Name                    : my-team
    InterfaceDescription    : Microsoft Network Adapter Multiplexor Driver
    Team                    : my-team
    VlanID                  :
    Primary                 : True
    Default                 : True
    TransmitLinkSpeed(Mbps) : 0
    ReceiveLinkSpeed(Mbps)  : 0

    Friday, October 5, 2012 1:42 AM