locked
network monitor 3.4 none of the network adapters are bound to the netmon driver RRS feed

  • Question

  • I've installed this on 3 client machines now (all win7 pro) and each of them has the same result: "none of the network adapters are bound to the netmon driver" when I try to capture.  I've run as admin, checked membership in teh NetMon Users group on the local machine.  Nothing seems to help.

    Any suggestions are welcome.

    thx,

    DML


    DLovitt

    Tuesday, July 30, 2013 8:18 PM

All replies

  • What happens if you type "sc query nm3" from the command line.  What are the results?

    There is a limit of filter drivers, and programs like VMware and such can add to this list.  If you look at the properties for the NIC, are there a lot of things bound to it?

    Paul

    Wednesday, August 7, 2013 3:38 PM
  • sc query nm3 gives:

    SERVICE_NAME: nm3
            TYPE               : 1  KERNEL_DRIVER
            STATE              : 4  RUNNING
                                    (STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)
            WIN32_EXIT_CODE    : 0  (0x0)
            SERVICE_EXIT_CODE  : 0  (0x0)
            CHECKPOINT         : 0x0
            WAIT_HINT          : 0x0

    Not a lot of things bound to the NIC either:

    Client for MS net

    MS network Monitor 3 Driver

    Virtual PC Network Filter Driver

    QoS packet Scheduler

    File and print Sharing...

    and the typical protocols

    Thanks for looking at this.


    DLovitt

    Wednesday, August 7, 2013 3:47 PM
  • We've had issues before with various Virtual PC stacks.  Does it work if you uninstall the Virtual PC Network Filter Driver?

    Paul

    Wednesday, August 14, 2013 2:39 PM
  • I've disabled the Virtual PC network filter driver- no change.  Again, I've installed NetMon on 3 machines now, (all domain joined) and none of them have the adapters actually bound (although the NetMon driver is installed and checked) in NetMon. Two of the machines don't have Virtual PC installed. On a newly rebuilt, fully patched, not domain joined machine, it works. This doesn't really solve the problem, however.

    DLovitt


    Wednesday, August 14, 2013 2:45 PM
  • And  I assume, once you join that working machine to the domain, you can no longer capture?  Does running as admin change anything?  Is there a way to understand what policies are being applied by joining the domain?

    Paul

    Wednesday, August 21, 2013 4:49 PM
  • Having same problem on Win 7 Home Premium except no domain. I have no idea how to bind the adapters. I ran in administrator mode no changes. I have my Tap Adapter (VPN), Wireless Nic, and an Ethernet adapter (I forget the exact titles of these things) and a couple VM adapters that I don't even have Virtualbox installed anymore for. I really only care about being able to use the Tap Adapter as that's what I'm always on. Help pl0x? :)
    Thursday, December 4, 2014 12:58 PM
  • The symptom above has many different root causes. So we should troubleshoot it to understand what is wrong for your case.

    What do you see when you run "sc query nm3" from a admin CMD prompt. 

    Can you run filtmc and tell me what it returns?

    Thanks

    Paul

    • Proposed as answer by Paul E Long Tuesday, February 3, 2015 6:39 PM
    Tuesday, December 16, 2014 6:52 PM
  • Did you try to run the tool as administrator ? 

    Vignesh Ganesan, Microsoft SharePoint & O365 Consultant, Pune, Maharashtra. Mob : 7387783354

    Thursday, January 28, 2016 11:18 AM
  • Run as admin solved it for me !

    Thanks !


    • Edited by alelavoie Friday, February 19, 2016 4:25 PM
    Friday, February 19, 2016 4:25 PM