none
Visual Studio Community 2017 installer wont launch, it starts by extracting something then hangs/exits

    Question

  • Hi

    I am trying to install microsoft visual studio 2017 community edition but the installer doesn't start. it starts extracting something and then just crashes. Tried restarting my laptop but that doesnt work. any solution to this problem? 

    Thursday, April 20, 2017 4:28 PM

All replies

  • Hi 

    Welcome to MSDN forum.

    Please delete folder under: %LocalAppData%\Microsoft\VisualStudio\Packages\Channels, the other who has the similar issue with you solved it by this. You could also download the Windows Fixit tool from here: https://support.microsoft.com/en-sg/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed, then run it to repair issues including corrupted registry keys or others.

    Meanwhile, disable any Anti-Virus or Anti-Spyware software on your computer and make sure you have a good network connection. Having a try with the following steps to Check if the Installer Service is running:

    1. Click Start, type Services.msc and press {ENTER}
    2. Double-click Windows Installer
    3. Set the Startup type of Windows Installer to Manual
    4. Click Start to start the service.
    5. Click OK.

    if the issue persists, I need your help to collect the complete VS installation log. Please usehttp://aka.ms/vscollect to gather the installation logs. After using it, you will find vslogs.zip under %temp% folder. Please upload the file to https://onedrive.live.com/ and share the link here.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Friday, April 21, 2017 2:50 AM