none
"Access Denied" error for a User with Full Control whenever editing a web part ? RRS feed

  • Question

  • Hi Forum,

    We have a SharePoint page that has a custom web part, and everything works perfectly fine. Nevertheless, There's one user e.g. (User1) with Full Control permissions level keeps getting "Access Denied" error whenever he tries to edit that web part (Edit Page > Click on the Arrow > Edit Web Part > "Access Denied" error shows up!).

    I have checked the situation with other users who have EXACTLY the same permissions level (Full Control), and all of them are able to edit that particular web part without any issues.

    So, My questions are:


    1) Why that only user (User1) is encountering the "Access Denied" error even though he has Full Control permissions on the site where the web part is added ? Please keep in mind that other users with the same permissions are able to edit the web part normally.



    2) What can I do to fix this problem? Any place to check?



    BTW, I already followed and checked everything on this article: (http://support.microsoft.com/kb/2001366?wa=wsignin1.0), But unfortunately it didn't help !

     

    I would greatly appreciate your inputs !


    • Edited by Asker2012 Monday, June 10, 2013 4:49 PM Adding some details !
    Monday, June 10, 2013 4:46 PM

Answers

  • Asker2012

    Ok, if this is custom web part can you please make sure user logged in with the same account with which he / she can edit the web part (with the specific domain log in). Also make sure user login to the machine with the same credentials (sme domain) which is added to the site with full permission. For testing modify permission on the top level site to contribute.

    Let us know your results 


    Regards,
    Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com
    Posting is provided AS IS with no warranties, and confers no rights
    Please remember to click Mark As Answer if a post solves your problem or Vote As Helpful if it was useful.

    • Marked as answer by Asker2012 Wednesday, August 21, 2013 6:15 PM
    Monday, June 10, 2013 8:45 PM
    Moderator

All replies

  • Hi Asker2012,

    is this web part added to the sub site ? If yes what is the permission on top level site ?

    Does this user exist in single domain ? or there are multiple domain login or this user ?


    Regards,
    Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com
    Posting is provided AS IS with no warranties, and confers no rights
    Please remember to click Mark As Answer if a post solves your problem or Vote As Helpful if it was useful.


    Monday, June 10, 2013 7:38 PM
    Moderator
  • @Pratik Vyas

    The web part is added to a Sub-Site, and the user (User1) has Full Control permissions level on that particular Sub-Site.

    Frankly I am not 100% sure about the parent site - Maybe the user (User1) has Read permissions level on that particular Sub-Site. But does it matter ?

    As for your other question: "Does this user exist in single domain ? or there are multiple domain login or this user ?"

    Not sure if I understood correctly !

    Well, It is a big organization with multiple domains. I means, There are some users who have accounts like: France\User33, Germany\User89...etc

    But again, I have confirmed with other user who has EXACTLY the same permissions as User1 and they both belong to the same domain...and that user was able to edit the web part normally, But User1 is getting the "Access Denied" error.


    • Edited by Asker2012 Monday, June 10, 2013 8:39 PM fixing a typo
    Monday, June 10, 2013 8:12 PM
  • Asker2012

    Ok, if this is custom web part can you please make sure user logged in with the same account with which he / she can edit the web part (with the specific domain log in). Also make sure user login to the machine with the same credentials (sme domain) which is added to the site with full permission. For testing modify permission on the top level site to contribute.

    Let us know your results 


    Regards,
    Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com
    Posting is provided AS IS with no warranties, and confers no rights
    Please remember to click Mark As Answer if a post solves your problem or Vote As Helpful if it was useful.

    • Marked as answer by Asker2012 Wednesday, August 21, 2013 6:15 PM
    Monday, June 10, 2013 8:45 PM
    Moderator
  • @Pratik Vyas

    Thanks for your prompt response.

    1) I understood the second part of your suggestion which is adding a Contribute permissions level to the user (User1) on the parent site (Top level site) - OK, I can try that and let you know if that make any difference.

    2) But I didn't understand the first part. So, I will reword the problem:

    There's a custom web part on a subsite that is working perfectly fine with all users. One user e.g. (Germany\User1) has Full Control on that subsite where the web part is located, Nevertheless, he has reported that he's getting "Access Denied" error whenever he tries to edit the web part.

    The user is using the same account to access the Windows, his machine, and SharePoint site. So, The user has no other account.

    I already followed and checked everything on this article: (http://support.microsoft.com/kb/2001366?wa=wsignin1.0), But unfortunately it didn't help !

    Also, I checked with other users e.g. (Germany\User6), (Germany\User444), (France\User99)...etc which allhave EXACTLY the same Full Control permissions  level, Yet...All these other users are able to edit the web part normally without any issues at all...

    I can try adding a Contribute permissions level to the user (User1) on the parent site (Top level site) and see how that goes. But are there other suggestions ?

    Monday, June 10, 2013 9:25 PM