locked
ASP.net Website Administration Tool Error RRS feed

  • Question

  • User869980383 posted

    Hi,

    I got an error while using WAT.

    I followed following steps:

    1) Provide Configuration -> Clicked on Select a different provider for each feature (advanced)

    2) Selected Oracle Membership Provider and Oracle Role Provider

    3) Clicked on Security tab. Here I found an Error.

    Error as,

    "There is a problem with your selected data store.  This can be caused by an invalid server name or credentials, or by insufficient permission.  It can also be caused by the role manager feature not being enabled.  Click the button below to be redirected to a page where you can choose a new data store. 
    The following message may help in diagnosing the problem: OracleConnection.ConnectionString is invalid "

    I don't have any problem with datasource. I can fetch records into gridview in page.

    Please Help me. Thanks in Advance.

    Wednesday, June 12, 2013 7:07 AM

Answers

  • User869980383 posted

    Here is a solution. One needs to have installed Oracle Tools for Visual Studio.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, June 13, 2013 1:50 AM

All replies

  • User-718146471 posted

    The connection string its referring to is a default. ASP.NET Web Site Administration tool uses connection string named "LocalSqlServer" to connect to the database. You can configure it in your web.config.

    <connectionStrings>

    <remove name="LocalSqlServer" />

    <add name="LocalSqlServer" connectionString="your connection string" providerName="System.Data.SqlClient" />

    </connectionStrings>

    Wednesday, June 12, 2013 7:46 AM
  • User-801004448 posted

    Do you use Oracle database on asp.net website?

    Wednesday, June 12, 2013 10:52 PM
  • User869980383 posted

    I followed what you said.

    Still I get an error as "There is a problem with your selected data store. This can be caused by an invalid server name or credentials, or by insufficient permission. It can also be caused by the role manager feature not being enabled. Click the button below to be redirected to a page where you can choose a new data store.

    The following message may help in diagnosing the problem: The connection name 'LocalSqlServer' was not found in the applications configuration or the connection string is empty. (C:\Windows\Microsoft.NET\Framework\v2.0.50727\Config\machine.config line 146)"

    Thanks.

    Thursday, June 13, 2013 12:33 AM
  • User869980383 posted

    Yes. I am using Oracle Database.

    I guess I need to run scripts from, "C:\Oracle\product\11.2.0\client_1\ASP.NET\SQL"

    But I am getting errors over there. I guess before running these scripts, I need to run other scripts. But I am not sure which scripts.

    Please help me.

    Thanks.

    Thursday, June 13, 2013 12:37 AM
  • User-2001332922 posted

    Blunt understanding to

    The following message may help in diagnosing the problem: The connection name 'LocalSqlServer' was not found in the applications configuration or the connection string is empty. (C:\Windows\Microsoft.NET\Framework\v2.0.50727\Config\machine.config line 146)"

    is that web.config take precedence after machine.config so concentrate to the line of code in web.config.

    Thursday, June 13, 2013 1:13 AM
  • User869980383 posted

    Got this error due to, adding tag,

    <connectionStrings>

    <remove name="LocalSqlServer" />

    <add name="LocalSqlServer" connectionString="your connection string" providerName="System.Data.SqlClient" />

    </connectionStrings>

    This has been removed and earlier mentioned error with invalid connectionString persists.


    Thursday, June 13, 2013 1:27 AM
  • User-13423606 posted

    ProviderName = System.Data.SqlClient is wrong.

    use ProviderName = System.Data.OracleClient because u use oracle db.

    another help about oracle DB use in asp.net application see below article...

    http://docs.oracle.com/cd/B28359_01/appdev.111/b28844/using_aspnt.htm

    Thursday, June 13, 2013 1:38 AM
  • User869980383 posted

    Here is a solution. One needs to have installed Oracle Tools for Visual Studio.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, June 13, 2013 1:50 AM