none
CE 5 Build syncs over USB but can't see device files RRS feed

  • Question

  • I have a new CE 5 build that can connect with my desktop over USB.   The device shows up on the desktop under Devices (I'm running Windows 8 x64), but when I attempt to view the files on the device, nothing is shown.  I have searched for hours to try and find what DLLs or Platform Builder catalog item(s) I am missing to no avail.  Perhaps someone here can help.

    Because we are running a dedicated app on our device, I have removed all the file viewers (i.e. Word, Excel, Outlook, etc.) along with some of the Graphics and Multimedia Technologies components.  I have added the Firewall.

    QFEs are up-to-date.

    On a fresh working build, I normally remember seeing a brief message on the desktop saying something like "Downloading drivers to device." the first time a connection is established but do not see that message with this build.

    Monday, March 25, 2013 11:44 PM

Answers

  • Thanks you for your suggestions.  By going back to a working build and making my changes one at a time, I was able to identify the problem as the Firewall component, which was blocking the sync connection.  The problem was solved by disabling the Firewall temporarily until I can find the correct settings for AS.

    [HKEY_LOCAL_MACHINE\COMM\Firewall\]

        "EnableIPV4"=dword:0

        "EnableIPV6"=dword:0

    • Proposed as answer by Keshava GN Thursday, April 4, 2013 2:17 PM
    • Marked as answer by David Baltz Thursday, April 4, 2013 5:06 PM
    Thursday, April 4, 2013 1:28 PM

All replies

  • Bump.
    Thursday, March 28, 2013 4:34 PM
  • Hi ,

     

    I think your issue should be raised in the Windows
    Embedded Compact Platform Development
      I believe they will know more information of this issue than us, and I will move this one to that forum.

     

    Thanks for your understanding,

     

    Best regards,

    Jesse


    Jesse Jiang
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, April 4, 2013 6:41 AM
  • How it behaves if you connect it to a Desktop machine on which WIndows XP Is running.

    In Windows CE the USB Device can be shown to host PC as USB Serial (Using Active Sync) or One of the storage available on target device can be shown as Mass Storage on Desktop machine.

    Under device manager what you are seeing. May be a snapshot of that will be helpful.

    Also you can check for default client driver registry entry for USB Function. What is the entry in your device for the following registry key?

    [HKEY_LOCAL_MACHINE\Drivers\USB\FunctionDrivers] "DefaultClientDriver"=- ; erase previous default [HKEY_LOCAL_MACHINE\Drivers\USB\FunctionDrivers] "DefaultClientDriver"=???

    Also what are the entries available in the nk.bin udner the following registry path. [HKEY_LOCAL_MACHINE\Drivers\USB\FunctionDrivers]

    Regards,

    GSR

    Thursday, April 4, 2013 6:54 AM
  • Are you sure that the device is connected via ActiveSync/WMDC? Because, normally that icon in MyComuter appears just by installing ActiveSync/WMDC, but if you open it, nothing you can see. So i think the device is not being connected in this case..

    Keshava G N ( keshavagn@iwavesystems.com ), Member - Technical, iWave Systems ( http://iwavesystems.com )

    Thursday, April 4, 2013 9:23 AM
  • Thanks you for your suggestions.  By going back to a working build and making my changes one at a time, I was able to identify the problem as the Firewall component, which was blocking the sync connection.  The problem was solved by disabling the Firewall temporarily until I can find the correct settings for AS.

    [HKEY_LOCAL_MACHINE\COMM\Firewall\]

        "EnableIPV4"=dword:0

        "EnableIPV6"=dword:0

    • Proposed as answer by Keshava GN Thursday, April 4, 2013 2:17 PM
    • Marked as answer by David Baltz Thursday, April 4, 2013 5:06 PM
    Thursday, April 4, 2013 1:28 PM
  • Nice to hear that your problem is solved. :) Please change the status of thread to "answered"... :)

    Keshava G N ( keshavagn@iwavesystems.com ), Member - Technical, iWave Systems ( http://iwavesystems.com )

    Thursday, April 4, 2013 2:13 PM