locked
Unable to deploy apps in Android Player RRS feed

  • Question

  • User139465 posted

    have created Android apps in Xamarin Studio. But for some need I have to install Visual Studio 2015 Community edition in to my system. But the problem now is whenever I am trying to run my early developed Xamarin Android program it is launching Android Player but in Xamarin Studio it is showing "Starting Nexus 5 ( KitKat )" or what ever the emulator name is and it is not moving forward .. refer to the image .

    Can any one guide me on that...???

    Wednesday, August 26, 2015 12:10 PM

All replies

  • User45748 posted

    I am having exactly the same problem and it started in the last 2 weeks. I have had to revert to GenyMotion at the moment but would like some guidance as to whether there is something that can fix this?

    Wednesday, August 26, 2015 4:16 PM
  • User35208 posted

    This started for me this morning after upgrading Xamarin Studio, which necessitated upgrading Android SDK. When the Android Player didn't work, I also upgraded that. However, still getting stuck on the "Starting Nexus 4 (Lollipop)..." status.

    Wednesday, August 26, 2015 5:39 PM
  • User92610 posted

    Same issue when I downloaded the latest xamarin studio. I was onn 0.3.7 and updated to 0.4.4 and it's still broken.

    Thursday, August 27, 2015 12:18 AM
  • User139465 posted

    But it is unfortunate that... no Xamarin expert is helping us.... really frustrating. If you have bugs in latest build then why you people released the build..? No testing ..nothing...

    Thursday, August 27, 2015 4:57 AM
  • User139465 posted

    Any suggestion from any body..?

    Friday, August 28, 2015 10:56 AM
  • User148932 posted

    I had a similar issue until this morning when a new build (v0.5.5) became available, I installed it and everything started working again after a reboot.

    Friday, August 28, 2015 7:08 PM
  • User154224 posted

    I had a similar issue...

    Saturday, August 29, 2015 12:11 PM
  • User16 posted

    same here. I attached the log files below

    Monday, August 31, 2015 12:15 PM
  • User354 posted

    I get this with a 'starting message being shown for ever'. However in most scenarios in the drop down for the choice of the device to deploy I then get the IP address of the android device shown which you can then deploy to instead and that works.

    Monday, August 31, 2015 12:34 PM
  • User126875 posted

    I have same problem , and in my device manager there is new device with ip adress 10.71.34.101 wich maches the device i am launching. The xamarin stops responding until i close virtual device.

    Monday, August 31, 2015 1:34 PM
  • User61458 posted

    I have the same issue and have contacted support. I can get around the issue by selecting the IP address in the device drop down list and then deploy to it.

    https://bugzilla.xamarin.com/show_bug.cgi?id=31881

    [Update] The new Android player 0.5.5(1) did not fix the issue for me.

    Monday, August 31, 2015 2:31 PM
  • User126875 posted

    Unfortunately my xamarin stops responding moment i open drop down menu, so i cant get around.

    Monday, August 31, 2015 2:40 PM
  • User61458 posted

    @Ivanxxx do you stop the IDE from deploying and then try selecting the new device?

    Monday, August 31, 2015 2:46 PM
  • User126875 posted

    It's no mater that i am deploying, as long as device is active the moment i open drop menu xamarin stops responding.

    Monday, August 31, 2015 3:24 PM
  • User7196 posted

    Try this:

    • start player manually and launch your image you wish to deploy to
    • when it is started select from the list of devices the one in Bold text, it will be named by the IP, in ma case usually like 10.1.1.120:5555

    Then deploy/start there. All will work and be fine.

    Monday, August 31, 2015 3:35 PM
  • User126875 posted

    It's the same thank you for the replay.

    Monday, August 31, 2015 4:10 PM
  • User126875 posted

    I have work around that works for me :smile: . Run >Run with. ty.

    Monday, August 31, 2015 4:53 PM
  • User138614 posted

    Tried following (while having XAP updated to the latest version):

    1) Running XAP first and running XS after which results in XS getting frozen (no matter if I start deploying or just not doing anything) 2) Running XAP after XS was run. XS getting cold like ice. 3) Running everything as usual which results in ice cold XS as well.

    Tuesday, September 1, 2015 10:09 AM
  • User139465 posted

    Partially solved.... check it

    Solution 1 :

    refer to the image

    Solution1 : 2

    Use Genymotion...

    Tuesday, September 1, 2015 11:14 AM
  • User51368 posted

    This issue is being caused by an update to the Android SDK Tools (24.3.4), it changes the way adb handles characters that need to be escaped. As a workaround, if you downgrade SDK tools then it should work as it did before.

    Tuesday, September 1, 2015 1:29 PM