none
Error in installing OpenXML 2.10.1 using NuGet in Visual Studio 2010 RRS feed

  • Question

  • Hi,

    I'm fairly new to Visual Studio projects.

    Due to limitations on my project, I have to use Visual Studio 2010 and implement OpenXML version 2.10.1.

    I installed NuGet Manager to install OpenXML 2.10.1 in Visual Studio 2010.


    Unfortunately I encounter error:

    'DocumentFormat.OpenXml' already has a dependency defined for 'System.IO.Packaging'.

    When I use the NuGet Console, I encounter this error:

    Install-Package : 'DocumentFormat.OpenXml' already has a dependency defined for 'System.IO.Packaging'.
    At line:1 char:1
    + Install-Package DocumentFormat.OpenXml -Version 2.10.1
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Install-Package], InvalidOperationException
        + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand
     

    Currently we have .NET 4.0 version.

    As I understand, System.IO.Packaging is already included in WindowsBase for .NET 4.0.


    Am I missing other Dependencies to add or some other configuration or steps?

    Thank you,

    JMikko



    • Edited by JMikko Wednesday, June 17, 2020 8:28 AM Edit version used
    Wednesday, June 17, 2020 8:23 AM