none
Data type mismatch in criteria expression... RRS feed

  • Question

  • I have a form that builds a SQL statement, and uses this SQL as the SQL for a query that I open.  This has been working fine until a recent Office upgrade on some of the PCs on the network.  I am running an older Office version and everything is aces.  When my colleague runs this (upgraded Office), he gets: "Data type mismatch in criteria expression".  I have remoted into his machine and tried to reproduce the error but cannot.  Any ideas on how to troubleshoot this?

    Thanks!


    Thanks for your help!!

    Saturday, April 15, 2017 12:46 PM

All replies

  • Post the SQL statement and datatype of any fields that are part of criteria.

    Build a little, test a little

    Saturday, April 15, 2017 4:52 PM
  • I hope he is using a separate copy of the FE.

    Did you check that his coy compiles without errors?

    Did you ensure there are no missing references?

    Have you tried a compact and repair?

     

    I do agree with Karl, we'd need to see the SQL Statement involved and you'd need to give us the data types of the fields involved.


    Daniel Pineault, 2010-2016 Microsoft MVP
    Professional Support: http://www.cardaconsultants.com
    MS Access Tips and Code Samples: http://www.devhut.net

    Saturday, April 15, 2017 5:25 PM