locked
Visual Studio 2013 cannot launch a site previously working in VS2012 RRS feed

  • Question

  • User-453421585 posted

    This is my 3rd full day working on this and I'm out of leads to follow.

    I have an application that runs under Visual Studio 2012.  I installed VS2013 then tried launching the site.  Immediately I received the 500.19 error.

    I resolved this by tinkering with the applicationhost.config in the IISExpress directory used by VS2013.

    I changed this to "allow" which permitted my applications web.config to set the application to us Windows Auth.

    <section name="anonymousAuthentication" overrideModeDefault="Allow" />

    That made a difference and my page now loads but the CSS and Obout dialog controls do not load.

    I have searched and searched for anyone else having a similar problem but I can't find it.  I have also changed nearly every setting I could find in this applicationhost.config with no joy.

    I wish there was a way to go back to launghing the application from the IDE instead of using the IISExpress.  I don't want to go back to VS2012 so I'll keep pressing forward.

    If anyone has any ideas of things I can try I'd appreciate it.

    Thanks...

    Monday, January 13, 2014 4:23 PM

All replies

  • User-760709272 posted

    Look at the source of the page and the network profiling in the developer tools of IE/Chrome (F12) to get an idea why they're not loading.  Also check you are targetting the correct version of the framework from the project properties.

    Monday, January 13, 2014 4:44 PM
  • User-453421585 posted

    They are both using Framework 4.5.  I'll see if I can figure out why the CSS and other resources aren't being downloaded.  They are producing 500 errors in the logs.

    I did notice something.

    In VS 2012 I was not using IISExpress which is introducing all kinds of configuration problems.  VS 2013 seems to only allow IISExpress or an IIS Server.

    Is there any way to configure VS 2013 to function as it did before in VS2012 for existing application?

    Also, I noticed that what is available in the properties of the project (F4 properties) is comletely different between the 2 versions of visual studio.

    VS 2012 Properties not found in VS 2013
    C# Language Level = Default
    CSS Version = 3.0
    Localizable = Default
    Localizable Inspector = Optimistic
    Path mapping = Note set
    Solution-Wide Inspections = On

    VS 2013 Properties not found in VS 2012
    Anonymous Authentication = DisabledManaged Pipeline Mode = Integrated
    SSL Enabled = False
    SSL URL =
    URL = http://localhost:1829
    Windows Authentication = Enabled


    I'm not sure why these properties are so radically different for the same project between VS 2012 and VS 2013.  I don't know if this info can help lead to a solution so I thought I'd include it.

    Tuesday, January 14, 2014 2:20 PM
  • User-453421585 posted

    I'm starting to think there might be a "path" problem to the CSS and images but I dont understand how it could be wrong since it works when deployed to production/test and in VS2012 IDE.  It only does not work when launch from VS 2013 which is forcing the application to load in IIS Express.

    Tuesday, January 14, 2014 2:28 PM
  • User-453421585 posted

    I enable parent path and that didn't seem to change anything.  I'm assuming I changed it for my site in <system.webServer> of IIS Express.  Maybe I should have done it at the application level just to make sure it took effect.

    As of now, day 4, no joy.

    Tuesday, January 14, 2014 3:19 PM
  • User-166373564 posted

    Hi rdunaway

    Thanks for raising this issue to us through the forums. I’m sorry for hearing your frustration on this issue.

    As we know, visual studio has backwards compatibility, if you develop a asp.net app in Visual Studio 2012, it will works fine in Visual Studio 2013.

    rdunaway

    I installed VS2013 then tried launching the site.  Immediately I received the 500.19 error

    If you get HTTP Error 500.19 – Internal Server Error HRESULT: 0x800700b7

    This  problem occurs because the ApplicationHost.config file has a duplicate entry for the following code.

    <add accessType="Allow" users="*" />

    To resolve this problem

    In the ApplicationHost.config file, delete the duplicate entry for the authorization rule. To do this, follow these steps:

    1. Click Start, type Notepad in the Start Search box, right-click Notepad, and then click Run as administrator.
      Note If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
    2. On the File menu, click Open, type %windir%\System32\inetsrv\config\applicationHost.config in the File name box, and then click Open.
    3. In the ApplicationHost.config file, delete the duplicate entry that resembles the following code. <div class="kb_codebody"> <div class="kb_codecontent">
      <add accessType="Allow" users="*" />

    hope it helps.

    Regards

    Angie

    Sunday, January 19, 2014 9:39 PM
  • User-453421585 posted

    I'm not sure that's true.  2013 is forcing me to use IIS Express which is the root of the problem.  I've found that if I launch VS 2013 as administrator it works.  This is not something I had to do in 2012 and I've tried changing 2013 to launch to app using VS instead of Express and there isn't the option to do it.

    So while I'm getting by now, it's not the same.

    Thanks for the reply...

    Monday, January 20, 2014 8:18 AM