locked
Using WWMWriter to write an ASF file hangs. RRS feed

  • Question

  • I am having a problem when I attempt to convert a MPEG4 video file into a ASF file  (no audio, and I reduced resolution).  A one minute video segment can take over an hour to export.  This as been observed at 3 of my customer sites and we have installed base of that are not having this problem.  We are using IWMProflie and IWMWriter to generate the file.  Our system has multiple video recorder servers and multiple clients that can view the recorded video and export the files to the ASF file format.  Not all clients at the customer site are experiencing the problem but all have the same software.

    Has there been any recent  patches that might impact Windows Media Foundation? 

    Are there any system settings that I need to check?

    Are there any logging or debug settings I can use to investigate?

    Any and all suggestions are greatly appreciated.

    Thanks,
    Don

    Monday, January 7, 2013 3:12 PM

All replies

  • Hello,

    try mftrace and see what is wrong, your task shouldn't take much time, cpu etc... cause I was able to transcode MJPEG video 80M to h264 ASF in seconds actually result was really cool, 2.5M vs 80M

    Regards

    Aleksey

    Wednesday, January 9, 2013 6:57 PM
  • I will try using mftrace (as soon as I can get the Windows SDK to load). 

    You are right that the export of the video files to asf format should go very quickly, and it does for most of our customers.

    It is just that on certain PCs it fails.  Same software, same network, same users.  We have even tried reinstalling our software.  No change.

    Thanks for responding.

    Don

    Friday, January 11, 2013 9:38 PM
  • I am having a problem loading the Windows SDK tools.

    I have VS 2010 Premium Version with Service Pack 1 installed. I have a C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\Bin directory and it have 147 entries in it but no mftrace.exe.

    I have tried to load the Windows SDK for Windows 7  from the Microsoft download web site, but the install fails.

    The error returned is that the SDK version (10.0.30319) is incompatible with the Visual Studio installed (10.0.40219).

    Any suggestions where I can get mftrace.exe?

    Monday, January 14, 2013 4:43 PM
  • This doesn't answer my oritional question, but my experience installing the Windows SDK might help someone else.

    As per above, I did have Windows SDK already installed, and I was attempting to add additional debug tools.
    Downloading and installing winsdk_web.exe failed.  (It was trying to do a full install.)  I retried and deselected
    all options other than the debug tools.  It failed again but indicated a file in the temp directory that was failing.
    I opened that directory and opened the .cab file.  I ran the .msi from the .cab, and it installed correctly.

    I ran winsdk_web.exe again.  This time when the SKD installer came up, the Change / Repair / Remove options
    came up.  In the change option I  selected additional debug tools and the installed correctly.

    I now have MFTrace.exe.  Back to debugging  IWMWriter.

    Wednesday, January 16, 2013 2:38 PM