locked
Unable to step through debug on physical iPhone RRS feed

  • Question

  • User393098 posted

    I have a Xamarin.Forms app running on Android and am trying to get it finished on iOS. It works on an iPhone emulator and it installs and runs on an iPhone 7 physical device but can't debug. I can start it in debug and it will stop at a break point, but when I try to continue or step to the next line, it gets the following error:

    2020-02-29 11:24:48.664 AutoMobile.iOS[1029:2604931] error: * Assertion at /Users/builder/jenkins/workspace/archive-mono/2019-08/ios/release/mono/mini/mini-arm64.c:5437, condition `native_offset % 4 == 0' not met The app has been terminated. Failed to Stop app: An error occurred on client IDB164000311 while executing a reply for topic xvs/idb/16.4.0.311/stop-app The app has been terminated. Step request failed: Exception of type 'Mono.Debugger.Soft.VMDisconnectedException' was thrown.

    Looking at the device crash log, the only additional info is "Address size fault".

    Any help or pointers would be greatly appreciated.

    PC Environment: Visual Studio 2019 16.4.5, Xamarin 16.4.000.311, Xamarin.Forms 4.5.0.356 Apple Environment: Mac OS Catalina, XCode 11.3.1, iPhone 7 iOS 13.3.1

    Project Settings, iOS Build (Debug, iPhone): * SDK Version: Default * Linker Behavior: Don't Link * Supported Architectures: ARM64 * HttpClient Implementation: Managed (default) * Enable Mono Interpreter (checked), everything else unchecked

    Saturday, February 29, 2020 10:54 PM

All replies

  • User372631 posted

    Make sure that the version of XF and IDE are all up to date . If it still doesn't work , delete the folder bin and obj both in share and iOS project . Then clean and rebuild it .

    Monday, March 2, 2020 8:33 AM
  • User393098 posted

    Thanks @LucasZhang, I double checked the versions (again), deleted the bin and obj folders (again), cleaned and rebuilt the solution (again). No change in behavior with the same assertion error. I've also tried uninstalling Visual Studio and reinstalling from scratch and completely rebuilding the Mac Mini and the iPhone with no change. App runs find on the iPhone until any break point is hit, then continue or step throws the error.

    Wednesday, March 4, 2020 1:02 AM
  • User372631 posted

    You could create a new blank project to check if the issue still exists .

    Wednesday, March 4, 2020 2:06 AM
  • User393098 posted

    @LucasZhang, I followed your suggestion and it does work on a new blank project. I rebuilt the iOS project from scratch adding one feature back in at a time until it failed again. It starts to get this debug step through error after adding in-app purchasing. Again, it all works until you hit a break point then try to step through code, it will get this condition error and end the app. I'm going to back out in-app purchasing and try to see where it went wrong. Thanks!

    Saturday, March 7, 2020 11:55 PM