none
Is there anyway to buy Visual Studio Pro 2005 SP1 ? RRS feed

  • Question

  • Hi, 

    I need to build a plugin for an application that highly recommend using VS2005 to compile the plugin since their application has been compile with VS2005.

    It's writtin that because of the changes in memory allocation between VS2005 and other versions, there would be no way to guarantee the behaviour of the plugin if the compiler is not VS2005.

    Is there a way to buy Visual Studio 2005 SP1 to compile C++ code ?

    If not what is the oldest version of Visual Studio that I can buy ?

    Is there a way to use VS2005 compiler with Visual Studio 2015 ?

    Thanks

    Thursday, June 20, 2019 1:44 PM

All replies

  • Hi umarcja,

    Welcome to MSDN forum.

    >>Is there a way to buy Visual Studio 2005 SP1 to compile C++ code ?

    Visual studio 2005 is too old and Microsoft has dropped it for public download.

    >>If not what is the oldest version of Visual Studio that I can buy ?

    The oldest version is visual studio 2010 currently.

    >>Is there a way to use VS2005 compiler with Visual Studio 2015 ?

    You could right-click the project/ Properties/General to switch platform toolset to use different compiler from different version

    But as far as I know, visual studio 2005(V80) seems to be not officially supported, and I find similar issue on stack overflow to use other method adding it. Hope it could help you.

    Any feedback will be expected.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, June 21, 2019 5:58 AM