none
SharePoint Online add-in: The endpoint address does not match the app's endpoint RRS feed

  • Question

  • Hi all,

    We have created an add-in for SharePoint Online and it has been published to the Office Store. The Add-in went through the approval process and it can be added to SharePoint Online from the store. The add-in is a provider hosted add-in and the web site we use is hosted in Azure App Services. As the app went through the approval process and we had tested it through our own test environments etc we thought everything is working as expected. After more than a year, one of our clients bought the add-in from the store and installed it to there SharePoint Online.

    And now to the problem... The add-in was not working and first we thought that the ClientSecret had expired. That actually had happened and we renewed the ClientSecret for the next three years from the seller dashboard. We upgraded the web site with the new ClientSecret and added the add-in from the store to our environment and tested. Still not working. After debugging we found out that the actual error (thanks to fiddler) was actually in the app domain name starting with an additional www.zzzz.azurewebsites.net as the actual web site and redirect url was zzzz.azurewebsites.net/... So the question is, how can we change the app domain or do we need to publish the add-in again to the store and remove the broken one? Another problem is that our company seller dashboard is linked to my colleagues account who is not working with us any more and this needs to be linked to my account, but it's a different story and another support case...

    Any help would be highly appreciated!

    Tuesday, November 28, 2017 6:54 AM