locked
Embedded 7 Toolkit: Creating Windows PE-64 bootable CD RRS feed

  • Question

  • Hello,

    Using Windows Embedded 7 Toolkit I created an x86-64bit windows PE ISO folder.

    The I used the following command to create the CD:

    oscdimg.exe -n -bc:\winpe_64\efisys.bin c:\winpe_64\ISO c:\winpe_64\winpe_64.iso
     
    But when I booted my embedded PC using this CD I got: No system disk.
     
    What am I doing wrong ?
     
    I got the same results when creating this CD using Windows AIK.
     
    Can you help ?
     
    Thanks,
    Zvika.

    • Edited by Z. V Thursday, November 24, 2011 4:18 PM
    Thursday, November 24, 2011 4:17 PM

Answers

  • i don't use DVD/CDs anymore, so i haven't tested but efisys sounds like 64 bit efi supported platforms. did you just try the etfsboot? (el torito not EFI) i see this file also in amd64 folder which is identical with the 32bit one. otherwise you might should try the UFD option -u1 or -u2
    Windows Embedded Developer and Scripting Guy //Germany
    • Marked as answer by Z. V Monday, November 28, 2011 2:31 PM
    Monday, November 28, 2011 1:56 PM

All replies

  • Hi

         I think the command you use is incorrect . please refer to the format of command :

    oscdimg –n –m –b”C:\Program Files\Windows Embedded Standard 2011\Tools\PETools\x86\boot\etfsboot.com”  E:\  C:\MyNewIBWDisk.iso

    Friday, November 25, 2011 6:40 AM
  • Hello,

    According to the walkthrough in PE documentation, when creating a WinPE-64 I should use efisys.bin instead of etfsboot.com.

    This is explained in: http://technet.microsoft.com/en-us/library/cc749311(WS.10).aspx

    Thanks,

    Zvika.

    Friday, November 25, 2011 7:26 AM
  • Hi:

         Sorry, I don't clearly read it. Maybe you can check your buring CD process. 

    Monday, November 28, 2011 2:21 AM
  • i don't use DVD/CDs anymore, so i haven't tested but efisys sounds like 64 bit efi supported platforms. did you just try the etfsboot? (el torito not EFI) i see this file also in amd64 folder which is identical with the 32bit one. otherwise you might should try the UFD option -u1 or -u2
    Windows Embedded Developer and Scripting Guy //Germany
    • Marked as answer by Z. V Monday, November 28, 2011 2:31 PM
    Monday, November 28, 2011 1:56 PM
  • Dear KNARZ,

    You are right.

    If I create the iso file with:

    oscdimg.exe -n -bc:\winpe_64\etfsboot.com c:\winpe_64\ISO c:\winpe_64\winpe_64.iso
     
    It works fine.
     
    Thanks,
    Zvika.
    Monday, November 28, 2011 2:30 PM