none
Problem with SQL WCF Adapter RRS feed

  • Question

  • Hi All,

    This is my first time attempting to use the SQL WCF adapter with BizTalk, so I installed it after installing the SDK, everything seems fine, when I go to the project ==> Add generated items ==> Add Adapter MetaData

    I can now see the option for the WCF-SQL adapter in addition to the SQL option. however when I select it and try to continue I get this error

    unable to display adapter user interface

    Could not load file or assembly microsoft.servicemodel.channels.tools.biztalkextension, version 3.0.0.0

    and that it could not find the file

     

    What should I do? Thanks in advance

    Saturday, April 10, 2010 9:22 AM

Answers

  • Hi,

    You can re-install SDK. When you download the SDK you have to un-pack it and you will see below what is unzipped:

    SDK New

    You need to install SDK (complete) running AdapterFramework.msi. Then check again in the installation folder. Note here is that you need ofcourse appropriate authorization, when installing.

    Another thing I like to add is that if you downloaded WCF-SQL Adapter, you need install WCF LOB Adapter SDK SP2.

    Regards,

    Steef-Jan Wiggers
    MCTS BizTalk Server
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly


    BizTalk
    Saturday, April 10, 2010 3:51 PM
    Moderator

All replies

  • Hi Samual,

    The assembly in question belongs to tools feature of the WCF LOB Adapter.

    Tools: {Installation Folder} \Tools\Microsoft.ServiceModel.Channels.Tools.BizTalkExtension.dll  (see this source).

    It is possible that you have not installed this feature. You can check if this dll is present in the folder. Another though that pops up is if you have rights to access the folder.

    Regards,

    Steef-Jan Wiggers
    MCTS BizTalk Server
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly

     


    BizTalk
    Saturday, April 10, 2010 11:55 AM
    Moderator
  • If you want to use WCF SQL Adapter you have to generate metadata by add generated items -> Consume adapter services and then select the WCF Custom adapter and select SQL binding. If you want to use the non-WCF adapter then you can select add adapter metadata which you are doing currently.

    The assembly which you have mentioned is in the following path.

    {Installation Folder}\Tools\Microsoft.ServiceModel.Channels.Tools.BizTalkExtension.dll

    Check that the assembly is installed correctly. This is the Consume Adapter Service BizTalk Project Add-In for Visual studio. You can check and verify the installation assemblies from this link http://download.microsoft.com/download/9/0/d/90d3fc09-de48-4d83-8147-e8a08275c255/Readme.htm

    If it still doesn't work re-install the WCF LOB adapter SDK again.


    Abdul Rafay - MVP & MCTS BizTalk Server
    blog: http://abdulrafaysbiztalk.wordpress.com/
    Please mark this as answer if it helps.
    Saturday, April 10, 2010 11:59 AM
  • Steef, Can't find the dll on my machine

    Abdul Rafay, after clicking Add Generated Items the only options I get are

    Add Adapter MetaData

    Generate Schemas

    Consume WCF Service

     

    I don't have an option for "Consume Adapter Services"

     

    Saturday, April 10, 2010 12:57 PM
  • Remove and Re-install the WCF LOB adapters pack and try again. Then verify if the assembly is present in the folder or not. Also check the Event viewer if there any problem.
    Abdul Rafay - MVP & MCTS BizTalk Server
    blog: http://abdulrafaysbiztalk.wordpress.com/
    Please mark this as answer if it helps.
    Saturday, April 10, 2010 1:03 PM
  • Remove and Re-install the WCF LOB adapters pack and try again. Then verify if the assembly is present in the folder or not. Also check the Event viewer if there any problem.
    Abdul Rafay - MVP & MCTS BizTalk Server
    blog: http://abdulrafaysbiztalk.wordpress.com/
    Please mark this as answer if it helps.
    Saturday, April 10, 2010 1:04 PM
  • may be SDK, which is required for Adapter Pack, re-installation will required also

    Which can be a part of solution

    Saturday, April 10, 2010 2:38 PM
  • Hi,

    You can re-install SDK. When you download the SDK you have to un-pack it and you will see below what is unzipped:

    SDK New

    You need to install SDK (complete) running AdapterFramework.msi. Then check again in the installation folder. Note here is that you need ofcourse appropriate authorization, when installing.

    Another thing I like to add is that if you downloaded WCF-SQL Adapter, you need install WCF LOB Adapter SDK SP2.

    Regards,

    Steef-Jan Wiggers
    MCTS BizTalk Server
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly


    BizTalk
    Saturday, April 10, 2010 3:51 PM
    Moderator
  • Armen and Steef,

     

    you are right it was the SDK, which was already installed, but the first time around I did a typical installation which did not install the add-in, second time around I tried the customer installation and then I had to choose those added features and now I see the options correctly in VS

    Now I am getting the "Consume Adapter Service" in VS and when clicking on it get the correct wizard for the sqlbinding setup

     

    Thanks all for your help

    Sunday, April 11, 2010 6:30 AM
  • Hi guys, 

    I am having the exact same problem as Samual above, not seeing that option in VS and getting the "Could not load file or assembly microsoft.servicemodel.channels.tools.biztalkextension" when going with the normal add adapter metadata. 

     

    I guess the problem is that I do not have the Tools-folder after installation of the Adapter SDK pack. Any clues to why I don't see that folder?

     

    I have tried re-installing both the LOB adapter pack and the SDK but with the same result. This is on windows 7, x86. 

    Thanks in advance!

    Saturday, April 9, 2011 8:44 PM
  • I have uninstall and installed many time , I am using WCF LOB Adapter SDK SP2, I did installation with complete and as well custome, but could not get sucess.

    Any idea ? what else I can try , I am using VS 2010, Biztalk 2010, windows 2008

     

     


    Rit
    Sunday, June 12, 2011 9:44 PM
  • Be careful just to check which version you are installing.

     

    The Visual Studio works (I think) only with the x86 version

     

    Regards,


    BizTalk Consultant in France
    Wednesday, August 10, 2011 3:23 PM
  • Hello,

    The WCF LOB Adapter SDK SP2 doesn't work with Biztalk 2010, particularly when installing tools.

    You need to install the WCF LOB Adapter SDK 2010 to make it work !

    Regards,

    • Proposed as answer by Lebat Tuesday, October 11, 2011 8:30 AM
    Friday, September 23, 2011 6:44 AM
  • Hi Samual,

    You can get Consume Adapter Metadata option following path Just New project ==> Add generated items ===> Consume Adapter Metadata.

    note: Visual studio does not work with   WCF LOB Adapter SDK SP2 64bit.

    you have to  uninstall 64 bit and just reinstall 32bit SDK. then you will find the above option.

    for verification check assembly: Microsoft.ServiceModel.Channels.Tools.BizTalkExtension.dll (path given in below screenshot)

    Please mark this as answer if it helps.


    Harmeet Singh Virk :Software Engineer-BizTalk

    • Proposed as answer by Kobus Alberts Monday, October 16, 2017 11:18 AM
    Tuesday, September 25, 2012 2:44 PM
  • Hi All ,

                I have install the both SDk 64 bit and 32 bit but fail to fix the issue please do the needful solution to fix this issue.

    regards,

    Khalid

    Thursday, January 9, 2014 10:32 AM
  • This fixed my issue although it was posted many moons ago....grateful...thanks:)

    Monday, October 16, 2017 11:19 AM
  • I came across the same issue, tried all the options stated above but nothing worked to my luck. There isn't a need to install both x32 and x64 SDK's. Figured out a way as below:

    1. Moving forward with the wizard, while choosing setup type, choose - 'Custom'.

    2. You need to select features in the next window, you might find 4 features:

    • Runtime
    • Tools
    • BizTalk Server Addin
    • Samples

    3. You might see a cross 'x' on all the features except 'Runtime'.

    4. To fix/avoid this error, you need to install 'Tools' feature mandatory. Click on the cross 'x' on 'tools' feature and select any of the options stating 'will be installed ..'.

    P.S : 'Tools' feature doesn't get installed with the 'Typical' setup type.

    • Proposed as answer by Colin Dijkgraaf Thursday, September 26, 2019 9:24 PM
    Tuesday, September 24, 2019 2:39 PM