none
Visual Studio 2015 refuses to use Proxy settings when accessing https for GIT or Nuget

    Question

  • I am struggling to get VS 2015 to use our corporate proxy.  I have talked with our Firewall support team and they have verified that when I make calls from VS they try to go directly to the site instead of through the proxy.  

    Proxy is clearly set in Internet Options and I have also tried adding a defaultProxy setting in the devenv.exe.config.

    I get the same error when trying to use Nuget package manager and browse Nuget through https or the GIT extension to hit our repository.

    I have tried everything over the last 4 days and am pretty much at a stand still until this is resolved.

    Thank you

    Mike

    Thursday, November 3, 2016 9:28 PM

All replies

  • Hi Mike,

    According to your description, please share me the detailed error message, and how you set proxy in your VS, which could help me further troubleshot this issue.

    1). Please run your VS in administrator to make sure VS could get enough permission to access internet.

    2). Please refer to the following MSDN document to set proxy in VS.

    https://msdn.microsoft.com/en-us/library/dn771556.aspx

    Sincerely,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, November 4, 2016 7:55 AM
    Moderator
  • Oscar,

    Thank you for your prompt reply.

    This is the error I receive.

        The request was aborted: Could not create SSL/TLS secure channel.

    I am not using Visual Studio Online and I am not having a proxy authorization issue so the link you gave is not valid for this issue.  As I stated in my initial post, our corporate Firewall support team has verified that when I click the push link from within Visual Studio Team Explorer synchronization, they see traffic from my machine directly to the https GIT repository.  Visual Studio or this GIT plugin is refusing to use my proxy settings and therefore the calls are not going to our corporate proxy.

    I have proxy settings set within the internet options and also have tried adding a defaultProxy setting in the devenv.exe.config.  Visual Studio 2015 refuses to use either of those settings.  It's acting like I do not have a proxy set.

    Thank you

    Mike

    Monday, November 7, 2016 4:39 PM
  • Hi Mike,

    I think we could try to reset and safe mode to exclude the reasons caused by VS settings and third plugin in VS.

    Please refer to the following step:

    Click Start->Developer Command Prompt for VS:

    Type:

    devenv.exe /SafeMode  and devenv.exe /ResetSettings separately to observe the results.

    Sincerely,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, November 8, 2016 10:10 AM
    Moderator