none
Problem scheduling a SSIS package using Azure Data Factory

    Question

  • Hopefully someone can assist me with this issue. I set up a Azure Data Factory SSIS-IR that created a SSISDB catalog in my database. I have deployed packages and everything runs fine if I manually execute the packages. If I schedule one of the master packages through SSMS I get an error saying 'Failed to verify Integration Runtime. The catalog does not belong to the integration runtime'

    The catalog was created by the ADF SSIS-IR so I am not sure what could be causing this issue. Any ideas would be appreciated.

    Scott


    Wednesday, August 29, 2018 3:50 PM

All replies

  • Hi Scott,

    How are you scheduling this, and if you are scheduling a Powershell cmdlet, are you authenticating with Azure as the first step in the Powershell script? We are seeking information about how you are scheduling this task. 

    As a reference, the full script Powershell examples in this tutorial all start with the following:

    ### Log in and select subscription
    Connect-AzureRmAccount
    Select-AzureRmSubscription -SubscriptionName $SubscriptionName

    Wednesday, August 29, 2018 5:17 PM
    Moderator
  • I am trying to do the scheduling through SSMS. I right-click on the package name and instead of 'Execute...' I select 'Schedule...' and that is where I get the error

    Scheduling through SSMS

    Wednesday, August 29, 2018 5:22 PM
  • Thanks for reporting this Scott, we'll investigate and follow up soon.
    Thursday, August 30, 2018 1:41 AM
  • Thank you Sandy. I appreciate all efforts to resolve it as we are very eager to get our DW on a refresh schedule in Azure
    Thursday, August 30, 2018 1:50 AM
  • When connecting to server in SSMS, setting “Server Name” to “******.database.windows.net”  instead of “tcp:******.database.windows.net,1433” solves the issue.


    Thursday, August 30, 2018 3:52 AM