none
Can not add new BizTalk Rules policies. RRS feed

  • Question

  • I'm currently trying to use the BizTalk Rules app within a logic app. I've been looking at the BizTalk Rules documentation, and after adding some test vocabulary, I need to add rules. When I open the policy panel, it consistently gives me a "failed to retrieve the list of policies" error and I am unable to add any rules or policies. Am I incorrectly adding in rules, or is this a bug?

    

    Wednesday, May 6, 2015 7:02 PM

Answers

All replies

  • Sorry about this issue. It is a bug in BizTalk Rules policies and we are in the process of updating the UX with the fix as soon as possible. Thanks for bearing with us.
    Monday, May 11, 2015 9:32 PM
  • This should be fixed now, please let us know if the problem persists.

    http://twitter.com/joshtwist

    Tuesday, May 12, 2015 4:16 AM
  • Thanks for the notice, Josh! I can see the policies now! Additional question, what is BizTalk Rules expecting as an input  when used in a logic app? I've been trying to use the content (an xml file) of a FTP action as an input. Every time I save the logic app and return, the input of the BizTalk rules card is cleared out and null. I've tried using the outputs of other actions (HTTP header, Office 365 sender, etc) to retain an output, but all of these clear out as well. 
    Tuesday, May 12, 2015 4:48 PM
  • It actually expects a jsonized XML object. Please see if the documentation helps you - http://azure.microsoft.com/en-in/documentation/articles/app-service-logic-use-biztalk-rules/
    Thursday, May 14, 2015 11:06 PM