locked
trouble with MDB2 and pear RRS feed

  • Question

  • User-919760595 posted
    I have installed PHP 5.3.3 with WebMatrix, installed MDB2_Driver_msql-1.5.0b3 with the pear installer. I'm getting this error on trying to connect: MDB2 Error: not found [Error message: extension mssql is not compiled into PHP]. I have the line extension=mssql in my php.ini I would be extremely grateful for any help on this
    Tuesday, December 21, 2010 11:27 AM

All replies

  • User-1672167363 posted

    I have installed PHP 5.3.3 with WebMatrix, installed MDB2_Driver_msql-1.5.0b3 with the pear installer. I'm getting this error on trying to connect: MDB2 Error: not found [Error message: extension mssql is not compiled into PHP]. I have the line extension=mssql in my php.ini I would be extremely grateful for any help on this

    Question what kind of database(s) are you working with?

    Could the problem be your thinking "mssql" is for "Microsoft Databases"?

    I checked the PHP net web site and this is what is in the

    help at PHP Net "MS SQL functions are aliases to "Sybase functions if PHP is compiled with Sybase

    extension and without MS SQL extension.". 

    If your intent is to work with "Microsoft Databases" you will need to install and enable the PHP sql driver.

    The PHP net site has various examples.

    I hope this helps,

    Martin :-)

    Tuesday, December 21, 2010 2:20 PM
  • User-919760595 posted
    Hi Martin, thanks for your reply. I am working with Microsoft SQL Server 2008 R2. I have installed the recommended driver and placed it in the ext directory of my php installation and placed this directive in the php.ini file: extension=php_sqlserv_53_nts_vc9.dll. The application use PEAR MDB2 for database access. So I installed pear and ran the pear update. I used pear install to install MDB2_Driver_mssql-1.5.0b3. I got the error message that it could not be installed because "MDB2_Driver_mssql-1.5.0b3 requires extension mssql." In the FAQ they said if all else fails install it with the option "--nodeps.' Which I did. Inside MDB2\Driver I found the file mssql.php which does the connect. I found a test there in that php file that was throwing the error. if (!PEAR::loadExtension(&this->phpType) .... return error, the error I posted. phpType is hard coded in that file to "mssql". Yikes. I'm new to PEAR and I don't know how PEAR MDB2 works. The driver is a dll, the one I specified. Why is there a hardcoded value "mssql"? Is it that php file in the Driver folder of MDB2? When do we actually load the driver php_sqlserv_53_nts_vc9.dll and how does MDB2 choose it? I'll go back ot php net and look for examples. Thanks again for posting.
    Tuesday, December 21, 2010 6:11 PM
  • User-1672167363 posted

    Hi Martin, thanks for your reply. I am working with Microsoft SQL Server 2008 R2. I have installed the recommended driver and placed it in the ext directory of my php installation and placed this directive in the php.ini file: extension=php_sqlserv_53_nts_vc9.dll. The application use PEAR MDB2 for database access. So I installed pear and ran the pear update. I used pear install to install MDB2_Driver_mssql-1.5.0b3. I got the error message that it could not be installed because "MDB2_Driver_mssql-1.5.0b3 requires extension mssql." In the FAQ they said if all else fails install it with the option "--nodeps.' Which I did. Inside MDB2\Driver I found the file mssql.php which does the connect. I found a test there in that php file that was throwing the error. if (!PEAR::loadExtension(&this->phpType) .... return error, the error I posted. phpType is hard coded in that file to "mssql". Yikes. I'm new to PEAR and I don't know how PEAR MDB2 works. The driver is a dll, the one I specified. Why is there a hardcoded value "mssql"? Is it that php file in the Driver folder of MDB2? When do we actually load the driver php_sqlserv_53_nts_vc9.dll and how does MDB2 choose it? I'll go back ot php net and look for examples. Thanks again for posting.

    Hello,

    Item 1.) The changes you need are as follows:

    First to use the Mcrosoft PHP SQL driver is copy "php_sqlserv_53_nts_vc9.dll" into the "C:\Program Files (x86)\PHP\ext"

    directory. and also copy "php_pdo_53_nts_vc9.dll" into the "C:\Program Files (x86)\PHP\ext" location.

    Second you need to add to php.ini lines in extension section.

    The existing extesions show the format for "name" and "where" to find the dlls.

    After making the changes to php.ini got to IIS Manager and restart the server.

     After the restart you should be able to verify that new

    library functions are present.

     Simple test for what php understands is at a command prompt start -> run cmd enter key and then

    cd C:\Program Files (x86)\PHP

    dir p*.exe should see php.exe

    then  type  php -i  your should see a display of libraries and system variables.

    There should be an entry showing the Microsoft SQL Server Extension was found.

    item 2.) The hard coding for extensions is a result of how the PHP was installed. The cause of problems usually

    starts when all the extensions are selected to be installed. It is not well described in installer that some extensions

    require having additional "dlls" that are not part of the installer. The other problem and is unclear are how "PDO" links with

    other libraries and extensions selected.

    The best choice when using the MSI installer for PHP is only select the libraries and extensions you will be using.

    You can always make changes to the php.ini to "Tweak" settings to match after installation use.

    To mark an extension as no to be used just put a ";" comment in first column.

    Restart the IIS server.

    Verify chages php -i .

    The resolution for "mssql" extension mark it as not used ";" in first column for extension.

    Restart IIS Server.

    Verify php -i .

    Retry the code with PHP engine and see if it has adjusted what libraries and extensions are loaded for given set of code.

    Sorry to say for much of eary stages of installation invovles "tweaking" and "fiddling" there is not a one size fits all answer.

    Just as a general rule when I have done php installs I make a backup to another folder of original php.ini

    then after making changes to the php.ini ( adding comments,modifying settings) copy this to folder and rename with version

    in the name ie. php-534-works.ini.

    The most recent wroking php.ini can be used to save about an hours worth of work. The back-up not only saves time

    but also gives you a way to recover if PEAR or application over writes your file.

    Item 3.) After you have things going for current drivers,code and install I would suggest getting the php web cache

    installer and modify the php.ini to include that library.

    The php web cache extension and tool are useful in monitoring memory and measuring performace as your coding.

    There is a good guide and download links in the IIS Net main section. It is a useful addon.

    I would suggest that for coding check out "Port 25" site "Interoperability Section".

    There are Linux and Windows users who are interested in making developement for PHP just plain work.

    I hope this helps,

    Martin :-)

    with many good guides and help.

    Wednesday, December 22, 2010 2:22 AM
  • User-919760595 posted
    I have made some small progress with your suggestion. I went back and commented the driver out of the php.ini file. The result was that the sqlsrv section of the phpinfo output was not there and my $dsn was null in the "pear" code. I put it back and it returned and the dsn was suitably populated. I checked the logs and there was no trouble loading the file. So it is loaded. on php -i the only indication is a section for sqlsrv and "sqlsrv support => enabled. Unlike say xdebug, and even mysql, there is no indication anywhere of version. I'm back where I started with the pear error. I will now try to use the driver without pear just to make sure my connection is OK. I'll post back Thanks!
    Wednesday, December 22, 2010 1:31 PM
  • User-1672167363 posted

    I have made some small progress with your suggestion. I went back and commented the driver out of the php.ini file. The result was that the sqlsrv section of the phpinfo output was not there and my $dsn was null in the "pear" code. I put it back and it returned and the dsn was suitably populated. I checked the logs and there was no trouble loading the file. So it is loaded. on php -i the only indication is a section for sqlsrv and "sqlsrv support => enabled. Unlike say xdebug, and even mysql, there is no indication anywhere of version. I'm back where I started with the pear error. I will now try to use the driver without pear just to make sure my connection is OK. I'll post back Thanks!

    I am glad that something is starting to work.

    I agree getting connection working is more important using standard PHP then PEAR adds

    some jazz.

    One way to get more information is to use php -i >php-info.txt.

    You will have text type file that you can see what chages with what settings.

    Later you might want to create an html page that has this code:

     <?php

    phpinfo();

    ?>

    It will use PHP to create a "nice" looking information display.

    Martin :)

    <?php 
      phpinfo
    ();
    ?>


     

    Wednesday, December 22, 2010 3:41 PM
  • User-919760595 posted
    Yes, thanks. I've been using phpinfo(); The new IIS has a PHP Manager module that has that too. I am back with MDB2. I installed the correct MDB2 driver, MDB2_Driver_sqlsrv-1.5.03b using the pear installer and it provides a file sqlsvr.php instead of mssql.php. I then changed the phptype in my config to sqlsvr as specified in the documentation. All other includes and paths are working but when I get to this line: require_once 'MDB2.php' I get this error: Cannot find a local copy of the file on server C:\Program%20Files%20@28x86%29\PHP\PEAR\MDB2.php. When I try to step into this call. My include_path is include_path=".;C:\Program Files (x86)\PHP\v5.3\pear" Notice the double quotes because it gags on the spaces. I will never know why they implemented spaces in file paths. Notice also it's trying to find it in PEAR not pear. I have set an environment variable PHP_PEAR_INSTALL_DIR to "C:\Program Files (x86)\PHP\v5.3\pear" So is it gagging on the html encoding? Where is it pulling that path if I made all configured paths lower case?
    Thursday, December 23, 2010 9:42 PM
  • User-1672167363 posted

    Yes, thanks. I've been using phpinfo(); The new IIS has a PHP Manager module that has that too. I am back with MDB2. I installed the correct MDB2 driver, MDB2_Driver_sqlsrv-1.5.03b using the pear installer and it provides a file sqlsvr.php instead of mssql.php. I then changed the phptype in my config to sqlsvr as specified in the documentation. All other includes and paths are working but when I get to this line: require_once 'MDB2.php' I get this error: Cannot find a local copy of the file on server C:\Program%20Files%20@28x86%29\PHP\PEAR\MDB2.php. When I try to step into this call. My include_path is include_path=".;C:\Program Files (x86)\PHP\v5.3\pear" Notice the double quotes because it gags on the spaces. I will never know why they implemented spaces in file paths. Notice also it's trying to find it in PEAR not pear. I have set an environment variable PHP_PEAR_INSTALL_DIR to "C:\Program Files (x86)\PHP\v5.3\pear" So is it gagging on the html encoding? Where is it pulling that path if I made all configured paths lower case?

    I see your getting some good progress.

    The way I have found to work around issues of "PATH" and "SHORT" names is uisng the command prompt.

    Using admin command prompt get to the (X86) or (win32) directory.

    cd C:\Program Files (x86)

    while at this directory level do this dir p* /x

    The extra x displays the real name the 8.3 real link

    ie."C:\Program Files" is "C:\Progra~1\" "C:\Program Files (x86)\  is C:\Progra~2\

    replace the 8.3 real link in any place that uses PHP.

    I always have this problem with PHP because it is a port of  Linux based

    program.

    This really causes problems with IIS Services. The installer for PHP tries to get it right

    but if you check the setting you will find it is wrong.

    The way to fix it is use the correct short path.

    The additional quiry is in PEAR they have a bad habit of switching betwen using "\" and "/" for where options and paths are used.

    The only way to resolve this is make a backup of the current file copy pear.ini >C:\User\your name\pear-back.ini.

    Then edit and test. If the test fails resotore the settings.

    I know you have a lot to get done but one side diversion.

    You may find it useful to install an editor called "GVIM" it is command prompt based editor.

    I use "GVIM" on my system because it has builtin syntax highlighting for PHP,C,CPP and others.

    If you (Google or Bing) for GVIM for X64 you should get a result for GVIM at google code.

    You may find it useful to install and use.

    Martin :)

    Thursday, December 23, 2010 10:08 PM
  • User-1672167363 posted

    Yes, thanks. I've been using phpinfo(); The new IIS has a PHP Manager module that has that too. I am back with MDB2. I installed the correct MDB2 driver, MDB2_Driver_sqlsrv-1.5.03b using the pear installer and it provides a file sqlsvr.php instead of mssql.php. I then changed the phptype in my config to sqlsvr as specified in the documentation. All other includes and paths are working but when I get to this line: require_once 'MDB2.php' I get this error: Cannot find a local copy of the file on server C:\Program%20Files%20@28x86%29\PHP\PEAR\MDB2.php. When I try to step into this call. My include_path is include_path=".;C:\Program Files (x86)\PHP\v5.3\pear" Notice the double quotes because it gags on the spaces. I will never know why they implemented spaces in file paths. Notice also it's trying to find it in PEAR not pear. I have set an environment variable PHP_PEAR_INSTALL_DIR to "C:\Program Files (x86)\PHP\v5.3\pear" So is it gagging on the html encoding? Where is it pulling that path if I made all configured paths lower case?

    I see your getting some good progress.

    The way I have found to work around issues of "PATH" and "SHORT" names is uisng the command prompt.

    Using admin command prompt get to the (X86) or (win32) directory.

    cd C:\Program Files (x86)

    while at this directory level do this dir p* /x

    The extra x displays the real name the 8.3 real link

    ie."C:\Program Files" is "C:\Progra~1\" "C:\Program Files (x86)\  is C:\Progra~2\

    replace the 8.3 real link in any place that uses PHP.

    I always have this problem with PHP because it is a port of  Linux based

    program.

    This really causes problems with IIS Services. The installer for PHP tries to get it right

    but if you check the setting you will find it is wrong.

    The way to fix it is use the correct short path.

    The additional quiry is in PEAR they have a bad habit of switching betwen using "\" and "/" for where options and paths are used.

    The only way to resolve this is make a backup of the current file copy pear.ini >C:\User\your name\pear-back.ini.

    Then edit and test. If the test fails resotore the settings.

    I know you have a lot to get done but one side diversion.

    You may find it useful to install an editor called "GVIM" it is command prompt based editor.

    I use "GVIM" on my system because it has builtin syntax highlighting for PHP,C,CPP and others.

    If you (Google or Bing) for GVIM for X64 you should get a result for GVIM at google code.

    You may find it useful to install and use.

    Martin :)

    OOPS!

    I missed your last comment.

    The problem with having PHP and PEAR together is PHP has an ini file PEAR has an ini file.

    The PEAR stores the PEAR ini file in C:\WINDOWS and PHP in the PHP application folder.

    When you first installed PEAR it asked are you doing a local install or a global install. The global install puts the

    PEAR ini into the C:\Windows directory so any PHP or server can find PEAR and then PHP.

    The additional system variable is a bit of a waste. When PEAR was installed it created a PEAR or PHP reg file.

    The reg file will set the system paths. The paths will be long paths and to make things better you can make them short paths.

    The one that PEAR gets wrong is the "./PHP/PHP.EXE"" they mis on putting the leading dot.

    Cheers :)

    Thursday, December 23, 2010 10:18 PM
  • User-1672167363 posted

    I have installed PHP 5.3.3 with WebMatrix, installed MDB2_Driver_msql-1.5.0b3 with the pear installer. I'm getting this error on trying to connect: MDB2 Error: not found [Error message: extension mssql is not compiled into PHP]. I have the line extension=mssql in my php.ini I would be extremely grateful for any help on this

    I found a MSDN Blog that may help with SQL PHP Driver.

    He covers  coding against the "PHP", "Webmatrix" and SQL PHP Driver.

    The blog is Brian Swan at blogs msdn.

     There are two articles covering the differences between mssql vs sqlsrv.

    The information may answer some of your questions.

    Martin :)

    Sunday, December 26, 2010 4:22 AM
  • User-919760595 posted
    Hi Martin, Thanks for the tip. I got the driver running outside MDB2. I'll try that blog. The short filenames did not help. When my code reaches this line require_once 'MDB2.php' I still get this error: Cannot find a local copy of the file on server C:\Program%20Files%20%28x86%29\PHP\PEAR\MDB2.php. When I try to step into this call. That is the correct path to MDB2.php. I also tried making the file permissions more liberal. I don't know. I'm kind of grasping at straws at this point. I do appreciate you sticking this out with me. I hope you had a nice holiday Hugh
    Monday, December 27, 2010 10:34 AM
  • User-919760595 posted
    Hi Martin, I just saw your edit to the previous post. When I installed pear I used "local". I'm pretty sure anyway. I looked and did not find a pear ini in C:\Windows. When I installed it on my laptop I did get a reg file that set environment variables and a key. I did not get that reg file with this install and copied the paths directly into the environment variables. PHP_PEAR_TEST_DIR C:\PROGRA~2\PHP\v5.3\tests PHP_PEAR_SYSCONF_DIR C:\PROGRA~2\PHP\v5.3 PHP_PEAR_PHP_BIN "C:\PROGRA~2\PHP\v5.3\php.exe" Is this where it's looking? Hugh
    Monday, December 27, 2010 10:51 AM
  • User-1672167363 posted

    Hi Martin, Thanks for the tip. I got the driver running outside MDB2. I'll try that blog. The short filenames did not help. When my code reaches this line require_once 'MDB2.php' I still get this error: Cannot find a local copy of the file on server C:\Program%20Files%20%28x86%29\PHP\PEAR\MDB2.php. When I try to step into this call. That is the correct path to MDB2.php. I also tried making the file permissions more liberal. I don't know. I'm kind of grasping at straws at this point. I do appreciate you sticking this out with me. I hope you had a nice holiday Hugh

    The XMAS was good,

    One of the quirks in using PEAR and PHP is where to find the includes.

    The "PHP" "requires_once" library needs to be resolved at server,by pear and php.

    item 1.) For Pear it manages the installed extensions and updates PEAR.ini.

    For the most part PHP has no clue when these changes occur ( exception the library path in PHP.ini).

    item 2.) For the Web Server it only knows what is Relative link from "Root" to current location.

         Layout:        "/ include /.. / app / include /.../"  so how to walk to or seach for what we need?

    item 3.) Good news, Bad News. Most of control relies on the programmer and their style.

        Part  1: A plan is needed put all the common includes in the server at "/ include" and use the "../include " as part of walking

                 to what is needed.  The server is going to CD and Dot its way to code.

                  Note this is very "linux" centric sorry.

      Part 2: A plan is needed to alias or "PATH" add to where

                  the "C:\Program~1\PHP\PEAR\include" is a different type of walk.

    item 4.) The best way maybe is using examples of working layouts and code.

              The blog site that Brian Swan posts has examples and maybe a real help.

                 Good examples are in the PEAR chm help file and the MySQL pdf help files.

    Sorry that there is not just one simple answer.

    I know it is a lot to digest,

    Martin :)

    Monday, December 27, 2010 11:18 AM
  • User-919760595 posted
    I compeletely reinstalled pear and ran the reg file it placed in there for "system" and it still can't find MDB2.php. I don't know quite what to do, however. It's still failing in the same spot. Here's something: the original app had PEAR with only and MDB2 directory in the webdirectory itself. I have not found any documentation to support that sort of install. Maybe that's the way to go here.
    Tuesday, December 28, 2010 2:41 PM
  • User-1672167363 posted

    I compeletely reinstalled pear and ran the reg file it placed in there for "system" and it still can't find MDB2.php. I don't know quite what to do, however. It's still failing in the same spot. Here's something: the original app had PEAR with only and MDB2 directory in the webdirectory itself. I have not found any documentation to support that sort of install. Maybe that's the way to go here.

    Hello,

    Since the devil of problems is with PEAR and MDB2 the best resource is the Faq

    for MDB2.

    Here are some of the on going issues:

    item 1.)  A suggestion from the PEAR site:I get an error! 

                  If you get a PEAR_Error (or a   MDB2_Error object), try using  

                   getMessage() and getUserInfo().

                  They do often give you more information about the cause   of the error. 

    item 2.) "MDB2 Error: not found"

       If you get this error after creating the MDB2 instance it means that you   don't have any MDB2 database driver   installed.

     Since most people use only one database system,   it is unnecessary to install 15 driver files."

    item 3.) Another MDB2 error "pear/MDB2_Driver_XXX requires php extension XXX"
                If you get this error when trying to install a driver it means that

     the php.ini loaded in the given installer does not see the "XXX" extension.   Either you forgot to install the extension all together or you

     need to make sure that the extension is actived in all relevant php.ini files.

     Note that there are usually separate php.ini files for the CLI and your other SAPIs.

    If all else failes do pear install -nodeps MDB2_Driver_XXX and it should work.

    I would suggest that you look at the full discussions at PEAR site.

    LOL

    Martin :)



     

       

    Tuesday, December 28, 2010 3:23 PM
  • User-919760595 posted
    Hi Martin, That's where I started: message: MDB2 Error:not found userinfo: unable to find package 'MDB2_Driver_sqlsvr' file 'MDB2\Driver\sqlsvr.php' The package is installed C:\Program Files (x86)\PHP\v5.3>pear list INSTALLED PACKAGES, CHANNEL PEAR.PHP.NET: ========================================= PACKAGE VERSION STATE Archive_Tar 1.3.3 stable Console_Getopt 1.2.3 stable MDB2 2.5.0b3 beta MDB2_Driver_mssql 1.5.0b3 beta MDB2_Driver_sqlsrv 1.5.0b3 beta PEAR 1.9.0 stable Structures_Graph 1.0.2 stable XML_Util 1.2.1 stable thanks for checking in! I'm still here! I ain't leaving till I figure this out Hugh
    Tuesday, December 28, 2010 4:04 PM
  • User-919760595 posted
    I also posted on the pear forum. I got 20 looks but no replies.
    Tuesday, December 28, 2010 4:07 PM
  • User-919760595 posted
    So I am going line through line in the pear manual following all instructions. One asks to "Check if PEAR is working." So I follow instructions and I see something from a previous post of yours about PHP_PEAR_PHP_BIN I get this. C:\Windows\system32>pear PHP_PEAR_PHP_BIN is not set correctly. Please fix it using your environment variable or modify the default value in pear.bat The current value is: .\php.exe C:\Windows\system32> This was set by the reg file so what is it supposed to be? I am off to find out
    Tuesday, December 28, 2010 6:16 PM
  • User-919760595 posted
    OK, I'm back after carefully reinstalling everything. I installed PHP 5.3.4, I removed the old pear directories and environment variables and carefully read through the pear manual. To test the pear install I tried everything in the manual and it's all working. One test says to run this: require_once 'System.php'; var_dump(class_exists('System')); echo "
    "; require_once 'MDB2.php'; var_dump(class_exists('MDB2')); So both returned true which means Pear and MDB2 are working. BUT! I am still having trouble with the driver. The driver I seek to employ is php_sql_53_nts_vc9.dll which I have tested without pear in php and it is up and working. The Pear database driver is MBDB2_Driver_sqlsvr-1.5.0b3. At first it would not install. I needed to update PEAR to 1.9.1 and MDB2 to 2.5.0b3 which I did successfully using the pear installer I tried "pear install MDB2_Driver_sqlsvr-beta" and it apparently installed the driver as it echoed it's version number. When I look in \MDB2\Drivers is see sqlsvr.php. Yet when I try to connect I get: MDB2 Error: not found unable to find package 'MDB2_Driver_sqlsvr' file 'MDB2\Driver\sqlsvr.php' So it finds pear and MDB2 but not MBD2_Driver_sqlsvr which leads me to believe that the path stuff with include_path is right. Any idea how to trouble shoot this? EDIT: I tried "pear upgrade MDB2_Driver_sqlsrv-beta" and I got nothing to upgrade so I tried "pear install MDB2_Driver_sqlsrv-1.5.0b3" and I got "pear/MDB2_Driver_sqlsrv is already installed and is the same as the released version 1.5.0b3 install failed So the pear installer thinks it is installed
    Wednesday, December 29, 2010 6:02 PM
  • User-1672167363 posted

    Hello,

    I see you have started a new topic and thread.

    I will stay on this one and let some sone else help the the older PHP.

    If you could if not to much of a problem post the

    database code that your having problems with related to this thread.

    Over the week end I install the MDB2 standard libraries and want to test your code adding a fresh view point.

    I was able to get things working for PHP native connections to my "MySQL" and "SQL2008 Server".

    Thanks,

    Martin :)

    Tuesday, January 4, 2011 12:55 AM
  • User-1672167363 posted

    Hi,

    I do not know where your at with the MDB2 and SQL Server drivers.

    Just so you know we have had more users posting and fixing SQL and PHP driver

    issues.

    You may want to check who the posters are and see is they are using the MDB2 or MDB

    in there work.

    At the very least your not the only one working on issues.

    Martin :)

    Wednesday, January 12, 2011 6:59 PM
  • User1624992088 posted

     I have been having the exact same problem.  I think this is due to the issue of mssql not being compiled into PHP on versions 5.3 and above because of many bugs.  While we are adding the native sql server drivers, I think MDB2 is still looking for the old drivers which no longer exist.  I think we are out of luck until mdb2 gets updated to use the new native sql server drivers.

    Friday, January 20, 2012 1:15 PM
  • User-1672167363 posted

    Hello,

    Do you have the SQL Server driver for PHP installed http://www.microsoft.com/download/en/details.aspx?id=17308

    http://learn.iis.net/page.aspx/699/install-the-sql-server-driver-for-php/ install guide.

    " I think this is due to the issue of mssql not being compiled into PHP on versions 5.3"

    Configuration problems not sure can you check you are using the latest Windows Version

    non-thread-safe ? 

    Regards,

    Martin

     

     

     

    Friday, January 20, 2012 1:31 PM
  • User1624992088 posted

     Yes, I have the non-thread safe version installed and can use it as long as I'm not using MDB2.  My comments come from reading the following article.

     http://stackoverflow.com/questions/6753474/connecting-to-ms-sql-from-php-on-iis-using-pear-mdb2

     

     

    Friday, January 20, 2012 3:46 PM
  • User-1672167363 posted

    Hello,

    I have read the article http://stackoverflow.com/questions/6753474/connecting-to-ms-sql-from-php-on-iis-using-pear-mdb2.

    You have the non-thread safe version installed. You can use PHP  as long as your not not using MDB2 .

     I understand the concerns the IIS Forums can not provide fixes for the problems.

    Your comments issues and problems are important and the IIS Forums do welcome your imput.

    For PHP problems please file a report at the PHP bugs site https://bugs.php.net/ they are the experts

    and provide help and support.

    Regards,

    Martin

     

     

     

    Friday, January 20, 2012 4:17 PM