none
Certification failing because 3rd party library references "Windows.Networking.Vpn " RRS feed

  • Question

  • I'm getting the following error during Windows Store 8.1 certification

    • ReactiveUI.Events.dll references the namespace Windows.Networking.Vpn which is not allowed for this app type.

    Is there anyway to get around this? I don't use "Windows.Networking.Vpn " anywhere in my code....

    The 3rd party library I'm using  references "Windows.Networking.Vpn " in the Windows Phone 8.1  RT version as well but the WPA 8.1 RT is able to pass certification... Is this just a different requirement with store vs phone? And I'll need a version of the 3rd party library that doesn't reference "Windows.Networking.Vpn " when I'm using it with Windows 8.1?


    Thursday, September 3, 2015 11:24 PM

All replies

  • Yea I saw that and kind of tried it but I don't think that applies Windows 8.1.... 

    That link is from the "Known Issues for Windows 10 SDK and Tools "

    Like the UWP applications (from my understanding) come with a default.rd.xml file already but I'm not doing UWP ... I'm  just doing Windows 8.1

    I followed steps here

    https://msdn.microsoft.com/en-us/library/Mt148501.aspx?f=255&MSPPError=-2147217396
    just for adding the default.rd.xml but that didn't really work

    I thought about upgrading it up to Windows 10 and trying it ...

    For now the 3rd party library is just a massive helper file so I just copied it over and removed the Windows.Networking.Vpn namespace and it works .....   Like it's not even a "thinks" issue bug type scenario... The library actually references that namespace...    WPA8.1 has no issues with that namespace but W8.1 does :-/  I'm guessing that's just the way it is but wanted to check


    • Edited by shaen Friday, September 4, 2015 1:00 AM
    Friday, September 4, 2015 12:58 AM