locked
PDF icon is not displaying RRS feed

  • Question

  • In SharePoint 2007 pdf icon is not showing

    have installed the PDF Ifilter

    after that done add the image in (window drive):\Program Files\Common Files\microsoft shared\Web Server Extensions\12\TEMPLATE\IMAGES

    after that add the mapping in docicon.xml in (window drive):\Program Files\Common Files\microsoft shared\Web Server Extensions\12\TEMPLATE\XML

    but still its not showing

    please help


    Friday, January 4, 2013 5:22 AM

Answers

  • I am not understanding what is the problem with your server. I have done same many times and works well.

    Just follow same process again and restart the IIS properly and also give read right to all users on pdf icon in images folder.

    Let us know your result


    Hemendra: "Yesterday is just a memory,Tomorrow we may never see"

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    • Marked as answer by vineshnagpal Tuesday, February 19, 2013 5:18 AM
    Friday, February 15, 2013 8:09 AM
    Moderator
  • >nd 2nd one is showing explorer icon in place of pdf icons

    Are you sure you have given the proper PDF image path in 2nd server? verify it again and also make sure that there s no other feature apply (script or any other custom solution) which is overriding this icon.


    Hemendra: "Yesterday is just a memory,Tomorrow we may never see"

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    Please feel free to unmark answer if does not solve your problem.

    • Marked as answer by vineshnagpal Tuesday, February 19, 2013 5:17 AM
    Monday, February 18, 2013 5:13 AM
    Moderator
  • hello Hemendra

    its working fine now

    i have copy the image of pdf from one server to another nd done complete crawl

    now its showing the pdf icon

    thanks a lot to all for you replies

    please see the below link and give me any solution for this

    http://social.msdn.microsoft.com/Forums/en-US/sharepointcustomizationlegacy/thread/28812850-1cb4-4611-aefb-7a54d52ca120

    Monday, February 18, 2013 5:23 AM

All replies

  • Hi,

    Few points:

    1. Did you restart he IIS after making above changes? if not then please do so

    2. Check that image permission in images folder. It should have atleast read right.

    Let us know your result


    Hemendra: "Yesterday is just a memory,Tomorrow we may never see"

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    Friday, January 4, 2013 8:44 AM
    Moderator
  • Agree with Hemendra above.

    I had the same issue a few months ago.

    See following article http://support.microsoft.com/kb/832809?wa=wsignin1.0

    You will need to copy and past it into url as I am not verified yet!

    I followed your exact steps above and all that was needed was an IIS reset, which happens on my servers at the weekend so all servers eventually could see the pdf icon.

    Thanks

    Friday, January 4, 2013 1:14 PM
  • thanks for reply

    i have done all the above activities and refer this link

    http://support.microsoft.com/kb/832809?wa=wsignin1.0

    but its still not working :(

    please help

    Friday, February 15, 2013 6:31 AM
  • I am not understanding what is the problem with your server. I have done same many times and works well.

    Just follow same process again and restart the IIS properly and also give read right to all users on pdf icon in images folder.

    Let us know your result


    Hemendra: "Yesterday is just a memory,Tomorrow we may never see"

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    • Marked as answer by vineshnagpal Tuesday, February 19, 2013 5:18 AM
    Friday, February 15, 2013 8:09 AM
    Moderator
  • thanks for your response

    i have two server

    have tried same steps on both the servers.but its show pdf icon only on one server

    nd 2nd one is showing explorer icon in place of pdf icons

    Friday, February 15, 2013 12:22 PM
  • >nd 2nd one is showing explorer icon in place of pdf icons

    Are you sure you have given the proper PDF image path in 2nd server? verify it again and also make sure that there s no other feature apply (script or any other custom solution) which is overriding this icon.


    Hemendra: "Yesterday is just a memory,Tomorrow we may never see"

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    Please feel free to unmark answer if does not solve your problem.

    • Marked as answer by vineshnagpal Tuesday, February 19, 2013 5:17 AM
    Monday, February 18, 2013 5:13 AM
    Moderator
  • hello Hemendra

    its working fine now

    i have copy the image of pdf from one server to another nd done complete crawl

    now its showing the pdf icon

    thanks a lot to all for you replies

    please see the below link and give me any solution for this

    http://social.msdn.microsoft.com/Forums/en-US/sharepointcustomizationlegacy/thread/28812850-1cb4-4611-aefb-7a54d52ca120

    Monday, February 18, 2013 5:23 AM
    • Marked as answer by vineshnagpal Friday, May 17, 2013 5:15 AM
    • Unmarked as answer by vineshnagpal Friday, May 17, 2013 5:15 AM
    Wednesday, March 6, 2013 5:27 AM