none
Viewing web app in android emulator

    Question

  • Hi all

    Can give some advice or point me a decent tutorial on how to use the android emulator in VS2015?

    I can launch an android emulator from VS Tools but even when it is fully loaded it never appears in the list of available devices to start the web app in debug mode. I have read load of articles about how to use it but they all seem to imply that the options will be available once the emulator loads.

    I am running VS2015 Pro on Windows 10 and have installed the Visual Studio Emulator for Android which shows under VS Tools.

    Thanks

    Friday, December 09, 2016 4:01 PM

All replies

  • Hi my friend,

    Welcome to the MSDN forum.

    >> Can give some advice or point me a decent tutorial on how to use the android emulator in VS2015?

    You can have a look at Visual Studio Android Emulator and this guide explains how to configure and use the Visual Studio Android Emulator to develop Xamarin.Android apps in Visual Studio 2015.

    >> I am running VS2015 Pro on Windows 10 and have installed the Visual Studio Emulator for Android which shows under VS Tools.

    To run the emulator, the computer must meet the requirements to run Hyper-V. Hyper-V requires a 64-bit version of the Pro edition of Windows 8, Windows 8.1, Windows 10, or higher. For more information about requirements, see System Requirements for the Visual Studio Emulator for Android.

    Visual Studio Emulator for Android is a component of the cross-platform tools available in Visual Studio and will be installed during a custom Visual Studio setup when you select Cross-Platform Mobile Development, then Common Tools and Software Development Kits, and then Visual Studio Emulator for Android. Please go to Control Panel—Uninstall a program and right click the VS 2015 item and select Change-Modify, then check if the above options are selected. If not, please check them and update the VS to install. For more detail information, please check here.

    >> I can launch an android emulator from VS Tools but even when it is fully loaded it never appears in the list of available devices to start the web app in debug mode. 

    What’s the project type that you created, you can try to create a C#-Windows-Universal-Blank App, then you should can get a similar emulator options like the following:

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, December 12, 2016 7:26 AM
    Moderator
  • Hi Sara

    Thanks for this but unfortunately I have been through that article in painstaking detail but still no devices ever show up in VS.

    I have given up on this now as I have wasted too much time on it. I cannot understand why this is such a complicated process.

    Thanks anyway.


    Monday, December 12, 2016 8:58 AM
  • Hi WldgDevelopment,

    Thank you for your update and sorry for this inconvenience.

    Out forum is to discuss Visual Studio WPF/SL Designer, Visual Studio Guidance Automation Toolkit, Developer Documentation and Help System, and Visual Studio Editor, if you have any other issue about this in the future, please feel free to let me know.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, December 13, 2016 7:44 AM
    Moderator