locked
VS2013 startup error, event type:clr20r3 p4:mscorlib p9:system.ArgumentNullException RRS feed

  • Question

  • Yesterday with vs2013 is normal, and then open the morning to collapse.

    问题签名:
      问题事件名称: CLR20r3
      问题签名 01: devenv.exe
      问题签名 02: 12.0.21005.1
      问题签名 03: 524fcb34
      问题签名 04: mscorlib
      问题签名 05: 4.6.1098.0
      问题签名 06: 58cf7273
      问题签名 07: 17c2
      问题签名 08: 1d
      问题签名 09: System.ArgumentNullException
      OS 版本: 6.1.7601.2.1.0.256.1
      区域设置 ID: 2052
      其他信息 1: 0a9e
      其他信息 2: 0a9e372d3b4ad19135b953a78882e789
      其他信息 3: 0a9e
      其他信息 4: 0a9e372d3b4ad19135b953a78882e789

    联机阅读隐私声明:
      http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0804

    如果无法获取联机隐私声明,请脱机阅读我们的隐私声明:
      C:\windows\system32\zh-CN\erofflps.txt

    Wednesday, November 1, 2017 6:04 AM

All replies

  • It's trying to run the IDE with .NET v2.X runtime, and of course that won't run.

    Please see if your .NET v4.5 runtime is there, and if it is, try to repair it.

    Wednesday, November 1, 2017 8:32 AM
  • We have two colleagues facing this issue today. We are using VS2013 Premium Update 4. The problem persists even after re-installation. Installing VS2013 Ultimate now.

    Wednesday, November 1, 2017 9:37 AM
  • I don't think it'll help, as it'll just check whether the runtime is installed by checking a registry key.

    Btw, I suggest you try checking whether your %windir%/SysWOW64/mscoree.dll is version 4.0.X. (Yup, on my system with .NET v4.6 installed, it's still 4.0.40305.0. And you look in SysWOW64 folder because the IDE runs as 32-bit application. You can see it runs from Program Files (x86) folder )

    Wednesday, November 1, 2017 9:45 AM
  • Wow! I'm getting this too. Just this morning. What the hell is going on?
    Wednesday, November 1, 2017 12:33 PM
  • Hi, I'm also having this issue. It worked yesterday fine, but this morning VS just crashes a few seconds after loading
    Wednesday, November 1, 2017 12:47 PM
  • This is the error I found in my ActivityLog.xml when I started devenv /log.

    ...AppData\Roaming\Microsoft\VisualStudio\12.0

        <record>381</record>
        <time>2017/11/01 12:42:32.790</time>
        <type>Error</type>
        <source>UserConnection</source>
        <description>Unexpected exception Buffer cannot be null.&#x000D;&#x000A;Parameter name: buffer    at Microsoft.VisualStudio.Shell.ThreadHelper.InvokeOnUIThread(InvokableBase invokable)&#x000D;&#x000A;   at Microsoft.VisualStudio.Shell.ThreadHelper.Invoke[TResult](Func`1 method)&#x000D;&#x000A;   at Microsoft.VisualStudio.Shell.Connected.ConnectedUser.AvatarCache..ctor(AvatarSize size, Byte[] value, Boolean isGenerated, Logger logger)&#x000D;&#x000A;   at Microsoft.VisualStudio.Shell.Connected.ConnectedUser.ProfileCache..ctor(Profile profile, Guid serverId, Uri profileUri, String emailAddress, Logger logger)&#x000D;&#x000A;   at Microsoft.VisualStudio.Shell.Connected.ConnectedUser.IdeConnector.&lt;ConnectAsync&gt;d__1.MoveNext()&#x000D;&#x000A;--- End of stack trace from previous location where exception was thrown ---&#x000D;&#x000A;   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)&#x000D;&#x000A;   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)&#x000D;&#x000A;   at Microsoft.VisualStudio.Shell.Connected.ConnectedUser.IdeUserSession.&lt;ConnectAndInitializeSessionAsync&gt;d__a.MoveNext()&#x000D;&#x000A;--- End of stack trace from previous location where exception was thrown ---&#x000D;&#x000A;   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)&#x000D;&#x000A;   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)&#x000D;&#x000A;   at Microsoft.VisualStudio.Shell.Connected.ConnectedUser.BaseUserSession.&lt;ConnectAsyncImpl&gt;d__15.MoveNext()&#x000D;&#x000A;--- End of stack trace from previous location where exception was thrown ---&#x000D;&#x000A;   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)&#x000D;&#x000A;   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)&#x000D;&#x000A;   at Microsoft.VisualStudio.Shell.Connected.ConnectedUser.BaseUserSession.&lt;ConnectAsync&gt;d__2.MoveNext()&#x000D;&#x000A;--- End of stack trace from previous location where exception was thrown ---&#x000D;&#x000A;   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)&#x000D;&#x000A;   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)&#x000D;&#x000A;   at Microsoft.VisualStudio.Shell.Connected.ConnectedUser.BaseUserSession.&lt;PollConnectAsync&gt;d__1e.MoveNext() for license source IdeUser</description>
      </entry>

    Wednesday, November 1, 2017 12:52 PM
  • The only thing I did differently this morning was change my windows domain account password. Did you?
    Wednesday, November 1, 2017 12:55 PM
  • Something is broken at https://visualstudio.com

    If you're are signed in today, VS will fail.

    Wednesday, November 1, 2017 1:27 PM
  • I was able to get back in by resetting user data.

    C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE>devenv.exe /resetuserdata

    ***  WHEN VISUAL STUDIO RESTARTS, DO NOT LOG INTO VISUALSTUDIO.COM  ***

    • Proposed as answer by Abbotn2 Wednesday, November 1, 2017 2:38 PM
    • Unproposed as answer by Abbotn2 Wednesday, November 1, 2017 7:10 PM
    • Proposed as answer by ashz1 Thursday, November 2, 2017 8:43 AM
    Wednesday, November 1, 2017 1:32 PM
  • I was able to get back in by resetting user data.

    C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE>devenv.exe /resetuserdata

    ***  WHEN VISUAL STUDIO RESTARTS, DO NOT LOG INTO VISUALSTUDIO.COM  ***

    I'm logged in, zero issues.

    This is for VS2017, perhaps there is something going on with earlier versions. I'm moving this thread to the Visual Studio forums.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.
    VB Forums - moderator
    profile for Karen Payne on Stack Exchange, a network of free, community-driven Q&A sites


    Wednesday, November 1, 2017 1:49 PM
  • No. Visual Studio 2013
    Wednesday, November 1, 2017 2:09 PM
  • I tested this on another system where I also have VS2013 installed.

    That IDE was not logged into visualstudio.com and it started fine. When I logged into visualstudio.com, it started to fail like my other system.

    Wednesday, November 1, 2017 2:17 PM
  • Same issue here. Although if I reset my user data, I can no longer run app due to expiration. As soon as I try to sign in again, it goes through the process and just sits there. Totally stuck.
    Wednesday, November 1, 2017 4:57 PM
  • Using the /resetuserdata switch let me bring up devenv.exe, but we're licensed through the Action Pack which means I have to log in to work haha. It locked up after login and it's been sitting here for about five minutes.

    Vacation day? :P

    Update:

    I've chatted online with the Partner people, who said my account is fine (I knew that)

    I've chatted online with the Visual Studio people, who said they can't help me with a technical problem

    Now I'm on hold at the 800 number.

    • Edited by CodeDude1962 Wednesday, November 1, 2017 6:52 PM
    Wednesday, November 1, 2017 4:59 PM
  • Same issue here. Although if I reset my user data, I can no longer run app due to expiration. As soon as I try to sign in again, it goes through the process and just sits there. Totally stuck.

    Experiencing exactly same thing. Product has completely locked me out. Microsoft QA is absolutely abysmal. :(


    Jules Winfield

    Wednesday, November 1, 2017 5:11 PM
  • Same issue on multiple machines here at the office today. Sign in is necessary to validate license and get to code. Someone please update this thread with any further info on this issue as it becomes available. Please\ThankYou

    Brian Stobbe

    Wednesday, November 1, 2017 7:33 PM
  • Had the same issue that just started this morning.

    I was able to start Visual Studio 2013 after disabling my network connections. 

    After reconnecting I was signed out of my company login.   When trying to connect again the login goes away forever.

    I am not able to login to Microsoft, however Visual Studio is working properly and my VSTS connection appears to be working fine.


    • Edited by FredF101 Wednesday, November 1, 2017 7:41 PM elaborated on the working status
    Wednesday, November 1, 2017 7:38 PM
  • The solution is to install Update 5

    For details:

    https://social.msdn.microsoft.com/Forums/en-US/46728392-212b-405e-aea0-2ab02f91cd1f/visual-studio-2013-crashes-on-startup?forum=visualstudiogeneral


    Jules Winfield

    Wednesday, November 1, 2017 8:29 PM
  • Hi all,

    Please install Update 5 for Visual Studio 2013

    https://my.visualstudio.com/Downloads?q=Visual%20Studio%202013%20Update%205

    If you cannot download the web installer

    1. Reset your settings using devenv /resetuserdata to fix the crash
    2. Open Visual Studio
    3. Use an MSDN product key to activate your Visual Studio
    4. Tools -> Extensions and Updates
    5. Select tab Updates
    6. Install Update 5 

     

    Best regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, November 2, 2017 2:46 AM
  • Same issue here with VS 2013 Community. Would love to download Update 5 but the page is inresponsive. Guess why!? ;-)

    No issues with VS 2015 Community though. But I need to get my 2013 running again...

    Thursday, November 2, 2017 12:15 PM
  • Can anyone please provide a working link for 2013 Update 5?

    After /resetuserdata I'm stuck. Can not sign in to Visual Studio...

    Thursday, November 2, 2017 12:54 PM
  • Can anyone please provide a working link for 2013 Update 5?

    After /resetuserdata I'm stuck. Can not sign in to Visual Studio...

    After some search I found: Stackoverflow: Microsoft Visual Studio Ultimate 2013 with Update 5 [closed]. There it's answerIt's the direct download link, that points to an iso.

    Running the update from there solved it for me.


    • Edited by monomorph Thursday, November 2, 2017 2:08 PM
    • Proposed as answer by monomorph Thursday, November 2, 2017 2:11 PM
    Thursday, November 2, 2017 2:07 PM