locked
Windows 8 and Cookies

    Question

  • I have installed Windows 8 on two machines, one being a 32 bit and the other a 64 bit machine. Both run flawlessly, except for the fact that both machines under IE 10 do not accept cookies. I set IE up as default settings and customized settings to accept cookies, but they both fail. Any fixes?
    Wednesday, September 14, 2011 8:41 PM

Answers

  • Hey BeHuge,

     

    While using the Windows Developer Preview, try enabling Compatibility View by using the desktop version of Internet Explorer 10 to navigate to a website that has had this problem and then click the broken page icon (Picture of the Compatibility View button (off)) in the Address bar. The icon will turn blue and your page will refresh. After that has finished try logging into the website again to see if the cookies is accepted.

    If that doesn't help, please answer the following question in your next reply:

    • What website/websites are you using when you encounter this problem? If this problem occurs on every website, please list a few examples for us.
    • What error or problem are you receiving that points toward cookies being the problem? 

     

    Hope that helps, look forward to hearing back from you.

    Thursday, September 15, 2011 9:25 PM
    Moderator

All replies

  • I have installed Windows 8 on both a 32 bit and 64 bit machine. IE 10 does not accept cookies in either version. I have gone thru IE settings and tried both by "default" and by "customized" by to no avail.... any ideas?
    Wednesday, September 14, 2011 8:52 PM
  • use IE9 that also comes installed on it? I don't know, there aren't as many options for ie 10 than I would have liked.  I would just use ie 9 for now becasue of the compatibility issues.
    Wednesday, September 14, 2011 9:06 PM
  • Where did you find IE9?
    Wednesday, September 14, 2011 9:10 PM
  • Hey BeHuge,

     

    While using the Windows Developer Preview, try enabling Compatibility View by using the desktop version of Internet Explorer 10 to navigate to a website that has had this problem and then click the broken page icon (Picture of the Compatibility View button (off)) in the Address bar. The icon will turn blue and your page will refresh. After that has finished try logging into the website again to see if the cookies is accepted.

    If that doesn't help, please answer the following question in your next reply:

    • What website/websites are you using when you encounter this problem? If this problem occurs on every website, please list a few examples for us.
    • What error or problem are you receiving that points toward cookies being the problem? 

     

    Hope that helps, look forward to hearing back from you.

    Thursday, September 15, 2011 9:25 PM
    Moderator
  • @Steven: I am experiencing this as well, whether I use the Compatibility View or not...

    The website I have a problem with is a single sign-on site that is used by the various websites hosted by my company. In other words, we have different websites and some of them require a login... similar to the Live sign-on mechanism, you are always redirected to that page when attempting to log in one of those sites, and you come back to the original site on successful login.

    The problem is, IE will always come back to that login page even though you successfully sign in... i.e. you enter your credentials, you hit 'Sign In', it seems to work but then suddenly comes back to the same page with no error message (of course because this was a successful login).

    Any thoughts? 

    Wednesday, September 28, 2011 7:40 PM
  • Hey Stivz,

     

    Please answer the following questions in your next reply:

    Does this problem happen on all websites that use cookies to login (this forum for example)?
    Does the login process complete properly on a computer using Internet Explorer 9, 8, etc.?

     

    Try adding all of the addresses that are involved with the login to the Trusted sites list which can be found by following these steps:

    • Open the desktop version of Internet Explorer
    • Click Tools
    • Click Internet Options
    • Click the Security tab
    • Click Trusted sites
    • Click Sites

     

    Then add the locations from the page you are logging into as well as any redirecting URL's that are used in the login process.


    Steven
    Thursday, September 29, 2011 2:24 AM
    Moderator
  • Thanks for quick reply, Steven.

     

    These websites have been working without problems for a few years already, on all earlier versions of IE.

    I did try adding the site to the Trusted Sites but it didn't change anything.

    IE1 on Windows 8 Develope Preview does work fine with other login mechanisms such as this site.

     

    Is there anything that changed significantly in how IE 10 handles cookies, which our development team should be aware of?

    Thursday, September 29, 2011 12:36 PM