none
The "Sensor restarting every couple of seconds" issue, why is it still a thing? RRS feed

  • Question

  • First of all, here's my specs:
    MB: MSI B450-A PRO
    CPU: AMD RYZEN 7 2700X 3.70GHz (with no integrated graphics)
    GPU: EVGA 2070 xc
    RAM: 16Go

    I have an unofficial adapter, but the thing is that the kinect is working flawlessly (no disconnection, no bad framerates in Kinect Studio) on my 4 years old "gaming" laptop (that was already pretty weak for the time)
    here's the specs of this one (it's the HP pavillion gaming 15-ak106nf:
    CPU: Intel i5 6300HQ 2.30GHz
    GPU: GeForce GTX 950M
    RAM: 8Go


    Hi, I am a (not so) proud owner of an xbox one Kinect v2 since April, but as you can guess, I encountered the famous "Sensor restarting every couple of seconds" issue from the beginning and the Kinect studio also has frame rate issues, so naturally I searched everywhere for a solution, and I quickly understood that my issue was that I had an AMD based motherboard, and most of them do not have a compatible USB chipset (but I still tried the different troubleshooting steps I found online just in case).
    I bought an expansion card with a Renesas chipset µPD720202, but after installing it, I still had the "Unknown USB controller" warning in Kinect Configuration Verifier, and the issue persisted.

    So the next thing I tried was to connect the Kinect via the usb-c port on my graphics card, it seemed to work (even if the warning was still there), but it was just because the disconnection took more time, and most of the time, I just had to restart the kinect once in a day.
    (odly enough, after an update for my motherboard USB was installed, the kinect started the behave as "good" as on the usb-c)

    But recently the issue started to get worse and worse, so I bought an expansion card with a chipset known to work (the Renesas µPD720200), and lo and behold: the warning in the Kinect Configuration Verifier disapeared, and instead, a green checkmark appeared before my eyes, I was happy, but not for long, because after testing the Kinect, the disconnection issue took longer but persisted, and the fps in Kinect Studio were still awfull...

    (It's clearly not a power issue,but I did not connect the expansion card to power, yet, and just in case I will test with it connected to power, the cable arrives this saturday so I'll update then)
    (And yes I tried multiple times to uninstall, delete and reinstall different drivers in different ways, I verified multiple times the sound and confidentiality parameters, I've tested all the USB ports on my mobo, but I still have that issue)

    (As I'm writing this, the Kinect Configuration Verifier just told me that: "Required Kinect Software not detected" for the last two steps, but odly enough it's still "working" like before (the camera app still detects my Kinect as a working webcam, and the Kinect Studio still detects my kinect too))

    So now I wonder if this is an issue that won't be fixable because of how Intel and AMD CPUs are working differently? Or is this because I don't have integrated graphics in my CPU and that's why some users with AMD CPUs don't have issue and why some users with Intel CPUs have issues, and that in some way it's important to have it?


    TL;DR

    -Bought a kinect, got issues with my AMD based motherboard but works perfectly with my 4yo laptop with an Intel CPU
    -Connected to the usb-c of my GC, still got issues but better
    -After some time it got worse
    -Bought a confirmed expansion card, green checkmarks but still have the same issues (still have to verify with it connected to power)
    Question: Is this an unfixable issue because of how AMD CPUs "work differently" than Intel CPUs? or because I don't have integrated graphics?



    • Edited by Silails Thursday, September 10, 2020 7:59 PM precidions about my tests
    Wednesday, September 9, 2020 11:17 PM

All replies

  • Hey,

    So I was having the same issue when i first plugged in my Kinect V2, and was annoyed when I switched out a few power adapters, only to still have the issue continue on each one. I started to think back on installation guide steps, and I remembered that one of the tips I was given, was to plug it into the USB 3.0 port closest to the graphics card, because there could be an issue with it working otherwise. Which is where I initially had it plugged in to on the back of my PC. Thinking about that as a possible point of issue, I figured it wouldn't hurt to try plugging it into each USB 3.0 port I had to see if switching the port would get it to finally work, before trying other solutions. After switching it over to a different USB 3.0 port once, it actually worked and stayed powered on!! I was super annoyed that THAT was the issue, but happy that I finally had it up and running. 

    Hopefully, just try moving it around to every USB 3.0 port you have on the back of your board, and even if you have any on the front of your PC as well. With any luck, I hope it will finally work like mine did.

    Thursday, September 10, 2020 2:26 AM
  • Hi, thanks for the response, but the thing is, I don't think that the GPU has anything to do with the issues because like I wrote, I've plugged the Kinect directly to my GPU and it only was a bit better but only by chance and i guess because the usb chip/drivers that Nvidia/EVGA uses seem to be a tad bit better for the kinect, and I've already tested all my ports on my mother board, plus it's not the gpu that takes care of the usb ports (excpect for the usb c on some GPUs), it's the usb chip and/or the CPU (probably both),

    My guess as to why your Kinect worked on the USB port that is closer to your GPU is because it's a 3.1 gen 1 while the others are either 3.0 or 3.1 gen 2 and that the chip for that takes care of that port, is a compatible one, because for me, on my mother board, it's only via the 3.1 gen 1 port that I get the "best" (bad) performances on kinect studio

    And actually, according to MSI support page for my mobo, it's the CPU that takes care of the 2 gen 1, and an other chip that takes care of the gen 2 and the 2.0, so maybe the issues are related to that?

    "AMD® B450 Chipset

    • 2 x USB 3.1 Gen2 (SuperSpeed USB 10Gbps) Type-A ports on the back panel
    • 2 x USB 3.1 Gen1 (SuperSpeed USB) ports available through the internal USB 3.1 Gen1 connector
    • 6 x USB 2.0 (High-speed USB) ports (2 Type-A ports on the back panel, 4 ports available through the internal USB 2.0 connectors)

    AMD® CPU

    • 2 x USB 3.1 Gen1 (SuperSpeed USB) Type-A ports on the back panel"

    (I don't have any 3.0, I only have 2*2.0, 2*3.1 gen and 2*3.1 gen 2




    • Edited by Silails Thursday, September 10, 2020 8:16 PM typos and precision
    Thursday, September 10, 2020 8:13 PM
  • (It's clearly not a power issue,but I did not connect the expansion card to power, yet, and just in case I will test with it connected to power, the cable arrives this saturday so I'll update then)
    UPDATE: it didn't change anything :(
    Friday, September 11, 2020 12:39 PM
  • Have you tried it on an Intel machine(e.g. your old laptop?) recently and for long enough to verify it might be the AMD vs Intel thing?

    I've never really asked or read about this but the fact that they're making it a point to have an Intel chip, might actually be a hard requirement.

    Friday, September 11, 2020 7:06 PM
  • Yes I did (and with the 2004 update of course) and it works flawlessly, but the thing is that some people with intel machines have reported (on this forum) the exact same problems, which is odd because it would have been easier to understand that it's because amd cpus aren't working properly because it's a different architecture (or whatever else), but no, some intel users have issues, and some amd users don't have any or they had but getting an expansion card resolved their issues.

    The thing I really want to know is why those issues happen, at this point even if a dev or someone who checked into the codes/drivers or idk what else that make things works, even if they sayed why it's working for some and not for other but say that it's un fixable without changing CPU, I would be somewhat releaved.
    • Edited by Silails Friday, September 11, 2020 8:37 PM typos
    Friday, September 11, 2020 8:34 PM
  • Little update (and rant):
    So when using VgbView.exe (I suppose that it's supposed to launch with VisualGestureBuilder.exe but this one launches but does nothing for me) it does not struggle with the frames (and thinking about it, when it works for Driver4VR, there's no frame rate issue when tracking my body either) so what it makes me think is that it's probably more about the overall depth detection and rendering that is causing frame issues, so the frame rate issue and the disconnection issue are probably not related, which is not great for finding fixes :(

    (rant: the thing that infuriates me is that the support for the kinect v2 on windows was dead years before it's support was dropped, they made little to no effort helping or communicating on those well known issues, the proof is that we are 6 years later (for the v2) and we still have no clue why those issues appear)
    Friday, September 11, 2020 9:09 PM
  • UPDATE (sorry for the spam):

    I don't really know what I'm doing at all, but when cheking the process KinectService.exe with Process Hacker, first red(ish) flag is that on my laptop under the "General" Tab in the File section, there is a N/A in place of the "(Verified) Microsoft Corporation" that my desktop has (when clicked on, it shows the certificat)

    Second thing is that under the "Environement" tab, the value for "PROCESSOR_ARCHITECTURE" are "AMD64" for both of my computers, despite my laptop having an Intel CPU, is that normal? (it still says "Intel64 Family[...], GenuineIntel" for PROCESSOR_IDENTIFIER though)


    • Edited by Silails Friday, September 11, 2020 10:11 PM precision
    Friday, September 11, 2020 10:08 PM
  • 1) From a bit of googling, AMD64 is an instruction set, not the chip arch itself. When 64bit came out, AMD was the first one to implement it, so the instruction set was named AMD64. Intel adopted it at first, but now have a different instruction set called Intel 64. That's what I understood at least.

    I also remember linux distros have been using amd64 as an identifier for 64bit packages and distros since a long time ago, regardless of cpu brand.

    2) There was never a compatibility study or some concrete reason/guidelines as to what works and what doesn't. There have been some people who have Renesas products which did not work. There are multiple factors at play, so it's not straightforward. The new Azure DK might also use a different usb library than the previous two, libusb but I see it also works with WinUSB. libusb is cross platform, but don't know if that was the only reason they switched to it, or perhaps it's more stable. I do know that libfreenect uses libusb to interface with Kinect v2(and probably v1 as well).

    3) Looking at Azure DK docs I also see these.

    Look at these: https://github.com/microsoft/Azure-Kinect-Sensor-SDK/issues/427

    https://docs.microsoft.com/en-us/azure/kinect-dk/troubleshooting#usb3-host-controller-compatibility

    They might affect v2 in the same way. The Host Controller, the usb driver it uses, the container ID. All can be relevant. Perhaps you can take a look with USBView?!

    4) There's another case for USB issues. I remember reading that after a cold boot, USB3 ports start at 2.0 speeds but don't always rev up to 3.0 speeds properly, which can cause Kinect to not connect. But this usually fixes after a restart or two. This is what the sticky troubleshooting guide refers to as "Checking if USB operates on superspeed".

    5) I almost never get a green mark for the controller on Kinect Configuration Verifier. They almost always are orange.

    6) The troubleshooting steps you found, were they from the sticky page on this forum or external? Just checking.

    7) I remember that *some* people lately had reconnects after the last update of the Kinect driver, due to permission issues for the audio on Windows 10(and the camera I think).



    Saturday, September 12, 2020 7:56 PM
  • Hi, thanks for taking your time to respond to my questions

    1) I've searched on google just after asking for amd64, my bad for not editing it out ^^'

    2) like I said on my first post, I bought a expansion card with the Renesas chip µPD720202 this one didn't work, but the one I recently bought was confirmed to work (the µPD720200) and everything is green in Kinect Config Verif (except for the "Update Configuration Definitions" and from time to time the "Verify Kinect Depth and Color Streams" but it's linked to the disconnection problem)

    What I find odd is why pluging in the (seemingly) same expansion card is working for some, but not for others, it's clearly not a power issue otherwise it wouldn't work on my laptop, it's not the expansion card usb chip which is at fault either, otherwise it wouldn"t work for anyone (I think), maybe my expansion card as some component that are different from the confirmed card?)

    3)  IsUserConnectable       : yes
    doesn't seem to be the same issue as the first link (or maybe I missed the point)
    also (yes I repeat myself ^^') I'm 99% sure it's not a power issue, otherwise it wouldn't work on my laptop too

    4) I've verified with USBTreeViewer and it does say that it opperates at Super Speed (although it's presented like that:

    Device Bus Speed         : 0x02 (High-Speed) -> not true, see below in Connection Information V2
    [...]
     DevIsOpAtSsOrHigher     : 1 (Is operating at SuperSpeed or higher)
     DevIsSsCapOrHigher      : 1 (Is SuperSpeed capable or higher)
    )

    6) Yes that's what I was refering to (but also some other pages found simply by "googleing" the issue

    7)I also verified the permissions countless times, with no effect on the issue

    Might not be related because I have the same issue on my laptop: I just remembered that it might be
    my motherboard that doesn't want to deliver the power or data transfert rate needed
    for the kinect, I just remembered that I have a wifi dongle that,
    when connected to any 3.1 port on my MB, it says "This Device Can Perform Faster in USB 3.0"

    But I would lean more towards the idea that the problem comes from the CPU in some way.



    • Edited by Silails Sunday, September 13, 2020 5:14 PM
    Sunday, September 13, 2020 5:12 PM
  • No problem.

    2) This whole "is verified to work" is not 100% true. It might work for people in their configurations. Your configuration is not 100% the same as theirs. Talking about the mobo, the bios, the settings in windows, the cpu you have on it and how that works with the mobo. Since we don't know what exactly is the reason, you can't lean on "I bought one that works for someone else". For all we know this could be a BIOS issue.

    4) This one is probably not your issue. While you do see them values correct now, they might not be around the time the Kinect is initialized. The only way I've found that works is a reboot. Perhaps init work doesn't poll, but ask and cache the result. Again, I just mentioned it because the speed is also a general issue.

    That point about the wifi dongle might be a clue. Perhaps the backwards compatibility with devices that require earlier gen protocol, is not correct? Or there is some bloatware which messes up with this because it tries to squeeze all bandwidth from hte new gen bus?

    Sunday, September 13, 2020 5:56 PM
  • 2)Ok I see ^^'

    4)How do I ask and cache the result?^^'



    About the backward compatibility, my BIOS has some settings for the PCI's:
    PCI_E1 - Max Link Speed: [Auto/Gen 1/Gen 2/Gen 3]
    Chipset Gen Switch: [Auto/Gen 1/Gen 2/Gen 3]
    Above 4G memory/Crypto Currency mining: [Enabled/Disabled]
    PCI_E1 Lanes Configuration: [Auto/x8+x8/x4+x4+x4+x4]

    Do you think that any of them would be of any help?
    And is there any way that I could detect which software eats my system bandwith?
    Sunday, September 13, 2020 8:07 PM
  • 4) Basically, just ask for the device once and stop trying. If it were polling for the device and the USB3.0 had spun up to superspeed after logon, then at some point it would have connected. But instead it needs a restart. Anyhow, I'm not too sure about this. This might be some kind of issue with USB Container IDs instead. Not sure. But this is a different problem.

    As for the rest, not sure. Could be, but you'd have to check with your mobo manual. See if you can set one of those to a different gen which emulates the older USB the device is expecting.

    I don't think there's a way to visualize bandwidth. None that I've come across at least. But if I were you I'd check any bloatware that the manufacturer installs. e.g. in Dell laptops, there are soo many apps that Dell usually has pre-installed. Some of those might be "optimizing" stuff.

    Thursday, September 17, 2020 11:39 PM
  • Thanks for the responses.

    So I tested different options in the bios and it didn't seemed to do anything.

    I would like to test the kinect on safe mode to have the best environement possible for the kinect (at least that's what I suppose), I added KinectMonitor to the safemode registery and so I can succesfully click on connect to service without errors, but I have nothing on screen and the kinect doesn't lightup, it seems that the NUI Sensor has a warning sign on it and I think that's why I don't have anything even if it's just the mic (because of the issue where when the mic is not authorized or deactivated, it doesn't work) what do you think?
    https://imgur.com/xdKFLWP
    • Edited by Silails Sunday, September 20, 2020 10:22 PM
    Sunday, September 20, 2020 10:18 PM
  • Not sure, but I think Safe Mode doesn't load up drivers it doesn't need because it's mostly intended for fixing OS stuff. So i have no idea if you can allow stuff to be loaded in. Worth a shot, if you can do it though.

    As for the Mic array, unless you can authorize it in SafeMode it probably won't work. v2 SDK is an all-inclusive by default provider, so if sth doesn't work, the service won't give you data.

    Also you better check that superspeed is being used for USB3 in Safe Mode. If mic array is not the issue, this is another reason why it might not light up.

    I'm not that familiar with Safe Mode. I just know it's constrained in some ways by removing "clutter" so you can troubleshoot stuff.

    PS: Have you checked either of these out? https://social.msdn.microsoft.com/Forums/en-US/7a9f139d-85fe-4e68-9ad2-5456f8e1f173/kinect-v2-disconnects-and-reconnects-on-recent-intel-chips-solution?forum=kinectv2sdk

    or

    https://skarredghost.com/2018/03/01/fix-kinect-v2-not-working-windows-10-creators-update/

    Both deal with some weird sleep/charging functions that are hidden in the system which can very well lead to disconnects because the device is not getting enough power and constantly to pass data around, or even operate properly.

    Sunday, September 20, 2020 10:29 PM
  • For the Safe Mode, I think I will try and search a bit more, but according to what you said, I don't have any big hope that I will manage to make the kinect turn on, but I don't want to give up trying to run the Kinect in a really clean environement ><'

    For the other stuff, yes I've already tried both of them (even with my amd mobo) but it did nothing (and just like many others, LowerFilters wasn't even in the registery directory, I added it anyways, it did nothing)
    Only thing that I didn't do is that I saw that there were two values proposed for the intel chip registery solution (0x7e060 and 0x7e066) but I didn't try the second value before, but it changed nothing (mostly because it's for Intel mobos)

    I also verified that there were no power saving features for the usbs or PCIE slots enabled in power management and in the BIOS, but nothing changed (except if I missed something)

    If it's a power issue, it's weird that my 4 yo mid-end laptop has no struggles with my kinect.
    Monday, September 21, 2020 6:21 PM
  • Good luck with the Safe Mode. Report back if you manage it.

    It's not weird.In Desktops it used to be that front USB panels got less power than the ones in the back which is why people wrote that it works better if connected on the back panels. Not sure if that applies still, or in every mobo though.

    Btw, my laptop is 5+ yo Lenovo Y50-70 with an 860M if memory serves and it can operate Kinect v2. Unity shows about 35FPS but it still works.

    This reminds me, I had to test RoomAliveKit at work at some point and I had 2 other Alienware laptops perhaps a bit older and mine to operate 2 Kinect v2s. I remember that one Alienware laptop's USB was less compatible somehow with V2 and I removed it and instead used mine. RoomAlive had some calibration setup tools and they used to show a time metric , kinda like latency which showed rather low for my laptop and one Alienware and almost .5x slower on the other Alienware. Not sure what exactly it measured, but the laptop with the higher value was slower and kind of problematic for calibrating properly.

    Tuesday, September 22, 2020 9:20 AM