Could not connect to remote computer web deploy ERROR_DESTINATION_NOT_REACHABLE RRS feed

  • Question

  • User1176874198 posted

    I am trying to configure Web Deploy 3.5 on Windows Server 2008 R2 Standard with SP1 installed on it. When I try to validate connection using Visual Studio 2013 to publish a website it throws the following error.

    Could not connect to remote computer (computer name). Make sure Web Management Service is started.
    Learn more at http://go.microsoft.com/fwlink/?linkId=221672#ERROR_DESTINATION_NOT_REACHABLE

    enter image description here And I have tried everything found on all the forums as follows. And I have also done this before at a different job and every time it worked just fine.

    1. Made sure Web Management Service is started and set to Automatic
    2. Made sure that Web Deployment Agent Service is started and set to Automaticenter image description here
    3. Web Deploy 3.5 is installed
    4. I have tried installing different version of Web Deploy 3.5 too like the hosting versions.
    5. I checked if the firewall port for Web Management Service is listening on 8172 port (see image below).enter image description here
    6. The .Net Framework version I think that is not an issue.
    7. I have also made sure that during installation of Web Deploy 3.5 all the components are installed.
    8. When I click on the server node inside IIS and inside Web Management Service it also says Enable Remote connection
    9. I have also checked if users are delegated to publish on that website.
    10. I don't find any logs inside C:\inetpub\logs\wmsvc either.

    I cannot ping the 8172/webdeploy.axd url. Is there any other service that could be listening on some port that I am missing. Something is odd here. I cannot see any traffic going through even Fiddler from my local machine. I have tried to paste the .axd url on the server's internet explorer and it still cannot reach it and doesn't say anything.

    More Finding:

    I tried to connect using Telnet client and it says: Could not open connection to the host, on port 8172: Connect failed. Somewhere it is blocked and I have no idea where to look for.

    I didn't knew a forum existed but I posted this same question on Server Fault too.

    Friday, July 18, 2014 10:45 AM


  • User-736483138 posted

    To start with, let's make sure that port 8172 is actually bound. To do that, run netstat -aon | findstr :8172 from a command prompt. You should get something that looks like this:

    netstat -aon | findstr :8172
      TCP               LISTENING       4
      TCP    [::]:8172              [::]:0                 LISTENING       4

    If you get this, then nothing is listening on that port.

    C:\Users\terri_2.TD-LAPTOP>netstat -aon | findstr :8172


    The next thing will be to turn off Windows Firewall to ensure that it is not blocking the connection. You should turn it back on after testing. If you are able to connect with the firewall turned off, then it is an issue with the rule. If you are not able to connect with it turned off, then you will need to move to your perimeter firewall (either your router if this is your home network or your companies firewall) and have port 8172 opened there.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, July 18, 2014 12:14 PM