locked
.NET Framework 2.0 question RRS feed

  • Question

  • I appologize in advance if some of my  questions to the forum is a little out of place. I am not a programmer or developer, just a gamer, system builder, and network administrator of a home network.

    After installing .NET Framework 2.0, Direct X9.0c's Diagnostic shows that one of the two system.dll files is missing. The one that is listed belongs to 1.1, so logic dictates that it is the one for 2.0 that is missing. However it is in the .NET 2.0 folder! Some other symptoms are that logging into .NET sites must be done manually (being signed in with MSN Messenger does no good), and Auto-Scroll function for IntelliPoint 5.2 does not function. The computer this is on is a new install of all software, updated.

    This may be just a quess, but is .NET Framework 2.0 even nessasary for a gaming/entertainment system on a home network? Having researched all these issued in the knowlage base has revealed very little useful information (as is MS's forte), other than the three problems may be linked together, or only two of them. Any idea's and information would be greatly appreciated.

    Saturday, December 24, 2005 11:14 PM

Answers

  • Does your system have the regkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DirectX\ManagedDirectXVersion? This key is created by dx9.0/dx9a/dx9b ManagedDX. i removed it on my system and problem goes away. The key ManagedDirectXVersion key is not needed for dx9c mdx.
    Thursday, January 5, 2006 10:50 AM
  • well it is recommended, highly, to install .NET Framework as newer applications will be built on this (generally) and will be built in the next version of the MS OS - Vista (codenamed Longhorn)

    have you tried to "repair" the framework?

    technically it is not necessary to have the framework installed on a gaming/entertainment system but depends on the applications you are running.

    Generally games do not require the framework unless otherwise stated.

    hope it helps in some way!

    Sunday, December 25, 2005 12:38 AM

All replies

  • well it is recommended, highly, to install .NET Framework as newer applications will be built on this (generally) and will be built in the next version of the MS OS - Vista (codenamed Longhorn)

    have you tried to "repair" the framework?

    technically it is not necessary to have the framework installed on a gaming/entertainment system but depends on the applications you are running.

    Generally games do not require the framework unless otherwise stated.

    hope it helps in some way!

    Sunday, December 25, 2005 12:38 AM
  • I do agree with you, from the research I have done it appears that 2.0 will be competeing with Java, which is important to me as I like to have Microsoft software to compliment the XP operating system.

    Having said that, and uninstalling 2.0, DirectX Diagnostics no longer reports a missing system.dll. This is important to us gamers, as it seems that the latest Need for Speed will not install do to this install bug that 2.0 has with registering with DirectX 9.0. Just in case I will reinstall 2.0, and if DirectX 9.0c still reports the missing .dll a repair will be attempted. If it still shows up missing a bug report to Microsoft will be in order, no?

    Sunday, December 25, 2005 1:02 AM
  • What is the missing file? Tell me about this so I can check on my computers :-)

     

    I have .NET 1.1 and 2.0 installed, as well as directx 9.0c

    oh, as for competing with java - it has done so with ease ;-)

    Sunday, December 25, 2005 2:18 AM
  • It is System.dll, which should be version 2.00.20727.42(?). Don't really know for sure what listed version in Diag..X would be, but the file is actually located in C:/Windows/Microsoft.NET/Framework/v2.0.50727. The version listed in the properties is: version 2.0.20727.42. The system.dll that is properly installed is version 1.01.4322.2032, that is part of .NET 1.1, the file version in the properties of the file is: version 1.1.4322.2032  That file is actually located at C:/.../v1.1.432.

    Wonder how the programmers at Microsoft missed that one, is it a case of the left hand not knowning what the right hand is doing? Or maybe just a deadline that snuck up on them!

     

     

    FYI:  Repair option does no good at all!

    Sunday, December 25, 2005 3:00 AM
  • I do not recieve such error messages/warnings at all... :-)

    my system.dll is version 1.01.4322.2300, which is .NET 1.1 final retail version.

     

    tried removing .NET framework completly, then installing 1.1 then 2.0 on top? if you have done this, tried installing .NET 2.0 on its own?

     

    the .NET 2.0 System.dll is version 2.0.50727.42

    the .NET 1.1 System.dll is version 1.1.4322.2300

     

     

    Sunday, December 25, 2005 4:55 AM
  • Will attempt your idea of uninstalling all .Net, 1.1 w/hotfix and 2.0. Then installing just 2.0, but this doesn't sound like a good idea, as some of the software that XP has and some of the hardware based software that runs on my rig requires 1.1. Hopefully 2.0 is backwards compatable for these programs. Will see how it goes. If not I will just run with 1.1 until Microsoft comes out with, v2.1?

     

    Uninstalled all .Net Framework software, restarted, installed 1.1 w/hot fix. DirectX Diagnostic showed no problems. Restarted and installed 2.0 and DirectX Diagnostic still showed a missing system.dll. Back to square one. What is strange is that all the other computers on the network, including the server show only 1.1's system.dll. DirectX Diagnostic doesn't even show the 2.0 system.dll at all, missing or otherwise! The other computers are all prebuilt computers with onboard video chipsets. Don't know if this makes a difference at all, but something is different. Oh well, I'll wait to install 2.0 when a fix for the problem is released, as I am not the only one with this problem a fix is eminent (need a spell checker).

    By the way, no error messages come up while installing .NET, or have ever popped up. It is only DirectX Diagnostic that shows a missing system.dll, and recommends a reinstallation of DirectX. Since this is not a problem with DirectX, but with .NET, reinstalling DirectX does no good.

    Thanx

    Sunday, December 25, 2005 6:12 AM
  • interesting

    .NET 2.0 is some what backward compatible with some applications or majority of them I believe, I could be wrong.

    it is Directx 9.0c you have installed right?

    It's wierd as my system does not show this error at all, I have both frameworks installed and the system.dll uses v1.1

    Sunday, December 25, 2005 2:57 PM
  • Yes DirectX 9.0c is installed properly, have no problems at all, even with the Diagnostic claiming a system.dll is missing. Since no software that I run requires 2.0, I will just leave it off the system for now, but will leave it as active with Windows/Microsoft Update for future usage that may become nessasary.

    It seems that not everyone is having this problem, if it even is one. I have checked many other websites/forums/newsgroups, and this "missing" system.dll glitch (or what ever it is) associated with .NET 2.0 is affecting other computers as well. Certian games and programs that use DirectX will not install if Diagnostics shows any errors. Even if the "error" does not seem to affect anything. There must be a reason for this, just figuring out what the problem is, is the hard part. Seems that I am the only one (there must be others) that figured out it has something to do with .NET Framework 2.0.

    Hopefully when Microsoft gets back from the extended weekend, they can address this issue, that is the reason I came to this forum. When something doesn't work right, or in this case causes something else to report a problem, it is best to go to the source, no? Since both of the programs involved are Microsoft creations, they have the best chance of "fixing" what ever it is.

    Interesting, very interesting indeed, things like this I enjoy, it excercises the mind.

    Monday, December 26, 2005 12:13 AM
  • ok, try this test:

    if you have Virtual PC install a plain vanilla OS.

    Then install DirectX 9.0c

    Then install .NET framework 2.0

    Any directx errors?

    Once done, if any errors, uninstall .NET Framework 2.0, install 1.1. Any errors?

    Then install 2.0.

    Any errors?

    I know it is frustrating doing this believe me, I am also an IT technician but doing these things helps find the core problem!

    But personally for any systems i have built/installed - i have never had these problems with .NET 2.0

     

    Monday, December 26, 2005 2:26 AM
  • Frustrating? no, not really, I find this stuff fun. When all of my computers run perfectly, I get bored and start tweaking the systems, or modding the games installed. I don't ever mess with the OS, I am not a programmer. I leave those kind of things to Microsoft.

    Actually I have tried all possible installation combinations with 1.1 and 2.0. As soon as 2.0 is installed it shows a missing system.dll in DirectX Diagnostics. It makes no difference if 1.1 is installed or not, 2.0 causes Diagnostics to show a missing system.dll. Perhaps the problem is with DirectX, I do have all updates for DirectX, and Managed DirectX. As I stated earlier, this is a fresh install. I thought that would clear up the missing .dll in Diagnostics. It did, until I installed .NET Framework 2.0. I approach installing software the same way as installing hardware. Put in one item, check everything, then install the next item. This way you can norrow down any problems that may arrise. This is how I came to the conslusion that the problem was with .NET 2.0. That and the system.dll that is properly registered with DirectX is definately 1.1.

    Since there is no way to unistall DirectX 9.0c, and then reinstall it after .NET 2.0 is installed, that option is no good. Also, since others are experiancing the same "missing" file according to Diagnostics, and some are running 9.0a and b, it has to be something with .NET 2.0. Really, why is it attempting to register it's system.dll with DirectX anyway. Maybe the problem is that DirectX is looking in the wrong location for this system.dll. This idea still makes no sence since many other computers don't even show two system.dll files, only the one for .NET 1.1. All of my computers have both 1.1 and 2.0 installed.

    As you know there are so many different combinations of hardware and software out there that not everything is going to work the same on all setups. One thing that comes to mind is that the other computers have Java installed, this one does not. Need to check with the others I have come across that are experiancing this "problem" to double check. Even then that may not be the reason for this "missing" system.dll.

    One thing I have not tried is using the .NET Wizards. Really don't want to as the Wizard and Configuration found in the Administration Tools are for 1.1, and 1.1 doesn't seem to have any problems as of yet.

    Perhaps it has something to do with Windows Installer 3.1 trying to register .NET 2.0 with DirectX in some instances when 2.0 is installed. Since 2.0 is going to take the place of Java for XP, and probably Vista as well, that may be the issue.

    Really, .NET Framework 2.0 is not nessasary, as you stated, with my setup. Since I am not running Office, Visio, Vision, any database managment, or the like that would require .NET 2.0 it is probably a good idea to leave it off the system until someone figures this out. I think we are off to a good start for the professionals to take off from.

    Monday, December 26, 2005 3:13 AM
  • I enjoy doing this stuff to, for most people its a "pain" - good stuff :-)

     

    Well, I havent heard anyone complaning about this stuff before, there maybe other people as you say but its not on a "large" scale so I don't think that Microsoft would investigate much, im sure they would - there are a few MSFT guys here and hopefully one of them can take a look into this and work with you on this one.

    Sorry if I haven't been of much help, but I am just randomly shooting out some stuff I have in my mind!

    Good luck, I would like to know what the output is of this one to be honest, would be interesting to see where the problem lies!

     

    Take care, happy New Year

    Monday, December 26, 2005 5:34 AM
  • Thanx for all your input, it was a help in that we were able to norrow down the possibilites. I probably wouldn't have tried a few of the reinstall techniques if you hadn't made suggestions. In all reality, when unistalling 2.0 cleared up the problem of the missing .dll, I would have left it at that. Now that the weekend is over, it is back to work for all of us.

    Have a happy and healthy New Year.

    Monday, December 26, 2005 2:08 PM
  • I am receiving an error as well.  My computer keeps freezing up whenever I try to play my games.  I'm a gammer as well.  I get the following error:

    C:/ windows/microsoft.net.framework/v2.0.50727/vbc.exe and for the life of me I don't know what this is or how to fix it.  I know I'm tired of always having to restart my computer cause I'm froze up and crash again.

    Can you shed some light on this and how it can be repaird?  Your help will be greatly appreciated.

     

    Thanks

    Tuesday, December 27, 2005 4:49 PM
  • First you may want to run a DirectX Diagnostic to see what problems DirectX may have. You can do this by either typing dxdiag into the Run command off of the Start Menu, or by running System Information, Tools button, DirectX Diagnostic. System Information is located off of Start, All Programs, Accessories,System Tools. I am assuming that you are running XP with Service Pack 2.

    Run all tests in all tabs (you will need to do this on at least two networked computers, both running DirectX Diagnostics for the Network tab). Do all tests pass?

    Have you tried reinstalling .NET Framework 2.0 to see if that cures the problem? Only uninstall .NET Framework 2.0 if you do not have any programs or services that require it. As of now (at least until spring) most will use 1.1 w/hotfix. Do not remove the update from the Windows/Microsoft update as you may need this in the near future.

    A list of the games with this problem my help someone with the resources to test the issue. One thing you may wish to do is contact the companies that make whatever games you are running to see if they have a clue. I take it that the games with this problem are on-line or network games, no? I can't figure any stand alone games even using the .NET Framework.

    When you get this error, does Windows create an error report to send to Microsoft, and do you send it. Also, does Windows or any other programs you run have any problems that you notice. Do you have all critical updates and optional updates that apply to your computer needs? Have you checked for updates for your hardware (from whoever manufactered your hardware), and the software that you are running?

    There are a million possiblilities, but there are more gamers and computer users out there.

    Wednesday, December 28, 2005 8:02 AM
  • Does your system have the regkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DirectX\ManagedDirectXVersion? This key is created by dx9.0/dx9a/dx9b ManagedDX. i removed it on my system and problem goes away. The key ManagedDirectXVersion key is not needed for dx9c mdx.
    Thursday, January 5, 2006 10:50 AM
  • Yes, that key is in that location. Data is listed as 4.09.00.0901. The next entry is Version, and the data is 4.09.00.0904. By what you are saying the problem is with Managed DirectX, not DirectX itself!

    I will check the other computers to see if this entery in the Registery is the same, before I make any changes.

    Having checked the other computers, they do not show that entry in the registery. Having deleted the offending registery entry has indeed cleared up the problematic error message. Thank you so much, you are amazing! Just wondering, how did you go about finding this?

    Thursday, January 5, 2006 11:11 PM
  • well if you have that key - am I not correct in saying that you have also installed the DirectX SDK?

    DirectX SDK puts in some debugging files

     

    I have also just reformatted my computer this week and I can again confirm that the problem you are having - I have not been able to re-produce :)

    Friday, January 6, 2006 2:51 AM
  • The existense of that regkey indicates that at one time you must have installed DXSDK 9.0 (dx9b runtime) released in early 2003. It shipped with mdx versioned 4.09.00.0901. The series of dxsdk 2005 updates setup doesn't create that regkey.

    We believe a change in the .NET 2.0 runtime has caused a problem with existing versions of DxDiag.  The messages you see in DxDiag are in fact harmless.


    Friday, January 6, 2006 4:35 AM
  • I have the same problem on my computer when I ran the dxdiag and got the missing file "System.dll <file missing>

    I read all replys here and on other MS forums and there doesn't seem to be an answer.

    My computer has all updates installed including .NET 2.0.

    Friday, January 6, 2006 6:34 AM
  • I did not install DirectX Software Developers Kit, as far as I know. When I reformatted my computer, I installed Windows XP, then ran the Windows Update until no more critical updates were available. Then went through the optional updates and only installed the ones that applied to what was needed. Then re-ran Update for criticals, and applied them. Then installed the most recent software that applied to the hardware in this rig directly from the manufactures websites. After that ran Windows Update again, just to make sure that nothing was missed.

    Ran native system checking tools to verify no problems exsisted during the affore mentioned proccess. As soon as .NET Framework 2.0 was installed, the "missing" system.dll showed as "missing, need to reinstall DirectX to get the latest version".

    There are no listed debug files within DirectX Diagnostic, only Final Retail versions.

    Did you mean, can not confirm? :)

    Friday, January 6, 2006 10:21 AM
  • I figured that this message was harmless, it just bugs me. Since not every computer is showing it, something isn't registering properly. The question is, what and why (maybe where)?

    With you mentioning 2003, this brings to mind the idea that perhaps this has something to do with the version of XP I am starting with. It was purchaced before Service Pack 1. Perhaps this is the issue at hand? With the choice of ME or XP, and with XP being based on the NT platform, I opted for XP. Little did I know that most games today will only run on XP!

    Friday, January 6, 2006 10:36 AM
  •  SunCat wrote:

    I have the same problem on my computer when I ran the dxdiag and got the missing file "System.dll <file missing>

    I read all replys here and on other MS forums and there doesn't seem to be an answer.

    My computer has all updates installed including .NET 2.0.

    Please delete the regkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DirectX\ManagedDirectXVersion

    That regkey is created by dx9-dx9b when mdx is installed. The series of dxsdk 2005 updates setup doesn't create that regkey and is not needed. You may safely delete it and the problem will go away. Install the latest dx9c.

    Thanks.

    Moses

    Wednesday, January 11, 2006 6:21 PM
  • That is the answer to the "problem". Thanx Moses, I found your solution clears up the issue. Now to see if it works for those who are having game installation problems.

    Still have no idea if this applies to the version of XP I started with, since I did not install any Software Developers Kits at all. Perhaps it does, perhaps it doesn't. With a new hard drive in a couple of months, XP w/SP2 will be the starting point. If the problem does not appear again, then the issue will be with the original version of XP (pre-Service Pack). With that said, those of you who view this thread, spread the word that Moses has spoken , no biblical pun intended ;)

    Step by step instructions:

    Start menu; Run; type "regedit" (do include the quotes, please) in the dialog box (the little window with the blinking cursor); open (clicking on the little plus in a box [+] in front of...) HKEY_LOCAL_MACHINE; open SOFTWARE; open Microsoft; open DirectX. There should be a Managed DirectX Version and a DirectX version listed. Delete the offending Managed DirectX Version registery key, you can do this by right clicking on the entery and selecting delete.

    Hopefully that clears up any misunderstanding on how exactly to do what Moses describes! For those of you who are not comfortable with doing this, find someone that is and/or create a system restore point before begining.

    Friday, January 13, 2006 10:54 AM
  • thank you for your time n effort for finding this out ,it worked for me i had same error n it crashed allot of games. i did what you posted above n fixed the problem so keep up the good work people

    have a nice day all

     

    Friday, March 17, 2006 9:17 PM
  • Grrrr!!! I followed your instructuons Mercernary but I have no + to open DirectX so I don't have a Managed DirectX Verison that I can delete.

    I keep getting an error message about some kernal thing. Kernal_Stack_Inpage_Error

    Let me give it to you straight, I have NO idea what I need to do or what the problem could be. Please help me correct this thing! I read somewhere that the problem is with .Net Framwork 2.0 and was told to uninstall it but with everything I've been reading it doesn't seem like something I should do. I also have SP2 for XP.

    Any help would be greatly appreciated!



     

    Saturday, March 18, 2006 2:42 PM
  • Are you sure it is the same problem with Direct X and .NET? What causes you to get Kernal_Stack_Inpage_Error (what type of programs are running and what are they doing) is the first thing to look at.

    Will also need to know what info led you to Direct X and .NET as the programs not having proper reg logging.

    Saturday, March 18, 2006 6:57 PM
  • thanks for your fix! it cleared up the system.dll missing problem.
    Saturday, December 2, 2006 11:58 PM
  • thanks for your step by step directions - you were right, Moses did have the solution. with your directions my problem has been solved.
    Sunday, December 3, 2006 12:01 AM
  • I have been having a Directx 9.0c installation problem which sounds like this solution would ease my headache.  However, I'm not quite knowledgeable enough to know where to find this HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DirectX\ManagedDirectXVersion key you are referring to.  Is it in the sytem file? If so, how do I go about identifying the correct file to edit/delete.  Appreciate anyone who can put this in dummy talk for me.
    Tuesday, April 17, 2007 8:53 AM
  • I should probably explain my problem as it is a bit different than what was originally started in this thread, though I have been told to come here for help. 

    I have been able to play numerous games that require Directx 9.0c (which my dxdiag shows I have) but some games (Lionhead in particular games) claim I do not have the 9.0c.  My regedit does not show the ManagedDirectXVersion as some of you h ave stated yours does.  My version matches what I have seen to be the latest Directx 9.0c update (4.09.00.0904) yet for some reason the games I have attempted to play don't recognize it to be valid even though it is WHQL logoed and no problems show up in the dxdiag. 

    So I tried a few things that were suggested such as uninstalling directx using Dxeradicator and following the steps to change files from an older 9.0b directx updater to the 9.0c but that didn't work, and now it seems my system is a bit buggy with my netscape browser now not wanting to work. I'm clueless to what to try, I have thought about uninstalling service pack 2 but who knows what can of worms I may be opening then.

    Any suggestions would be greatly appreciated.
    Tuesday, April 17, 2007 10:10 AM
  • K first off did you search to see if you have any old drivers for your video card installed

     

    i find you should uninstall all drivers for video card befor you update to the newest one (also some times the newest drivers are buggy so you might want to stay one step back depending on the card you have)

     

    also what type of card due you have and what op system you are running and are you running 2 video cards on that machine and what board is it ?

     

    had same prob on brothers comp n way i fixed it was installing the newest driver befor any other one due to it (went to the older driver all the time it would say it was running the new one but it wasnt running it LoL

     

    but i will check my email later to see if you reply back to this when i get home in a few hrs

    Saturday, April 21, 2007 12:15 AM
  • delteing the Key is only a cover up for me i elet the key dxdiag says all is fine but games still restart my PC!!! i tryed DX happy unistall but dont want to pay that much!!! although there maybe away............ if anyone has a zipped Direct X 9c file share with us it might has the system.dll in it?? or on the windows Disc??? hope anyone could help me is there away??
    Monday, June 4, 2007 11:38 AM
  • Funny you should say that a couple months ago had the same prob

     

    was the video card it sucked to much power from the power supplie n the system detects it n shuts down comp to protect it

     

    now you can due a couple things till you get a new power supplie

     

    one turn every thing down in options of the game you are trying to play (this will let you play from 1 hr to 6 hrs max) also turn down options in card area down too

     

    also if you still need help dew to Iam a die hard gamer too is look up www.goteamspeak.com down load client and then due a search for term/hals freelancer n pass is term/hals

     

    now any one can use this for help in game related stuff there is a bunch of use die hard there that will help you out not a prob

    Monday, June 4, 2007 6:31 PM
  • In response to Revis:

     

    The key is referring to a component stored in the windows registry, in order to access the windows registry simply follow these instructions:

     

    Click the start Button on your taskbar, then click on Run, in the Run window that appears simply type regedit and click OK, now a double paned window should appear called the Registry Editor.

     

    The registry editor is a place where windows and application setting are commonly stored. The registry editor has a similar structure to Windows Explorer, where folders represent registry keys and items. Assuming you are acquainted with Windows Explorer's folder structure, you should not have a problem finding the required registry key.

     

    I hope you found this mini tutorial helpful!

     

    Regards

     

    Romesh Abeyawardena

     

    Student Software Developer (MCAD Proffesional)

    Sunday, February 17, 2008 2:03 PM
  • I follwed this up until I couldn't find 'registry key' !?

     

    Wednesday, February 20, 2008 7:40 PM