none
The remote server returned an unexpected response: (413) Request Entity Too Large. RRS feed

  • Question

  • Hi Guys,

     I am new to site and whilst I have connected to web services, i am in no way an expert and could be doing with help on a regular basis.


    Anyway, as the title suggest, I am receiving a  message size issue. I have the setting set to the max possible, which I have set in the past to resolve this problem.

    Below are my client bindings and further down I have provided the service side config. The service side had to use wsHTTP, whilst client is using basicHTTP. It appears to be connecting and transferring to a point, however as soon as any data at all is passed it fails.

    any help appreciated.

    Client Side 

            <basicHttpBinding>
              <binding name="BasicHttpBinding_ILoader" receiveTimeout="00:15:00" sendTimeout="00:15:00" maxReceivedMessageSize="2147483647" maxBufferSize="2147483647" maxBufferPoolSize="2147483647">
                <readerQuotas maxDepth="32" maxArrayLength="2147483647" maxStringContentLength="2147483647"/>
                <security mode="Transport"/>
              </binding>

            </basicHttpBinding>

    Server Side

       <wsHttpBinding>
            <binding name="SSLWSTransport"
                receiveTimeout="00:15:00" sendTimeout="00:15:00"
                maxReceivedMessageSize="2147483647"
                maxBufferPoolSize="2147483647">
              <readerQuotas maxDepth="32"
                    maxArrayLength="2147483647"
                    maxStringContentLength="2147483647" />
              <security mode="Transport">
              </security>
            </binding>
          </wsHttpBinding>

    Friday, August 18, 2017 7:31 AM

All replies