locked
SQL Server Configuration Manager - Protocol Name is blank RRS feed

  • Question

  • When I run SQL Server Configuration Manager (2008) and click on SQL Server Network Configuration and then Protocols for SQL, the right side of the screen shows the protocol icons and their status, but the names (TCP/IP, Shared Memory, Named Pipes, etc) are not there. Can someone tell me how to get the names to display again? They used to show up. A thought is that I installed XP SP3 and that made them go away, but I can't prove that.
    Monday, April 26, 2010 12:54 AM

Answers

  • Hi bcousins,

    Based on my testing, the following file in your computer might be missing or corrupt:
    %Program Files (x86)%\Microsoft SQL Server\100\Tools\Binn\Resources\1033\sqlcm.xml

    This file contains some of the string resources required by SQL Server Configuration Manager(SSCM). Since this file is missing or corrupt, SSCM will not be running properly.

    In order to solve this issue, please copy this file from another computer that has SQL Server installed.

    If anything is unclear, please let me know.

    Thanks,
    Tom Li

    • Proposed as answer by jandho Friday, May 25, 2012 10:19 AM
    • Marked as answer by Kalman TothEditor Saturday, September 29, 2012 11:12 PM
    Wednesday, April 28, 2010 3:44 AM
  • Hi bcousins,

    There is several reasons why you cannot see “Protocol Name”:

    • While the width of column “Protocol Name” is very small, there is insufficient space to display name of protocol.
    • Related keys in registry is corrupt
    • Components of SQL Server Configuration Manager(SSCM) is corrupt

    In order to solve this issue, please follow the steps below:

    1. Open SSCM and double-click the vertical line between the headers of column “Protocol Name” and column “Status”
    2. Open “Registry Editor”, go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL10.MSSQLSERVER \MSSQLServer\SuperSocketNetLib and check the keys referencing to the protocols
      SSCM reads configuration from these keys, while these keys is corrupt, you will encounter errors.
    3. Reinstall the SSCM

    If anything is unclear, please let me know.

    Thanks,
    Tom Li

    Tuesday, April 27, 2010 9:41 AM

All replies

  • Please cross check.  I am running the SQL 2008 on Windows XP and I am getting the TCP/IP, Shared Memory, Named Pipes, etc under Protocols for MSSQLServer instance.
    Sivaprasad S http://sivasql.blogspot.com Please click the Mark as Answer button if a post solves your problem!
    Tuesday, April 27, 2010 3:54 AM
  • If you have checked everything and if it still doesnt show up , then its really strange. Have you rebooted the machine after the xp sp3 patches ?
    Thanks, Leks
    Tuesday, April 27, 2010 5:36 AM
    Answerer
  • Hi bcousins,

    There is several reasons why you cannot see “Protocol Name”:

    • While the width of column “Protocol Name” is very small, there is insufficient space to display name of protocol.
    • Related keys in registry is corrupt
    • Components of SQL Server Configuration Manager(SSCM) is corrupt

    In order to solve this issue, please follow the steps below:

    1. Open SSCM and double-click the vertical line between the headers of column “Protocol Name” and column “Status”
    2. Open “Registry Editor”, go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL10.MSSQLSERVER \MSSQLServer\SuperSocketNetLib and check the keys referencing to the protocols
      SSCM reads configuration from these keys, while these keys is corrupt, you will encounter errors.
    3. Reinstall the SSCM

    If anything is unclear, please let me know.

    Thanks,
    Tom Li

    Tuesday, April 27, 2010 9:41 AM
  • Yes. I have rebooted several times. They still do not show up. I really can't say it was SP3 since I installed that about a month ago. Just have not run SSCM for a while.

    Tuesday, April 27, 2010 6:31 PM
  • Checked the listview column widths. They are plenty wide to show the protocol name.

    Went into regedit. The keys are there with the display names set. Ran regmon and started sscm and saw regmon log that the keys were read successfully.

    In SSCM, you can right-click and Export List. Here is what gets exported on my system:
    Name Order Enabled
     1 Enabled
     2 Enabled
     3 Enabled
      Disabled

    Nothing is output under Name. Also seems like export is not exporting a "Status" heading for the last column.

    Surely there is a better way to fix this besides reinstalling. That is just guessing.

    Anybody got any other ideas? Seems like a bug to me.

    Billy C.

     

    Tuesday, April 27, 2010 6:40 PM
  • Hi bcousins,

    Based on my testing, the following file in your computer might be missing or corrupt:
    %Program Files (x86)%\Microsoft SQL Server\100\Tools\Binn\Resources\1033\sqlcm.xml

    This file contains some of the string resources required by SQL Server Configuration Manager(SSCM). Since this file is missing or corrupt, SSCM will not be running properly.

    In order to solve this issue, please copy this file from another computer that has SQL Server installed.

    If anything is unclear, please let me know.

    Thanks,
    Tom Li

    • Proposed as answer by jandho Friday, May 25, 2012 10:19 AM
    • Marked as answer by Kalman TothEditor Saturday, September 29, 2012 11:12 PM
    Wednesday, April 28, 2010 3:44 AM
  • Nice input Tom , thats excellent . I can change the name "namedpipes" or "tcp/ip" to anyother in the xml and i am seeing the changes in SSCM .
    Thanks, Leks
    Wednesday, April 28, 2010 4:05 AM
    Answerer
  • Thanks for the help Tom. I diff'ed my file against the same file on our server and they are identical. The server works fine and shows the protocol names. I tried copying the file anyway, but that did not fix the bug.

    If you have any other ideas to try, please let me know.

    Billy C.

    Thursday, April 29, 2010 6:32 AM
  • Hi bcousins

    Did you find an answer to this issue? I have the same issue as you have described and the solutions outlined have not helped.

    Rob

    Monday, August 30, 2010 2:25 PM
  • Thursday, September 16, 2010 5:32 AM
    Answerer
  • The @@version

    Microsoft SQL Server 2008 (RTM) - 10.0.1600.22 (Intel X86)   Jul  9 2008 14:43:34   Copyright (c) 1988-2008 Microsoft Corporation  Developer Edition on Windows NT 5.2 <X86> (Build 3790: Service Pack 2)

    I have since removed the database as I could not get it to work and installed on another machine.

    Thanks

    Rob

    Thursday, September 16, 2010 12:43 PM
  • Thursday, September 16, 2010 1:08 PM
    Answerer
  • Thanks when I initially logged this problem I had installed the latest service pack, but that didn't fix the issue. See bcousins comments above as my issue followed his.  I was just asking him if he resolved the problem but gave up on my machine and removed SQL Server.
    Friday, September 17, 2010 10:27 AM
  • I've faced the same issue , after replaced the sqlcm.xml from the installation folder it works fine.

    Thanks Tom , your solution works fine.

     

    Cheers,

    P.Veera Vinod.


     Senior Solution Engineer, Quantum Secure Inc.
    Friday, February 11, 2011 3:31 PM
  • Hi,

    We had the same problem on one of our developer pc's. Copying sqlcm.xml as you suggested worked for us.

    Thank you


    Jan D'Hondt - Database and .NET development

    Friday, May 25, 2012 10:20 AM