locked
Workflow doesn't deploy normally RRS feed

  • Question

  • Hi,

    I've recently begun writing visual studio workflows that operate across different sharepoint sites and subsites.  i.e. I have a workflow that triggers from one custom list on one site or subsite that writes data onto another site or subsite.  I'm not certain that this triggers this problem, but it's just begun happening after many successful uneventful workflow deployments.

    It seems to work ok given these features:

    When I intially deploy the workflow I can't see any workflows deployed on the list. i.e. hover over an item in the list, get the flyout, there is no option for workflows.  I have to go into the list workflow settings, select the workflow from the templates, give it a name and hit ok.  Then I'm tending to go into Remove a workflow, see my originally deployed workflow, and go to my manually assigned workflow and not allow it any new instances. 

    After the above process I can see the workflows from the fly-out on a list item, and I then can see my deployed workflow...but it won't fire.

    If I then re-deploy the workflow it will fire and act normally.

    Does anyone know where I can find more information about this?

    Best regards,

    S'

    Tuesday, June 1, 2010 3:21 PM

Answers

  • Hi Seven,

    Thanks for the posts...but these don't seem to address this circumstance?  I actually finished the last of these last week, but it would still be helpful to understand what's causing the auto-association to not work normally.

    Best regards,

    S'

    • Marked as answer by Seven M Friday, June 11, 2010 6:53 AM
    Friday, June 4, 2010 2:37 PM

All replies

  • I think you may be misunderstanding what, allowing new instances means.  If you check the option to not allow any new instances, this will make it such that your workflow will not be able to create any new instances.  Thus, when a new item is added, the workflow will not fire because it is not allowed to create any new instances.

    Allowing the workflow to have new instances will solve your problem.


    Kevin

    Tuesday, June 1, 2010 8:10 PM
  • Hi Kevin,

    Thanks for the reply...

    I'm deploying the workflow...first workflow for the list.  It doesn't show until I manually assign one from the templates.  Since this reveals my initial deployment of the workflow I then have two.  Since I only want one instance I mark my manually created reference as no new instances so it doesn't fire....

    Best regards,

    S'

     

    Tuesday, June 1, 2010 8:28 PM
  • Hmm, I misunderstood than.

    So your originally deployed workflow is hidden until a new one is manually added.

     

    I'm assuming you created a workflow feature which is activated at the site collection level, then you have some code that attaches it to the correct list.

    Could you post the snippet that attachs the workflow to the list?  It might be as simple as a certain property was not updated.


    Kevin

    Tuesday, June 1, 2010 8:32 PM
  • Hi Kevin,

    I'm leaving the check box in vs checked...it's supposed to automatically attach it to the list...has always worked before...sort of the crux of my problem.

    I'm sort of assuming that having it split between two sites or sub sites is goofing this up in the deployment process?  That's sort of what I'm trying to get a handle on.  Was hoping that someone else was experiencing this and had found an article that explained this nuance of the deployment process, haven't turned one up yet.

    Best regards,

    S'

    Tuesday, June 1, 2010 9:06 PM
  • Hi,

     

    For deploying the workflow, please refer to:

    http://msdn.microsoft.com/en-us/library/cc627285(office.12).aspx

    http://weblog.vb-tech.com/nick/archive/2006/09/04/1760.aspx

     

    Hope it is helpful!


    Seven
    Friday, June 4, 2010 8:29 AM
  • Hi Seven,

    Thanks for the posts...but these don't seem to address this circumstance?  I actually finished the last of these last week, but it would still be helpful to understand what's causing the auto-association to not work normally.

    Best regards,

    S'

    • Marked as answer by Seven M Friday, June 11, 2010 6:53 AM
    Friday, June 4, 2010 2:37 PM