locked
My Silverlight application not working on some computers RRS feed

  • Question

  • Normal 0 false false false EN-US X-NONE X-NONE MicrosoftInternetExplorer4 /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin;}

    We have put up a silverlight 2.0  test application on

    http://spinelreview.com/silverlight.aspx

    it works on some computers and does not work on others ; it shows download silverlight logo ; although silverlight is installed

     

    The strange thing is other silverlight applications/web sites show up fine ; only our application is giving this problem

    We have already set all correct MIME types and made application High trust (in case required)

    All systems are using XP sp2 with IE or FireFox

     

    Any suggestions

     

    Thank You

     

    prashant

    Tuesday, October 14, 2008 7:37 AM

Answers

  •  

    Hi,

    It is due to version Conflict.

    Remove 2.31005.0 version at first and then install the version for which it is redirecting you..

     

    Tuesday, October 14, 2008 9:07 AM

All replies

  • Hi,

    When it is asking to install you can check which version is installed and which version it is asking to install.

    Check in all same version message is coming or what.

    it may be due to different versions installed in each machine..

    Try to install same version of silverlight in each machine..

    Tuesday, October 14, 2008 8:00 AM
  •  Hi

    whereever it is working has silverlight 2.0.30523.8 version (we have developed it in same version SDK)

    where as the where it is NOT working is having 2.31005.0 plugin installed

    so where what is the way out? where can we find latest SDK

     

    Thanks

    Prashant

    Tuesday, October 14, 2008 8:51 AM
  •  

    Hi,

    It is due to version Conflict.

    Remove 2.31005.0 version at first and then install the version for which it is redirecting you..

     

    Tuesday, October 14, 2008 9:07 AM
  • Hi

    Since it is working in some computers, it means that the server is well configured.

    The problem you have is that there is not only one version of silverlight. e.g. Silverlight 1, silverlight release candidate 2, etc.

    Each one of these releases has its own silverlight player.

    Make sure all the silverlight players of every computer are the same, and remember to remove old silverlight versions before you install the onw that you need.

     

    Regards

    Mark as answer if this post answered your question

    Thursday, October 16, 2008 1:24 PM