none
VS 2015 Community Update 2 is a mess

    Question

  • Hello,

    I have updated my VS to the new Update 2 (also have installed the free Xamarin), then all my projects with xaml results a exception:

    System.TypeLoadException
    Method 'GetStylePropertyTargetType' in type 'Microsoft.VisualStudio.DesignTools.WindowsXamlDesigner.Metadata.WindowsUIXamlPlatformMetadata' from assembly 'Microsoft.VisualStudio.DesignTools.UniversalXamlDesigner, Version=14.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'

    Well, some people here avec same problem with XAML designer.

    So, I tried to repair... nothing change.

    Now, I have uninstalled Visual Studio and reinstalled it with Update 2 installer on website and the results it's worst! 

    All my projets are now not compatible anymore: VisualStudio say I must install Universal Windows platform (normally the installer had to do it himself ...), so now when I create a new Universal App, I can't and also when I want to open a existing project because UWP component for him not exist.

    I have repaired, reinstalled manually several times... some time installer said sdk tools 1.3 (10586) installed and sometimes sdk tools  1.2 (10240).

    When visual studio stuck this way, I think the only solution is to reinstall Windows...


    • Edited by cgiu Sunday, April 03, 2016 3:01 PM say hello :)
    Sunday, April 03, 2016 3:01 PM

Answers

  • This is how I solved it.

    Problem:
    "Tools (1.3) and Windows 10 SDK (10.0.10586)" is not installed by the Visual Studio installer.

    Procedure:
    Found the msi installer for this package where Visual Studio installer extracts it.
    Tried running it. Says it needs .NET Framework.

    Solution:
    Installed ".NET Framework 3.5 (includes .NET 2.0 and 3.0)" via "Turn Windows features on or off".
    Used Visual Studio installer from control panel which now is able to add the tools.

    /André

    Tuesday, April 05, 2016 11:19 AM

All replies