none
Create AdminDeployment .xml with /CreateAdminFile switch

    Question

  • I've read the documentation here concerning the creation and editing of the Admin Deployment .xml file for unattended installs of Visual Studio 2015 https://msdn.microsoft.com/en-us/library/ee225237.aspx

    I'm wanting to create a new xml from scratch yet I am unable to create it following the directions from the above link to run the switch /CreateAdminFile  <file location>.

    I feel i may be missing something incredibly simple but the syntax for my command is as follows

    vs_professional.exe /createadminfile C:\users\USER\Desktop\AdminDeployment.xml

    I've tried a number of variaitons but I want to find what the default xml file is? Is there a default file that's created or are you just supposed to create it from scratch?

    Thanks

    Tuesday, July 26, 2016 10:46 PM

All replies

  • Hi my friend,

    Thank you for your post.

    I also try to create this file, here is my cmd:

    And it works.

    Could you please tell us the error information when you type the cmd?

    Besides, if you download the ISO image,  after you unzip the file, it contains the AdminDeployment .xml.

    So you could find the AdminDeployment .xml  file and modify it according to your re, then do the unattended installation.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Wednesday, July 27, 2016 8:05 AM
    Moderator
  • Thank you for your help. I still am not having luck though creating the admin file. When I run the line of code identical in form to yours and the one i posted above, I'll get a visual studio logo pop up in the middle of the screen for a number of seconds and then no xml is created. I do have one existing that I'll just tweak at this point I believe, unless you have another idea? Thank you for your help.

    Edit: I get no error info from either a window or in the cmd prompt

    Thursday, July 28, 2016 5:07 PM
  • Hi bergermeister843,

    Thanks for your update.

    Do you have a VS iso image on your machine? in this situation, if you couldn't use the cmd to create a AdminDeployment .xml  file, you may find this type file in the ISO, and them just modify it to deside which packages you would like to install.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Monday, August 01, 2016 2:19 AM
    Moderator
  • I'm having the EXACT same problem as berger is having... 

    I downloaded the VS Professional 2015 from the MS Volume License site. Open the ISO and mount it on my system. Every time I run:

    D:\vs_professional.exe /CreateAdminFile C:\Users\<Username>\Desktop 

    I'm greeted with the VS Professional 2015 splash screen and after a few seconds it goes away. No XML file is created. 

    I also searched the ISO that is mounted for AdminDeployment.xml and there is no file in the ISO with it. 

    Am I doing something wrong? Am I getting a bad copy of the program from the VL site? I don't understand why it's not working. 


    Thanks... Frank

    Friday, September 02, 2016 7:30 PM
  • Add the file name at the end of the command line as follows

    D:\vs_professional.exe /CreateAdminFile C:\Users\<Username>\Desktop\AdminDeployment.xml

    Thursday, March 23, 2017 6:36 PM