locked
Membership Tables in ASP.NET RRS feed

  • Question

  • User-559866590 posted

    Hello,

    I have recently altered my program so that when a user registers their details on the site, their email and password will be saved to the membership tables. I done this without the built in login controls but I am having an issue where the email is saved under the UserName column in the Users table instead of the Email column in the Memberships table. I would like them both in the same table so that it would be easier to query the data.

    Has anyone got any suggestions of how this could be resolved?

    Sunday, March 8, 2015 4:49 PM

Answers

  • User2008642861 posted

    Hi JonnyH91,

    From your post, I suppose that your website use the E-mail as account name, so it store under UserName, Do you ask user to get their UserName? Or you could creat a custom Membership. For more information, you could refer to the below link.

    https://msdn.microsoft.com/en-us/library/ms366730(v=vs.100).aspx

    If you have any other concern about it, please feel free to let me know.

    Best regards,

    Archer

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, March 9, 2015 10:17 PM

All replies

  • User2008642861 posted

    Hi JonnyH91,

    From your post, I suppose that your website use the E-mail as account name, so it store under UserName, Do you ask user to get their UserName? Or you could creat a custom Membership. For more information, you could refer to the below link.

    https://msdn.microsoft.com/en-us/library/ms366730(v=vs.100).aspx

    If you have any other concern about it, please feel free to let me know.

    Best regards,

    Archer

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, March 9, 2015 10:17 PM
  • User-1506965535 posted

    but I am having an issue where the email is saved under the UserName column in the Users table instead of the Email column in the Memberships table.

    Hi Johny,

    Can you check your table, whether the data is getting inserted properly or not. There might be some codebehind issue i guess. Also post the code or link to know us better what is happening.

    Saturday, March 14, 2015 5:56 AM